Add patch from upstream maintainer to avoid nonportable assumption in
test code.
This commit is contained in:
parent
69add15dd2
commit
a5db90440c
3 changed files with 22 additions and 3 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.59 2013/05/31 12:40:56 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.60 2013/06/07 13:05:42 gdt Exp $
|
||||
|
||||
.include "../../devel/scmgit/Makefile.common"
|
||||
|
||||
PKGNAME= scmgit-base-${GIT_VERSION}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
COMMENT= GIT Tree History Storage Tool (base package)
|
||||
|
||||
CONFLICTS+= git<4.9.5nb1 # misc/git
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.71 2013/05/15 11:16:29 adam Exp $
|
||||
$NetBSD: distinfo,v 1.72 2013/06/07 13:05:42 gdt Exp $
|
||||
|
||||
SHA1 (git-1.8.2.3.tar.gz) = 2831f7deec472db4d0d0cdffb4d82d91cecdf295
|
||||
RMD160 (git-1.8.2.3.tar.gz) = 47c2f6843436b87a38eeba14b05beaff8a5c7e76
|
||||
|
@ -11,3 +11,4 @@ SHA1 (patch-ag) = 4f0b9a5745203ea7ef369c8272b3ea7c644762f0
|
|||
SHA1 (patch-ah) = f22a2160631fb624e9e20616c68ad1a4aa2bebc7
|
||||
SHA1 (patch-ai) = 56b63d4790a11f5eb128186ad5efdd1bcf102f2e
|
||||
SHA1 (patch-config.mak.uname) = e7fa7a91d4d9dd6793d752b1833f97fcaea236b1
|
||||
SHA1 (patch-wrapper.c) = d8252c63cca9a134fca3f8f6f28663f563c7b4bc
|
||||
|
|
18
devel/scmgit-base/patches/patch-wrapper.c
Normal file
18
devel/scmgit-base/patches/patch-wrapper.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-wrapper.c,v 1.1 2013/06/07 13:05:42 gdt Exp $
|
||||
|
||||
git's wrapper around mkstemp assumes that the libc function will not
|
||||
modify the argument when the call fails. This causes one of git's
|
||||
tests to fail. This patch is from Junio C. Hamano, and will likely be
|
||||
included in future versions of git.
|
||||
|
||||
--- wrapper.c.orig 2012-11-26 03:18:01.000000000 +0000
|
||||
+++ wrapper.c
|
||||
@@ -229,7 +229,7 @@ int xmkstemp(char *template)
|
||||
int saved_errno = errno;
|
||||
const char *nonrelative_template;
|
||||
|
||||
- if (!template[0])
|
||||
+ if (strlen(template) != strlen(origtemplate))
|
||||
template = origtemplate;
|
||||
|
||||
nonrelative_template = absolute_path(template);
|
Loading…
Reference in a new issue