Obey to PKG_SYSCONFDIR. Use bsd.pkg.install.mk framework to deal
with configuration file. Install example configuration file in the canonical pkgsrc directory. Bump PKGREVISION.
This commit is contained in:
parent
ef35a4ae37
commit
a5e87f43d9
5 changed files with 54 additions and 7 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.14 2003/08/03 00:46:22 seb Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2003/08/03 01:01:32 seb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pinfo-0.6.1
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://zeus.polsl.gliwice.pl/~pborys/stable-version/
|
||||
|
||||
|
@ -15,14 +15,20 @@ BUILD_USES_MSGFMT= yes
|
|||
USE_BUILDLINK2= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGINSTALL= yes
|
||||
|
||||
USE_NEW_TEXINFO= YES
|
||||
INFO_FILES= pinfo.info
|
||||
|
||||
CPPFLAGS= -DDFLT_INFOPATH='\"/usr/share/info:${X11BASE}/info:${LOCALBASE}/info:/usr/local/info\"'
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
|
||||
CONF_FILES= ${PREFIX}/share/examples/pinfo/pinforc ${PKG_SYSCONFDIR}/pinforc
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/src/pinforc ${PREFIX}/share/examples/
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/pinfo
|
||||
${INSTALL_DATA} ${WRKSRC}/src/pinforc ${PREFIX}/share/examples/pinfo
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2003/08/03 00:46:22 seb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2003/08/03 01:01:32 seb Exp $
|
||||
bin/pinfo
|
||||
info/pinfo.info
|
||||
man/man1/pinfo.1
|
||||
|
@ -7,5 +7,5 @@ ${PKGLOCALEDIR}/locale/de/LC_MESSAGES/pinfo.mo
|
|||
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/pinfo.mo
|
||||
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/pinfo.mo
|
||||
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/pinfo.mo
|
||||
share/examples/pinforc
|
||||
@exec if [ ! -f %D/etc/pinforc ]; then cp %D/share/examples/pinforc %D/etc/; fi
|
||||
share/examples/pinfo/pinforc
|
||||
@dirrm share/examples/pinfo
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.3 2001/07/02 23:06:55 fredb Exp $
|
||||
$NetBSD: distinfo,v 1.4 2003/08/03 01:01:32 seb Exp $
|
||||
|
||||
SHA1 (pinfo-0.6.1.tar.gz) = f0444f4eb3bad4f10ad96c971d7bcd553b567ef4
|
||||
Size (pinfo-0.6.1.tar.gz) = 271015 bytes
|
||||
SHA1 (patch-aa) = e2d7d0e8ccbe5db276fb736d22682bb8f719eb98
|
||||
SHA1 (patch-ab) = f089af56a969af630e2cb886aa8fb40be055eca7
|
||||
SHA1 (patch-ac) = 7dbddcf81e9ad6ff00dadd8a93cf2c160992ce75
|
||||
SHA1 (patch-ad) = fe53fc7178c9376c6858d6d1531585f03bd98ddf
|
||||
SHA1 (patch-ae) = 2186095dee7aafeca9b1933cc657fa07b775fb1e
|
||||
|
|
20
misc/pinfo/patches/patch-ad
Normal file
20
misc/pinfo/patches/patch-ad
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ad,v 1.1 2003/08/03 01:01:33 seb Exp $
|
||||
|
||||
--- src/Makefile.am.orig 2000-07-06 10:00:19.000000000 +0000
|
||||
+++ src/Makefile.am
|
||||
@@ -88,15 +88,5 @@ else
|
||||
sigblock.o: $(pinfo_SIGBLOCK)
|
||||
endif
|
||||
|
||||
-install-data-local:
|
||||
- if [ ! -f $(DESTDIR)$(sysconfdir)/pinforc ] ; then \
|
||||
- if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
|
||||
- $(INSTALL) -d $(DESTDIR)$(sysconfdir); \
|
||||
- fi; \
|
||||
- $(INSTALL) -m 644 $(srcdir)/pinforc $(DESTDIR)$(sysconfdir) ; \
|
||||
- else \
|
||||
- echo "WARNING! Old pinforc detected. I'm not installing the new file"; \
|
||||
- fi
|
||||
-
|
||||
EXTRA_DIST = $(pinfo_READLINE) $(pinfo_SNPRINTF) $(pinfo_SIGBLOCK)
|
||||
|
19
misc/pinfo/patches/patch-ae
Normal file
19
misc/pinfo/patches/patch-ae
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ae,v 1.1 2003/08/03 01:01:33 seb Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2000-10-05 22:42:37.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -334,14 +334,6 @@ maintainer-clean-generic clean mostlycle
|
||||
@HAVE_SIGBLOCK_FALSE@sigblock.o: $(pinfo_SIGBLOCK)
|
||||
|
||||
install-data-local:
|
||||
- if [ ! -f $(DESTDIR)$(sysconfdir)/pinforc ] ; then \
|
||||
- if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
|
||||
- $(INSTALL) -d $(DESTDIR)$(sysconfdir); \
|
||||
- fi; \
|
||||
- $(INSTALL) -m 644 $(srcdir)/pinforc $(DESTDIR)$(sysconfdir) ; \
|
||||
- else \
|
||||
- echo "WARNING! Old pinforc detected. I'm not installing the new file"; \
|
||||
- fi
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
Loading…
Reference in a new issue