Buildlinkify w. readline support and patch so all NetBSD instances of

readline will work.
This commit is contained in:
jmc 2003-05-12 21:27:10 +00:00
parent 2817eebc92
commit a5eab2dc75
3 changed files with 23 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/05/05 10:57:05 mjl Exp $
# $NetBSD: Makefile,v 1.2 2003/05/12 21:27:10 jmc Exp $
#
VERS= 0.43b
@ -14,6 +14,8 @@ COMMENT= ELF format exploration shell
WRKSRC= ${WRKDIR}/elfsh_0.43
USE_BUILDLINK2= yes
# XXX This package should be converted to use libtool
do-install:
@ -25,4 +27,5 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/README ${PREFIX}/share/doc/elfsh/README
${INSTALL_DATA} ${WRKSRC}/doc/libelfsh-ref.txt ${PREFIX}/share/doc/elfsh/libelfsh-ref.txt
.include "../../devel/readline/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2003/05/05 10:57:05 mjl Exp $
$NetBSD: distinfo,v 1.2 2003/05/12 21:27:10 jmc Exp $
SHA1 (elfsh-0.43b-portable.tgz) = a4ccc9e8727409f65a3b9571455d7e2fea56e55b
Size (elfsh-0.43b-portable.tgz) = 101978 bytes
SHA1 (patch-aa) = 32c31367c920dde165a79464c984bfdb346598b5
SHA1 (patch-ab) = 4d9e36b5f163c582d636256afff5b9f9460264eb
SHA1 (patch-ac) = 76b9926e1e3705be731784859304a168f211cf91

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ac,v 1.1 2003/05/12 21:27:11 jmc Exp $
--- elfsh/include/elfsh.h.orig Mon May 12 15:59:28 2003
+++ elfsh/include/elfsh.h Mon May 12 16:00:27 2003
@@ -15,7 +15,12 @@
#if defined(__NetBSD__)
+#include <sys/param.h>
+#if __NetBSD_Version__ < 106000000
#include <readline.h>
+#else
+#include <readline/readline.h>
+#endif
#elif defined(__linux__) || defined(__FreeBSD__) | defined(sun)
#include <readline/readline.h>
#endif