Update chat/ejabberd to 16.08.
ejabberd 16.08 MUC - New MUC/Sub support - Add 'allow_subscription' room configuration option for MUC/Sub OAuth and ReST API - Add OAUTH SQL backend - New special scope: ejabberd:admin and ejabberd:user, to more easily grant group of privileges - Add DB backend support for ejabberd_oauth - Added ejabberdctl commands to manage OAuth tokens: oauth_issue_token, oauth_list_tokens, oauth_list_scopes, oauth_revoke_token - Simplified OAuth form: username and password merged into JID field - User configurable validity duration for tokens on OAuth token generation form - Add support for sending back missing scope error to API ReST command calls - Oauth: several minor fixes - Support oauth password grant type, to generate token programmatically Elixir support - Update supported Elixir version to 1.2 and 1.3. - Support installation of Elixir contributions with external module command line tool. PubSub - Fix use of like parameter in sql pubsub's requests - Fix node configuration change with sql backends - Fix send_last_items duplication with multi-plugin setup MAM - Always limit result set page size - Use hooks instead of direct calls API - Add support for checking access rules conformance for commands - Add support for rich error reporting for API - Add support for sending back missing scope error to API ReST command calls - Fix handling of complex values as arguments in http_api - Improve error handling Other improvements - External Component Connection Hooks - Fix compilation issues on R19 - Support for OpenSSL 1.1 - Make access rules in ejabberd_web_admin configurable - Make modules loading in a dependent order (#1191) - Make s2s stats commands more robust - Preserve PID for offline sessions - Several quoting fixes for PostgreSQL - Switch supervised workers from temporary to transient ejabberd 16.06 Config - New ACL infrastructure - Add shorter version of some common access rules definitions - Allow @ inside acl rules user, user_glob or user_regexp to pass both user and server in single string - Add acl rule access_rules_validator and shaper_rules_validator for use in mod_opt_type and opt_type callback functions. - Allow using shapers defined by name like in s2s_shaper: fast - Allow mod_opt_type and opt_type to transform values passed to it, and support better error reporting - Do not call transform_terms multiple times in configuration processing when merging them - Don't halt program when include_config_file is missing/can't be read - Allow again multiple fqdn values in configuration Commands - Allow passing username and ip to ejabberd_commands, and use it in mod_http_api - Fix path to epmd in ejabberdctl - push_roster: must convert read strings to binaries - set_presence: Fix command API - Fix for modules_update_specs command - Add ejabberdctl commands to manage oauth tokens. Core - Bounce messages sent to server JID - Fix C2S session leak in rare cases - Fix handling of queued stanzas on session timeout - Give more time to stop and kill epmd - When stopping ejabberd, stop modules after broadcasting c2s shutdown - XEP-0198: Use different error message for bounces - XEP-0198: Add 'h' attribute to element - XEP-0198: Also count stanzas when socket is closed Databases - Fix pgsql compatibility on delete_old_messages command - Handle Redis connection in a separate module - Report in SQL when scram is enabled but the stored password isn't - Update SQL escaping - Use MEDIUMTEXT type for muc_room.opts in MySQL schema MAM - Send unique stanza id and archived tag also in the message carbons - Fix "assume_mam_usage: if_enabled" - Fix typo in mod_mam:select() - Updated support of XEP-0313 from version 0.4 to 0.5.1 - Mnesia: Avoid cleanup on bag when disc_only, switch in memory - Mnesia: Don't exceed table size limit - Mnesia: Use transactions when writing Client State Indication - Fix handling of chat states - Simplify check for carbon-copied chat states - Simplify handling of PEP stanzas - Pass chat states of other resources - Unwrap carbon copies when checking for chat states - Add queue_pep option - Queue chat state notifications - Move CSI queue handling code from ejabberd_c2s - When stopping, delete only the configured hooks Other modules - ext_mod: Set HTTP/1.0 so Github accepts the request - gen_mod: Compile early to remove undefined behaviour warning - mod_http_upload: Let client retry HTTP upload on file size mismatch - mod_last: Produce mod_last entry on account creation - mod_muc_room: Notify on affiliation changes - mod_register: Check password with jid:resourceprep when registering account - mod_roster: respect roster item changes introduced with roster_process_item hooks upon pushing - PubSub: Fix PubSub RSM on get_items - PubSub: Add support for PubSub publishing options - PEP: Fix sender in case of explicit pep subscriptions - ejabberd_xmlrpc: Report error when conversion of argument type fails
This commit is contained in:
parent
3606741453
commit
a5f91ac2fd
4 changed files with 37 additions and 35 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.66 2016/05/17 10:32:06 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.67 2016/08/12 10:27:27 fhajny Exp $
|
||||
|
||||
DISTNAME= ejabberd-16.04
|
||||
PKGREVISION= 1
|
||||
DISTNAME= ejabberd-16.08
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= http://www.process-one.net/downloads/ejabberd/${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -11,24 +10,24 @@ HOMEPAGE= http://www.ejabberd.im/
|
|||
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
DEPENDS+= erlang-cache_tab>=1.0.2:../../devel/erlang-cache_tab
|
||||
DEPENDS+= erlang-esip>=1.0.4:../../net/erlang-esip
|
||||
DEPENDS+= erlang-cache_tab>=1.0.3:../../devel/erlang-cache_tab
|
||||
DEPENDS+= erlang-esip>=1.0.7:../../net/erlang-esip
|
||||
DEPENDS+= erlang-ezlib>=1.0.1:../../devel/erlang-ezlib
|
||||
DEPENDS+= erlang-fast_tls>=1.0.3:../../security/erlang-fast_tls
|
||||
DEPENDS+= erlang-fast_xml>=1.1.3:../../textproc/erlang-fast_xml
|
||||
DEPENDS+= erlang-fast_yaml>=1.0.3:../../textproc/erlang-fast_yaml
|
||||
DEPENDS+= erlang-iconv>=1.0.0:../../converters/erlang-iconv
|
||||
DEPENDS+= erlang-fast_tls>=1.0.6:../../security/erlang-fast_tls
|
||||
DEPENDS+= erlang-fast_xml>=1.1.14:../../textproc/erlang-fast_xml
|
||||
DEPENDS+= erlang-fast_yaml>=1.0.5:../../textproc/erlang-fast_yaml
|
||||
DEPENDS+= erlang-iconv>=1.0.1:../../converters/erlang-iconv
|
||||
DEPENDS+= erlang-jiffy>=0.14.7:../../textproc/erlang-jiffy
|
||||
DEPENDS+= erlang-lager>=3.0.2:../../sysutils/erlang-lager
|
||||
DEPENDS+= erlang-lager>=3.2.1:../../sysutils/erlang-lager
|
||||
DEPENDS+= erlang-luerl>=0.2:../../lang/erlang-luerl
|
||||
DEPENDS+= erlang-p1_mysql>=1.0.1:../../databases/erlang-p1_mysql
|
||||
DEPENDS+= erlang-p1_oauth2>=0.6.1:../../security/erlang-p1_oauth2
|
||||
DEPENDS+= erlang-p1_pam>=1.0.0:../../security/erlang-p1_pam
|
||||
DEPENDS+= erlang-p1_pgsql>=1.1.0:../../databases/erlang-p1_pgsql
|
||||
DEPENDS+= erlang-p1_utils>=1.0.4:../../misc/erlang-p1_utils
|
||||
DEPENDS+= erlang-p1_utils>=1.0.5:../../misc/erlang-p1_utils
|
||||
DEPENDS+= erlang-p1_xmlrpc>=1.15.1:../../textproc/erlang-p1_xmlrpc
|
||||
DEPENDS+= erlang-stringprep>=1.0.3:../../textproc/erlang-stringprep
|
||||
DEPENDS+= erlang-stun>=1.0.3:../../net/erlang-stun
|
||||
DEPENDS+= erlang-stringprep>=1.0.5:../../textproc/erlang-stringprep
|
||||
DEPENDS+= erlang-stun>=1.0.6:../../net/erlang-stun
|
||||
CONFLICTS+= jabberd-[0-9]*
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -37,7 +36,6 @@ USE_TOOLS+= bash:run gmake patch
|
|||
|
||||
CONFIGURE_ARGS+= --disable-debug
|
||||
CONFIGURE_ARGS+= --enable-iconv
|
||||
CONFIGURE_ARGS+= --enable-lager
|
||||
CONFIGURE_ARGS+= --enable-mysql
|
||||
CONFIGURE_ARGS+= --enable-odbc
|
||||
CONFIGURE_ARGS+= --enable-pam
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.40 2016/04/29 19:05:22 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.41 2016/08/12 10:27:27 fhajny Exp $
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ELDAPv3.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/XmppAddr.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/acl.beam
|
||||
|
@ -40,9 +40,12 @@ lib/erlang/lib/${PKGNAME}/ebin/ejabberd_local.beam
|
|||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_logger.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_node_groups.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_oauth.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_oauth_mnesia.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_oauth_sql.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_piefxis.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_rdbms.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_receiver.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_redis.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_regexp.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_riak.beam
|
||||
lib/erlang/lib/${PKGNAME}/ebin/ejabberd_riak_sup.beam
|
||||
|
@ -224,6 +227,7 @@ lib/erlang/lib/${PKGNAME}/include/ejabberd_commands.hrl
|
|||
lib/erlang/lib/${PKGNAME}/include/ejabberd_config.hrl
|
||||
lib/erlang/lib/${PKGNAME}/include/ejabberd_ctl.hrl
|
||||
lib/erlang/lib/${PKGNAME}/include/ejabberd_http.hrl
|
||||
lib/erlang/lib/${PKGNAME}/include/ejabberd_oauth.hrl
|
||||
lib/erlang/lib/${PKGNAME}/include/ejabberd_sm.hrl
|
||||
lib/erlang/lib/${PKGNAME}/include/ejabberd_sql_pt.hrl
|
||||
lib/erlang/lib/${PKGNAME}/include/ejabberd_web_admin.hrl
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.43 2016/04/29 19:05:22 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.44 2016/08/12 10:27:27 fhajny Exp $
|
||||
|
||||
SHA1 (ejabberd-16.04.tgz) = eaf9fcb827397d9f8cb5c70b2b2bf432408d5d06
|
||||
RMD160 (ejabberd-16.04.tgz) = 1672ad385d091cb703c41aa3984eff85756f79db
|
||||
SHA512 (ejabberd-16.04.tgz) = 5975d5a164060cca59b6d92de2c432f063061e832b2e03cae351fe3c16b178259489dc0b82ea800f1c2388eeb7e3aa4340630ad3c10a22cc6d6f0b4eef8fa0f2
|
||||
Size (ejabberd-16.04.tgz) = 1715963 bytes
|
||||
SHA1 (ejabberd-16.08.tgz) = 9044c6b04c11b2e17232c4e44aa39c82da239e84
|
||||
RMD160 (ejabberd-16.08.tgz) = 2fa25907fbf2acb9e316c1d8886df3b28c9f2c7f
|
||||
SHA512 (ejabberd-16.08.tgz) = 661bf33e6d7f4c53d0c3679d1a9428fba11c22bad7d8bd535b49d7eeeff4de215a7a94f8300683e1dbaf2e68ea908f6e54cfe0ed2f1dc82326a46659e7c70f55
|
||||
Size (ejabberd-16.08.tgz) = 1739542 bytes
|
||||
SHA1 (patch-aa) = a9197c75afa9ea4a2fbad70aec894f1b28c7bc88
|
||||
SHA1 (patch-ad) = 6a7cfbabb22cf362cf21791656be454f10ac5de8
|
||||
SHA1 (patch-ae) = c61e6662420745ff029418c26ac6211e04f27d49
|
||||
SHA1 (patch-configure) = 8cf03f571ef13ed825b445e0f1664d387895b8fe
|
||||
SHA1 (patch-rebar.config) = 657a06a7cb002f0bbb898942aa447b984d46604a
|
||||
SHA1 (patch-rebar.config) = 19ad1ce0d2a31221019d3f52d8e64d2679fbdf01
|
||||
SHA1 (patch-tools_ejabberdctl.bc) = 3c7bc0ad14d5b266a192b29e4d075e8f93103569
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
$NetBSD: patch-rebar.config,v 1.3 2016/04/29 19:05:22 fhajny Exp $
|
||||
$NetBSD: patch-rebar.config,v 1.4 2016/08/12 10:27:27 fhajny Exp $
|
||||
|
||||
Deps are handled by pkgsrc.
|
||||
|
||||
--- rebar.config.orig 2016-04-28 13:57:55.000000000 +0000
|
||||
--- rebar.config.orig 2016-08-04 07:49:23.000000000 +0000
|
||||
+++ rebar.config
|
||||
@@ -7,51 +7,6 @@
|
||||
%%% Created : 1 May 2013 by Evgeniy Khramtsov <ekhramtsov@process-one.net>
|
||||
%%%-------------------------------------------------------------------
|
||||
|
||||
-{deps, [{lager, ".*", {git, "https://github.com/basho/lager", {tag, "3.0.2"}}},
|
||||
- {p1_utils, ".*", {git, "https://github.com/processone/p1_utils", {tag, "1.0.4"}}},
|
||||
- {cache_tab, ".*", {git, "https://github.com/processone/cache_tab", {tag, "1.0.2"}}},
|
||||
- {fast_tls, ".*", {git, "https://github.com/processone/fast_tls", {tag, "1.0.3"}}},
|
||||
- {stringprep, ".*", {git, "https://github.com/processone/stringprep", {tag, "1.0.3"}}},
|
||||
- {fast_xml, ".*", {git, "https://github.com/processone/fast_xml", {tag, "1.1.3"}}},
|
||||
- {stun, ".*", {git, "https://github.com/processone/stun", {tag, "1.0.3"}}},
|
||||
- {esip, ".*", {git, "https://github.com/processone/esip", {tag, "1.0.4"}}},
|
||||
- {fast_yaml, ".*", {git, "https://github.com/processone/fast_yaml", {tag, "1.0.3"}}},
|
||||
-{deps, [{lager, ".*", {git, "https://github.com/basho/lager", {tag, "3.2.1"}}},
|
||||
- {p1_utils, ".*", {git, "https://github.com/processone/p1_utils", {tag, "1.0.5"}}},
|
||||
- {cache_tab, ".*", {git, "https://github.com/processone/cache_tab", {tag, "1.0.3"}}},
|
||||
- {fast_tls, ".*", {git, "https://github.com/processone/fast_tls", {tag, "1.0.6"}}},
|
||||
- {stringprep, ".*", {git, "https://github.com/processone/stringprep", {tag, "1.0.5"}}},
|
||||
- {fast_xml, ".*", {git, "https://github.com/processone/fast_xml", {tag, "1.1.14"}}},
|
||||
- {stun, ".*", {git, "https://github.com/processone/stun", {tag, "1.0.6"}}},
|
||||
- {esip, ".*", {git, "https://github.com/processone/esip", {tag, "1.0.7"}}},
|
||||
- {fast_yaml, ".*", {git, "https://github.com/processone/fast_yaml", {tag, "1.0.5"}}},
|
||||
- {jiffy, ".*", {git, "https://github.com/davisp/jiffy", {tag, "0.14.7"}}},
|
||||
- {p1_oauth2, ".*", {git, "https://github.com/processone/p1_oauth2", {tag, "0.6.1"}}},
|
||||
- {p1_xmlrpc, ".*", {git, "https://github.com/processone/p1_xmlrpc", {tag, "1.15.1"}}},
|
||||
|
@ -35,17 +35,17 @@ Deps are handled by pkgsrc.
|
|||
- "527722d12d0433b837cdb92a60900c2cb5df8942"}}},
|
||||
- %% Forces correct dependency for riakc and allow using newer meck version)
|
||||
- {if_var_true, riak, {hamcrest, ".*", {git, "https://github.com/hyperthunk/hamcrest-erlang",
|
||||
- "908a24fda4a46776a5135db60ca071e3d783f9f6"}}}, % for riak_pb-2.1.0.7
|
||||
- "13f9bfb9b27d216e8e033b0e0a9a29097ed923dd"}}}, % for riak_pb-2.1.0.7
|
||||
- {if_var_true, riak, {protobuffs, ".*", {git, "https://github.com/basho/erlang_protobuffs",
|
||||
- "6e7fc924506e2dc166a6170e580ce1d95ebbd5bd"}}}, % for riak_pb-2.1.0.7 with correct meck dependency
|
||||
- %% Elixir support, needed to run tests
|
||||
- {if_var_true, elixir, {elixir, ".*", {git, "https://github.com/elixir-lang/elixir",
|
||||
- {tag, "v1.1.1"}}}},
|
||||
- {tag, {if_version_above, "17", "v1.2.6", "v1.1.1"}}}}},
|
||||
- %% TODO: When modules are fully migrated to new structure and mix, we will not need anymore rebar_elixir_plugin
|
||||
- {if_var_true, elixir, {rebar_elixir_plugin, ".*",
|
||||
- {git, "https://github.com/processone/rebar_elixir_plugin", "0.1.0"}}},
|
||||
- {if_var_true, iconv, {iconv, ".*", {git, "https://github.com/processone/iconv",
|
||||
- {tag, "1.0.0"}}}},
|
||||
- {tag, "1.0.1"}}}},
|
||||
- {if_var_true, tools, {meck, "0.8.*", {git, "https://github.com/eproxus/meck",
|
||||
- {tag, "0.8.4"}}}},
|
||||
- {if_var_true, tools, {moka, ".*", {git, "https://github.com/processone/moka.git",
|
||||
|
|
Loading…
Reference in a new issue