Add patches for gcc-4.3, taken from upstream.
Functionally same as PR#43783.
This commit is contained in:
parent
ed1255848c
commit
a617c2a477
7 changed files with 103 additions and 5 deletions
|
@ -1,12 +1,17 @@
|
|||
$NetBSD: distinfo,v 1.16 2010/05/20 21:12:13 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.17 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
SHA1 (id3lib-3.8.3.tar.gz) = c92c880da41d1ec0b242745a901702ae87970838
|
||||
RMD160 (id3lib-3.8.3.tar.gz) = bfa2499ec649ed40815ad0a370c78eb1517952c4
|
||||
Size (id3lib-3.8.3.tar.gz) = 950726 bytes
|
||||
SHA1 (patch-aa) = 35e7df9577fd7fdd8657dca32207e34b580a0b57
|
||||
SHA1 (patch-aa) = 5983075fc3d03b7c8fff56eca59140553c7bf777
|
||||
SHA1 (patch-af) = 0266e9220791b7b14a35dc9b7564ab75cbc6562b
|
||||
SHA1 (patch-ag) = a047fe90d83c88e0f6d0a6a0595a440ef49276e3
|
||||
SHA1 (patch-ah) = 42a04014cc839565063daa395884b757214eb911
|
||||
SHA1 (patch-ai) = c0521a6d62d17826c9b1f35f6be51e1b72c48e7c
|
||||
SHA1 (patch-aj) = 626952e7bbddbcf5db66a0509f62d588ccaed17a
|
||||
SHA1 (patch-ak) = f7d1155a7750b455ac590d5777b332a55542393d
|
||||
SHA1 (patch-aq) = 7c0cbf3a54cb3e8ad7c7d93ba9d1733ba18b646a
|
||||
SHA1 (patch-ar) = 80151b6f5c9ca6129c1682b08487ff35c3728868
|
||||
SHA1 (patch-as) = 022a014c4cdd3d7bfc940914b798a3eeac3d15e2
|
||||
SHA1 (patch-at) = 8b56148335d8326452e15201f73a70d0beb26b5f
|
||||
SHA1 (patch-au) = 2ed79872f25cea86a5ce4899e5e9d93f734e81fa
|
||||
|
|
|
@ -1,8 +1,21 @@
|
|||
$NetBSD: patch-aa,v 1.4 2006/09/23 13:26:24 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
* make gcc-4.3 compilant
|
||||
http://id3lib.cvs.sourceforge.net/viewvc/id3lib/id3lib-devel/include/id3/id3lib_strings.h?r1=1.7&r2=1.8
|
||||
* add missing arguments
|
||||
* make gcc-3.4 compliant
|
||||
|
||||
--- include/id3/id3lib_strings.h.orig 2003-03-02 00:23:00.000000000 +0000
|
||||
+++ include/id3/id3lib_strings.h
|
||||
@@ -100,10 +100,10 @@ namespace std
|
||||
@@ -30,6 +30,7 @@
|
||||
#define _ID3LIB_STRINGS_H_
|
||||
|
||||
#include <string>
|
||||
+#include <cstring>
|
||||
|
||||
#if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
|
||||
namespace std
|
||||
@@ -100,10 +101,10 @@ namespace std
|
||||
|
||||
static char_type
|
||||
to_char_type(const int_type& __c)
|
||||
|
@ -15,7 +28,7 @@ $NetBSD: patch-aa,v 1.4 2006/09/23 13:26:24 wiz Exp $
|
|||
|
||||
static bool
|
||||
eq_int_type(const int_type& __c1, const int_type& __c2)
|
||||
@@ -117,7 +117,8 @@ namespace std
|
||||
@@ -117,7 +118,8 @@ namespace std
|
||||
{ return eq_int_type(__c, eof()) ? int_type(0) : __c; }
|
||||
};
|
||||
|
||||
|
|
16
audio/id3lib/patches/patch-aq
Normal file
16
audio/id3lib/patches/patch-aq
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aq,v 1.1 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
make gcc-4.3 compilant
|
||||
http://id3lib.cvs.sourceforge.net/viewvc/id3lib/id3lib-devel/configure?r1=1.78&r2=1.79
|
||||
|
||||
--- configure.orig 2003-03-02 00:23:00.000000000 +0000
|
||||
+++ configure
|
||||
@@ -10296,7 +10296,7 @@ done
|
||||
|
||||
for ac_header in \
|
||||
string \
|
||||
- iomanip.h \
|
||||
+ iomanip \
|
||||
|
||||
do
|
||||
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
16
audio/id3lib/patches/patch-ar
Normal file
16
audio/id3lib/patches/patch-ar
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ar,v 1.1 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
make gcc-4.3 compilant.
|
||||
http://id3lib.cvs.sourceforge.net/viewvc/id3lib/id3lib-devel/examples/demo_convert.cpp?r1=1.16&r2=1.17
|
||||
|
||||
--- examples/demo_convert.cpp.orig 2003-03-02 00:23:00.000000000 +0000
|
||||
+++ examples/demo_convert.cpp
|
||||
@@ -84,7 +84,7 @@ void DisplayTags(ostream &os, luint nTag
|
||||
}
|
||||
}
|
||||
|
||||
-int main( unsigned int argc, char * const argv[])
|
||||
+int main( int argc, char * const argv[])
|
||||
{
|
||||
flags_t ulFlag = ID3TT_ALL;
|
||||
gengetopt_args_info args;
|
16
audio/id3lib/patches/patch-as
Normal file
16
audio/id3lib/patches/patch-as
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-as,v 1.1 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
make gcc-4.3 compilant
|
||||
http://id3lib.cvs.sourceforge.net/viewvc/id3lib/id3lib-devel/examples/demo_copy.cpp?r1=1.12&r2=1.13
|
||||
|
||||
--- examples/demo_copy.cpp.orig 2003-03-02 00:23:00.000000000 +0000
|
||||
+++ examples/demo_copy.cpp
|
||||
@@ -81,7 +81,7 @@ void DisplayTags(ostream &os, luint nTag
|
||||
}
|
||||
}
|
||||
|
||||
-int main( unsigned int argc, char * const argv[])
|
||||
+int main( int argc, char * const argv[])
|
||||
{
|
||||
int ulFlag = ID3TT_ID3;
|
||||
ID3D_INIT_DOUT();
|
16
audio/id3lib/patches/patch-at
Normal file
16
audio/id3lib/patches/patch-at
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-at,v 1.1 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
make gcc-4.3 compilant
|
||||
http://id3lib.cvs.sourceforge.net/viewvc/id3lib/id3lib-devel/examples/demo_tag.cpp?r1=1.16&r2=1.17
|
||||
|
||||
--- examples/demo_tag.cpp.orig 2003-03-02 00:23:00.000000000 +0000
|
||||
+++ examples/demo_tag.cpp
|
||||
@@ -46,7 +46,7 @@ void DisplayTags(ostream &os, luint nTag
|
||||
os << "v2";
|
||||
}
|
||||
|
||||
-int main( unsigned int argc, char * const argv[])
|
||||
+int main( int argc, char * const argv[])
|
||||
{
|
||||
int ulFlag = ID3TT_ID3;
|
||||
ID3D_INIT_DOUT();
|
16
audio/id3lib/patches/patch-au
Normal file
16
audio/id3lib/patches/patch-au
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-au,v 1.1 2010/08/22 07:47:56 obache Exp $
|
||||
|
||||
make gcc-4.3 compilant
|
||||
http://id3lib.cvs.sourceforge.net/viewvc/id3lib/id3lib-devel/include/id3/writers.h?r1=1.12&r2=1.13
|
||||
|
||||
--- include/id3/writers.h.orig 2003-03-02 00:23:00.000000000 +0000
|
||||
+++ include/id3/writers.h
|
||||
@@ -30,7 +30,7 @@
|
||||
|
||||
#include "id3/writer.h"
|
||||
#include "id3/id3lib_streams.h"
|
||||
-//#include <string.h>
|
||||
+#include <cstring>
|
||||
|
||||
class ID3_CPP_EXPORT ID3_OStreamWriter : public ID3_Writer
|
||||
{
|
Loading…
Reference in a new issue