Import libappindicator-12.10.0 as devel/libappindicator.
A library to allow applications to export a menu into the Unity Menu bar. Based on KSNI it also works in KDE and will fallback to generic Systray support if none of those are available.
This commit is contained in:
parent
208b3eca5e
commit
a661b42531
7 changed files with 114 additions and 0 deletions
3
devel/libappindicator/DESCR
Normal file
3
devel/libappindicator/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
A library to allow applications to export a menu into the Unity Menu bar. Based
|
||||
on KSNI it also works in KDE and will fallback to generic Systray support if
|
||||
none of those are available.
|
18
devel/libappindicator/Makefile
Normal file
18
devel/libappindicator/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1 2016/05/20 21:39:03 youri Exp $
|
||||
|
||||
USE_GTK_VERSION= 2
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 33 34 35 # py-gtk2
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
COMMENT= Allow applications to export a menu into the panel
|
||||
|
||||
.include "../../devel/libindicator/buildlink3.mk"
|
||||
.include "../../devel/libdbusmenu-gtk/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/py-gobject/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
25
devel/libappindicator/Makefile.common
Normal file
25
devel/libappindicator/Makefile.common
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2016/05/20 21:39:03 youri Exp $
|
||||
#
|
||||
# used by wip/libappindicator3/Makefile
|
||||
|
||||
DISTNAME= libappindicator-12.10.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://launchpad.net/libappindicator/12.10/12.10.0/+download/
|
||||
|
||||
HOMEPAGE= https://launchpad.net/libappindicator/
|
||||
LICENSE= gnu-lgpl-v3 AND gnu-lgpl-v2.1
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
EXTRACT_USING= gtar
|
||||
|
||||
PKGCONFIG_OVERRIDE+= bindings/mono/appindicator-sharp-0.1.pc.in
|
||||
PKGCONFIG_OVERRIDE+= src/appindicator3-0.1.pc.in
|
||||
PKGCONFIG_OVERRIDE+= src/appindicator-0.1.pc.in
|
||||
|
||||
CONFIGURE_ARGS+= --with-gtk=${USE_GTK_VERSION}
|
||||
|
||||
PY_PATCHPLIST= yes
|
||||
.include "../../lang/python/extension.mk"
|
25
devel/libappindicator/PLIST
Normal file
25
devel/libappindicator/PLIST
Normal file
|
@ -0,0 +1,25 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2016/05/20 21:39:03 youri Exp $
|
||||
include/libappindicator-0.1/libappindicator/app-indicator-enum-types.h
|
||||
include/libappindicator-0.1/libappindicator/app-indicator.h
|
||||
lib/libappindicator.la
|
||||
lib/pkgconfig/appindicator-0.1.pc
|
||||
${PYSITELIB}/appindicator/__init__.py
|
||||
${PYSITELIB}/appindicator/__init__.pyc
|
||||
${PYSITELIB}/appindicator/__init__.pyo
|
||||
${PYSITELIB}/appindicator/_appindicator.la
|
||||
share/gtk-doc/html/libappindicator/annotation-glossary.html
|
||||
share/gtk-doc/html/libappindicator/api-index-0-5.html
|
||||
share/gtk-doc/html/libappindicator/api-index-deprecated.html
|
||||
share/gtk-doc/html/libappindicator/api-index-full.html
|
||||
share/gtk-doc/html/libappindicator/ch01.html
|
||||
share/gtk-doc/html/libappindicator/home.png
|
||||
share/gtk-doc/html/libappindicator/index.html
|
||||
share/gtk-doc/html/libappindicator/index.sgml
|
||||
share/gtk-doc/html/libappindicator/left.png
|
||||
share/gtk-doc/html/libappindicator/libappindicator-app-indicator.html
|
||||
share/gtk-doc/html/libappindicator/libappindicator.devhelp2
|
||||
share/gtk-doc/html/libappindicator/object-tree.html
|
||||
share/gtk-doc/html/libappindicator/right.png
|
||||
share/gtk-doc/html/libappindicator/style.css
|
||||
share/gtk-doc/html/libappindicator/up.png
|
||||
share/pygtk/2.0/defs/appindicator.defs
|
17
devel/libappindicator/buildlink3.mk
Normal file
17
devel/libappindicator/buildlink3.mk
Normal file
|
@ -0,0 +1,17 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2016/05/20 21:39:03 youri Exp $
|
||||
|
||||
BUILDLINK_TREE+= libappindicator
|
||||
|
||||
.if !defined(LIBAPPINDICATOR_BUILDLINK3_MK)
|
||||
LIBAPPINDICATOR_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libappindicator+= libappindicator>=12.10.0
|
||||
BUILDLINK_PKGSRCDIR.libappindicator?= ../../devel/libappindicator
|
||||
|
||||
.include "../../devel/libindicator/buildlink3.mk"
|
||||
.include "../../devel/libdbusmenu-gtk/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.endif # LIBAPPINDICATOR_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libappindicator
|
7
devel/libappindicator/distinfo
Normal file
7
devel/libappindicator/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/05/20 21:39:03 youri Exp $
|
||||
|
||||
SHA1 (libappindicator-12.10.0.tar.gz) = 17e2e22cb7025a175ba7f7cff5efdf5dc0e79634
|
||||
RMD160 (libappindicator-12.10.0.tar.gz) = 24e5df115394adcea584c19d36562162c3ab333e
|
||||
SHA512 (libappindicator-12.10.0.tar.gz) = 317a22a23c8ed84e74207b64b2e9683992d1fb7208176637a051dfe925974f966d1cfa31e650b45eaf839ab61641dee8fbebc8a07882a09b0dd766d88b8d5b9a
|
||||
Size (libappindicator-12.10.0.tar.gz) = 535562 bytes
|
||||
SHA1 (patch-src_app-indicator.c) = 681e8be34a56748cb0786fb06e299df5fd2e1a7a
|
19
devel/libappindicator/patches/patch-src_app-indicator.c
Normal file
19
devel/libappindicator/patches/patch-src_app-indicator.c
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-src_app-indicator.c,v 1.1 2016/05/20 21:39:03 youri Exp $
|
||||
|
||||
Fix clang build.
|
||||
|
||||
--- src/app-indicator.c.orig 2012-07-11 17:28:34.000000000 +0000
|
||||
+++ src/app-indicator.c
|
||||
@@ -196,9 +196,9 @@ static void bus_creation (GObject * obj,
|
||||
static void bus_watcher_ready (GObject * obj, GAsyncResult * res, gpointer user_data);
|
||||
|
||||
static const GDBusInterfaceVTable item_interface_table = {
|
||||
- method_call: bus_method_call,
|
||||
- get_property: bus_get_prop,
|
||||
- set_property: NULL /* No properties that can be set */
|
||||
+ .method_call = bus_method_call,
|
||||
+ .get_property = bus_get_prop,
|
||||
+ .set_property = NULL /* No properties that can be set */
|
||||
};
|
||||
|
||||
/* GObject type */
|
Loading…
Reference in a new issue