Prevent to detect unwanted builtin openssl.

After bump of BUILDLINK_API_DEPENDS.openssl to 1.0.1c,
buitin openssl is not acceptable for various platforms.
This commit is contained in:
obache 2014-03-27 05:15:00 +00:00
parent b650100c3f
commit a672644455
6 changed files with 85 additions and 25 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.60 2014/03/12 12:57:06 obache Exp $
# $NetBSD: Makefile,v 1.61 2014/03/27 05:15:00 obache Exp $
.include "dist.mk"
@ -155,6 +155,12 @@ SUBST_STAGE.findlib= pre-configure
SUBST_FILES.findlib= Lib/distutils/unixccompiler.py
SUBST_SED.findlib= -e 's,/usr/local,${PREFIX},'
SUBST_CLASSES+= sslbase
SUBST_MESSAGE.sslbase= Fixing find-file for openssl with SSLBASE.
SUBST_STAGE.sslbase= pre-configure
SUBST_FILES.sslbase= setup.py
SUBST_VARS.sslbase= SSLBASE
post-extract:
${LN} -s ${WRKSRC}/Lib/smtpd.py ${WRKSRC}/Tools/scripts/smtpd${PY_VER_SUFFIX}.py
${MV} ${WRKSRC}/Tools/scripts/pydoc ${WRKSRC}/Tools/scripts/pydoc${PY_VER_SUFFIX}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.54 2014/03/12 12:57:06 obache Exp $
$NetBSD: distinfo,v 1.55 2014/03/27 05:15:00 obache Exp $
SHA1 (Python-2.6.9.tar.xz) = 2fc159946dfcceffbe4a8638de32d0cd8059c2f8
RMD160 (Python-2.6.9.tar.xz) = 42edf7c9f2f64b77ab173de30ea453257c2c06b3
@ -16,7 +16,7 @@ SHA1 (patch-ad) = a997e39d16a8f0023125362b180d19ee97ab519b
SHA1 (patch-ae) = a6d578b5f12eb42fbbcc11791576d2686a4807d9
SHA1 (patch-ah) = 501d220b41e578402f3400fe88e582aa2408a147
SHA1 (patch-al) = 45dd16af8e7a45aa323138f712c034aa79a91019
SHA1 (patch-am) = 4064aa3cbe34389ce344d7372eb71c7305f38e07
SHA1 (patch-am) = 602726fb7f694c1cfe39691aef01fee1687befb1
SHA1 (patch-an) = 17b4e17b3b562c29a050e9bb20447084ce82b8ab
SHA1 (patch-ao) = 8c6a156b0f0c2a6d319658477fff348e6a0c3603
SHA1 (patch-ap) = 5ad6f248027be369bd27f69210ff3c7b97a297a2

View file

@ -1,4 +1,4 @@
$NetBSD: patch-am,v 1.20 2014/03/12 12:57:06 obache Exp $
$NetBSD: patch-am,v 1.21 2014/03/27 05:15:00 obache Exp $
Disabled modules for normal build:
bsddb
@ -17,14 +17,16 @@ Those have separate packages where needed.
Only check the BUILDLINK_DIR for libraries etc, do not pick up random
headers and libraries from the system.
Build the _ssl module with pkgsrc choiced OpenSSL.
Build the 1.85 compat module all the time against the BDB version of choice.
Add in Debian multiarch support (retrofitted from Python 2.7.2) to
support building the "nis" and "crypt" modules.
--- setup.py 2010-07-18 00:31:09.000000000 +1200
+++ setup.py 2011-09-23 01:51:17.757519638 +1200
@@ -18,7 +18,7 @@
--- setup.py.orig 2013-10-29 15:04:39.000000000 +0000
+++ setup.py
@@ -18,7 +18,7 @@ from distutils.command.install_lib impor
from distutils.spawn import find_executable
# This global variable is used to hold the list of modules to be disabled.
@ -33,7 +35,7 @@ support building the "nis" and "crypt" modules.
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -354,10 +354,40 @@
@@ -354,10 +354,40 @@ class PyBuildExt(build_ext):
return platform
return sys.platform
@ -77,7 +79,20 @@ support building the "nis" and "crypt" modules.
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.
@@ -703,9 +733,7 @@
@@ -691,10 +721,9 @@ class PyBuildExt(build_ext):
depends = ['socketmodule.h']) )
# Detect SSL support for the socket module (via _ssl)
search_for_ssl_incs_in = [
- '/usr/local/ssl/include',
- '/usr/contrib/ssl/include/'
+ '@SSLBASE@/include'
]
- ssl_incs = find_file('openssl/ssl.h', inc_dirs,
+ ssl_incs = find_file('openssl/ssl.h', [],
search_for_ssl_incs_in
)
if ssl_incs is not None:
@@ -703,9 +732,7 @@ class PyBuildExt(build_ext):
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
@ -88,7 +103,16 @@ support building the "nis" and "crypt" modules.
if (ssl_incs is not None and
ssl_libs is not None):
@@ -815,172 +843,6 @@
@@ -724,7 +751,7 @@ class PyBuildExt(build_ext):
# look for the openssl version header on the compiler search path.
opensslv_h = find_file('openssl/opensslv.h', [],
- inc_dirs + search_for_ssl_incs_in)
+ search_for_ssl_incs_in)
if opensslv_h:
name = os.path.join(opensslv_h[0], 'openssl/opensslv.h')
if sys.platform == 'darwin' and is_macosx_sdk_path(name):
@@ -815,172 +842,6 @@ class PyBuildExt(build_ext):
else:
raise ValueError("unknown major BerkeleyDB version", major)
@ -261,7 +285,7 @@ support building the "nis" and "crypt" modules.
# The sqlite interface
sqlite_setup_debug = False # verbose debug prints from this script?
@@ -1094,35 +956,40 @@
@@ -1094,35 +955,40 @@ class PyBuildExt(build_ext):
# we do not build this one. Otherwise this build will pick up
# the more recent berkeleydb's db.h file first in the include path
# when attempting to compile and it will fail.
@ -327,7 +351,7 @@ support building the "nis" and "crypt" modules.
# Some systems have -lndbm, others don't
if self.compiler.find_library_file(lib_dirs, 'ndbm'):
ndbm_libs = ['ndbm']
@@ -1131,7 +998,7 @@
@@ -1131,7 +997,7 @@ class PyBuildExt(build_ext):
exts.append( Extension('dbm', ['dbmmodule.c'],
define_macros=[('HAVE_NDBM_H',None)],
libraries = ndbm_libs ) )
@ -336,7 +360,7 @@ support building the "nis" and "crypt" modules.
gdbm_libs = ['gdbm']
if self.compiler.find_library_file(lib_dirs, 'gdbm_compat'):
gdbm_libs.append('gdbm_compat')
@@ -1147,14 +1014,12 @@
@@ -1147,14 +1013,12 @@ class PyBuildExt(build_ext):
libraries = gdbm_libs ) )
else:
missing.append('dbm')
@ -354,7 +378,7 @@ support building the "nis" and "crypt" modules.
else:
missing.append('dbm')
@@ -1408,6 +1273,14 @@
@@ -1408,6 +1272,14 @@ class PyBuildExt(build_ext):
)
libraries = []
@ -369,7 +393,7 @@ support building the "nis" and "crypt" modules.
else: # Linux and other unices
macros = dict(
HAVE_SEM_OPEN=1,
@@ -2026,9 +1899,9 @@
@@ -2026,9 +1898,9 @@ def main():
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.37 2014/03/12 12:40:57 obache Exp $
# $NetBSD: Makefile,v 1.38 2014/03/27 05:22:33 obache Exp $
.include "dist.mk"
@ -162,6 +162,12 @@ SUBST_STAGE.findlib= pre-configure
SUBST_FILES.findlib= Lib/distutils/unixccompiler.py
SUBST_SED.findlib= -e 's,/usr/local,${PREFIX},'
SUBST_CLASSES+= sslbase
SUBST_MESSAGE.sslbase= Fixing find-file for openssl with SSLBASE.
SUBST_STAGE.sslbase= pre-configure
SUBST_FILES.sslbase= setup.py
SUBST_VARS.sslbase= SSLBASE
post-extract:
${LN} -s ${WRKSRC}/Lib/smtpd.py ${WRKSRC}/Tools/scripts/smtpd${PY_VER_SUFFIX}.py
${MV} ${WRKSRC}/Tools/scripts/pydoc ${WRKSRC}/Tools/scripts/pydoc${PY_VER_SUFFIX}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.32 2014/03/15 05:38:14 dholland Exp $
$NetBSD: distinfo,v 1.33 2014/03/27 05:22:33 obache Exp $
SHA1 (Python-2.7.6.tar.xz) = 8321636af2acbeaa68fc635d7dda7369ed446a80
RMD160 (Python-2.7.6.tar.xz) = 8efc73a01a466d8fa16c5c1734c89be79c2c538a
@ -16,7 +16,7 @@ SHA1 (patch-ad) = de730b9f5a5efb56afa8bed05824b5f6579242ec
SHA1 (patch-ae) = ff6d8c6164fe3c6dc4fb33d88eb8a49d5c5442f6
SHA1 (patch-ah) = ae3ce0656d890ca34292920bf0185f94ba847139
SHA1 (patch-al) = dd8bed847f797b97df1a9ad7ffe17645b0f08925
SHA1 (patch-am) = e5d78bfd5b9e6339985ed4cb587897042b6b8590
SHA1 (patch-am) = 801c8fbe14be2138ef45f2d80646d8be6d4ea25a
SHA1 (patch-an) = 6098fbf0fc31422196cc40d3a227934523db11ca
SHA1 (patch-ao) = 3a1cd2b255340fd23fc1fce8680e692581ffcec1
SHA1 (patch-au) = 2a2a988ac92553d17eb898870d1adb3c30a59b66

View file

@ -1,4 +1,4 @@
$NetBSD: patch-am,v 1.12 2014/03/12 12:40:57 obache Exp $
$NetBSD: patch-am,v 1.13 2014/03/27 05:22:33 obache Exp $
Disabled modules for normal build:
bsddb
@ -17,6 +17,8 @@ Those have separate packages where needed.
Only check the BUILDLINK_DIR for libraries etc, do not pick up random
headers and libraries from the system.
Build the _ssl module with pkgsrc choiced OpenSSL.
Build the 1.85 compat module all the time against the BDB version of choice.
cygwin 2.7.3-no-libm.patch
@ -61,7 +63,20 @@ cygwin 2.7.3-no-libm.patch
math_libs = []
# XXX Omitted modules: gl, pure, dl, SGI-specific modules
@@ -797,9 +802,7 @@ class PyBuildExt(build_ext):
@@ -785,10 +790,9 @@ class PyBuildExt(build_ext):
libraries=math_libs) )
# Detect SSL support for the socket module (via _ssl)
search_for_ssl_incs_in = [
- '/usr/local/ssl/include',
- '/usr/contrib/ssl/include/'
+ '@SSLBASE@/include'
]
- ssl_incs = find_file('openssl/ssl.h', inc_dirs,
+ ssl_incs = find_file('openssl/ssl.h', [],
search_for_ssl_incs_in
)
if ssl_incs is not None:
@@ -797,9 +801,7 @@ class PyBuildExt(build_ext):
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
@ -72,7 +87,16 @@ cygwin 2.7.3-no-libm.patch
if (ssl_incs is not None and
ssl_libs is not None):
@@ -918,175 +921,6 @@ class PyBuildExt(build_ext):
@@ -818,7 +820,7 @@ class PyBuildExt(build_ext):
# look for the openssl version header on the compiler search path.
opensslv_h = find_file('openssl/opensslv.h', [],
- inc_dirs + search_for_ssl_incs_in)
+ search_for_ssl_incs_in)
if opensslv_h:
name = os.path.join(opensslv_h[0], 'openssl/opensslv.h')
if host_platform == 'darwin' and is_macosx_sdk_path(name):
@@ -918,175 +920,6 @@ class PyBuildExt(build_ext):
else:
raise ValueError("unknown major BerkeleyDB version", major)
@ -248,7 +272,7 @@ cygwin 2.7.3-no-libm.patch
# The sqlite interface
sqlite_setup_debug = False # verbose debug prints from this script?
@@ -1204,35 +1038,39 @@ class PyBuildExt(build_ext):
@@ -1204,35 +1037,39 @@ class PyBuildExt(build_ext):
# we do not build this one. Otherwise this build will pick up
# the more recent berkeleydb's db.h file first in the include path
# when attempting to compile and it will fail.
@ -312,7 +336,7 @@ cygwin 2.7.3-no-libm.patch
config_args = [arg.strip("'")
for arg in sysconfig.get_config_var("CONFIG_ARGS").split()]
dbm_args = [arg for arg in config_args
@@ -1244,7 +1082,7 @@ class PyBuildExt(build_ext):
@@ -1244,7 +1081,7 @@ class PyBuildExt(build_ext):
dbmext = None
for cand in dbm_order:
if cand == "ndbm":
@ -321,7 +345,7 @@ cygwin 2.7.3-no-libm.patch
# Some systems have -lndbm, others have -lgdbm_compat,
# others don't have either
if self.compiler.find_library_file(lib_dirs,
@@ -1288,18 +1126,14 @@ class PyBuildExt(build_ext):
@@ -1288,18 +1125,14 @@ class PyBuildExt(build_ext):
libraries = gdbm_libs)
break
elif cand == "bdb":
@ -348,7 +372,7 @@ cygwin 2.7.3-no-libm.patch
if dbmext is not None:
exts.append(dbmext)
else:
@@ -2222,9 +2056,9 @@ def main():
@@ -2222,9 +2055,9 @@ def main():
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install