Make sure php-oauth's configure can find pkgsrc libcurl. PKGREVISION++
This commit is contained in:
parent
968192daf0
commit
a6a8609593
3 changed files with 31 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.2 2014/02/12 23:18:35 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2015/09/03 06:19:26 fhajny Exp $
|
||||
|
||||
MODNAME= oauth
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
PECL_VERSION= 1.2.3
|
||||
CATEGORIES+= security
|
||||
|
||||
|
@ -11,6 +11,8 @@ LICENSE= modified-bsd
|
|||
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
CONFIGURE_ARGS+= --with-curl=${BUILDLINK_PREFIX.curl}
|
||||
|
||||
.include "../../lang/php/ext.mk"
|
||||
.include "../../www/curl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/09/13 08:12:52 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.2 2015/09/03 06:19:26 fhajny Exp $
|
||||
|
||||
SHA1 (php-oauth/oauth-1.2.3.tgz) = e2a42961c8134746fc0cd8ef9bd433f760b94975
|
||||
RMD160 (php-oauth/oauth-1.2.3.tgz) = 506f0644b22323a4d1ad6794433768d83357b5ba
|
||||
Size (php-oauth/oauth-1.2.3.tgz) = 45531 bytes
|
||||
SHA1 (patch-config.m4) = c64940fc005c3f61a4c2bd8f370a4e16d434c336
|
||||
|
|
25
security/php-oauth/patches/patch-config.m4
Normal file
25
security/php-oauth/patches/patch-config.m4
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-config.m4,v 1.1 2015/09/03 06:19:26 fhajny Exp $
|
||||
|
||||
Make sure configure can find our curl.
|
||||
|
||||
--- config.m4.orig 1970-01-01 09:13:08.000000000 +0000
|
||||
+++ config.m4
|
||||
@@ -5,6 +5,9 @@ dnl
|
||||
PHP_ARG_ENABLE(oauth, for oauth support,
|
||||
[ --enable-oauth Include oauth support])
|
||||
|
||||
+PHP_ARG_WITH([curl], [whether to enable cURL engine support],
|
||||
+[ --with-curl[=PATH] Include cURL engine support], $PHP_OAUTH, $PHP_OAUTH)
|
||||
+
|
||||
if test "$PHP_OAUTH" != "no"; then
|
||||
PHP_SUBST(OAUTH_SHARED_LIBADD)
|
||||
|
||||
@@ -12,7 +15,7 @@ if test "$PHP_OAUTH" != "no"; then
|
||||
CFLAGS="$CFLAGS -Wall -g"
|
||||
|
||||
AC_MSG_CHECKING(for cURL in default path)
|
||||
- for i in /usr/local /usr; do
|
||||
+ for i in "$PHP_CURL" /usr/local /usr; do
|
||||
if test -r $i/include/curl/easy.h; then
|
||||
CURL_DIR=$i
|
||||
AC_MSG_RESULT(found in $i)
|
Loading…
Reference in a new issue