Updated devel/rudiments to 0.34.
Changes in 0.34 * fixed some STATFS/FSTATFS that needed to be CHAR-versions of the calls * added test for utime and utime.h * utime is used on platforms that don't have utimes * updated process class methods to return -1 and set ENOSUPP for process-group related calls on systems that don't have the concept of process-groups * added a call to select() instead of poll() for file-descriptor passing for systems that don't support poll() * added tests for timespec in various header files * added test for dlopen * updated configure script not to outright disable classes if the functions they're dependent on aren't found, but rather for the methods to return erros and set errno to ENOSYS * added netapi32 on mingw * updated vfstab detection to reflect minix/haiku-style rather than just haiku * moved non-member variables and methods into daemonprocess class and its private class * updated xmldomnode to output xml entities rather than raw characters * fixed a bug that caused numeric xml entities greater than 127 to get set to 127 * updated mutex class to show a consistent interface on all platforms * updated configure script to detect pthreads properly on minix * cleaned up semaphoreset class * lots of mingw32 compatibility fixes * wrapped exit() in process class Changes in 0.33 * removed configure tests for strlcpy and strlcat * added test for pvt->_translatebyteorder to hostToNet/netToHost for 64bit numbers * made filedescriptor::hostToNet/netToHost public and static, moved translatebyteorder flag test out of them * serviceentry and inet*socket classes use filedescriptor::hostToNet/netToHost rather than htonl/htons * added charstring::printBits methods * xmlsax class uses optimizations even when not using mmap now * updated linkedlist class a good bit * applied Renat Sabitov's logger patch * fixed some bugs where filesystem.C wouldn't compile on platforms where statfs can return some strings * haiku port * implemented bswap for systems with nothing like it * added #ifdef's in configure script for all header files * fixed detection of several things on modern openbsd systems * added definitions of (u)int(8|16|32|64)_t for systems that don't have them * added randomnumber::getSeed() that uses /dev/urandom if available * environment class prefers putenv to setenv to work around a memory leak that can occur when using setenv to set an environment variable over and over * fixed 2 memory leaks in environment class * fixed memrchr and strpbrk tests in configure script * fixed a logger dependency on the permissions class in features.mk.in * updated environment class to use malloc and free * fixed reference-after-free by putenv in environment class * applied patches from Renat Sabitov * updated signalhandlers to have (void *)(int) signature * added charstring::subString without an end parameter * applied patch by Claudio Freire * changed several %lf's to %Lf's in charstring long double parsers * fixed uninitiaized nodename/nodevalue in xmldomnode * fixed unterminated buffer after clear in stringbuffer * removed "rebuild" target from all Makefiles * added charstring::capitalize method * made stringbuffer::terminate append a \0 unconditionally * made stringbuffer::clear() terminate the buffer at position 0 * fixed a bug where xmldomnode::getFirstXXX() could crash if there was no first XXX * added xmldomnode::moveChild * fixed uninitialized _grp in groupentry class * regularexpression class uses pcre_free rather than delete to free pcre_extra block now * fixed printf %lld's in timezonefile class * made several unsigned shorts use uint16_t in charstring class * changed integerLength to return uint16_t rather than int * added man page to rpm spec file Changes in 0.32 * xmlsax does "sequential" and "only-once" hints when reading the file * xmlsax/dom classes use optimal read and write buffers now * added DESTDIR= to rudiments.pc.in * added charstring::httpUnescape * fixed a bug in datetime that would cause TZ to remain after doing a timezone conversion if TZ was unset to begin with * fixed a bug in regularexpression that could cause a double-free 0.31 - added OSSwapLittleToHost/OSSwapHostToLittle for Mac OS X * modified environment::clear() for mac os x * regularexpression wasn't setting the match count correctly, fixed that * added charstring::subString() method * added missing lingerOnClose(), fixed dontLingerOnClose() * added base64 encode/decode methods * fixed charstring::parseNumber() for unsigned int's * added /opt/csw to configure script's search path * fixed a memory leak in xmldom::unCacheString() Changes in 0.30 * changed commandline::value() to commandline::getValue() * fixed a memory leak in dictionary * added setHour/Minute/Second/etc. methods to datetime * fixed readdir_r vulnerability * added support for either "-arg value" or "--arg=value" to commandline * added support for break and control characters to chat class * added print method to environment class * added close-on-exec methods to filedescriptor class * added clear method to environment class * made all methods in environment class static * added wrappers for strspn/strcspn/strpbrk functions to charstring class * fixed bug where datetime would set wrong timezone if it is initialized with a combined zone name like PST8PDT * added directory::getChildCount() * added datetime::validDateTime() * xmldom class stores all strings found in the xml file in a stringlist and stores pointers to them in the xmldomnodes to reduce memory usage in xml files that have lots of duplicated strings * added configure tests for dirfd/DIR.dd_fd/DIR.d_fd * initialize addrinfo struct pointer to NULL in inetclientsocket.C
This commit is contained in:
parent
668a742391
commit
a745b87b04
4 changed files with 32 additions and 27 deletions
|
@ -1,14 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.19 2008/06/20 01:09:16 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2011/10/28 11:23:21 fhajny Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rudiments-0.29
|
||||
PKGREVISION= 2
|
||||
DISTNAME= rudiments-0.34
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=rudiments/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://rudiments.sourceforge.net/
|
||||
COMMENT= C++ class library for client/server/daemon applications
|
||||
LICENSE= gnu-lgpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2009/06/14 17:49:13 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2011/10/28 11:23:21 fhajny Exp $
|
||||
bin/rudiments-config
|
||||
include/rudiments/character.h
|
||||
include/rudiments/charstring.h
|
||||
|
@ -141,6 +141,8 @@ include/rudiments/private/serversocket.h
|
|||
include/rudiments/private/serversocketincludes.h
|
||||
include/rudiments/private/serviceentry.h
|
||||
include/rudiments/private/serviceentryincludes.h
|
||||
include/rudiments/private/shadowentry.h
|
||||
include/rudiments/private/shadowentryincludes.h
|
||||
include/rudiments/private/sharedmemory.h
|
||||
include/rudiments/private/sharedmemoryincludes.h
|
||||
${PLIST.shm}include/rudiments/private/shmfile.h
|
||||
|
@ -163,6 +165,7 @@ include/rudiments/private/unixsocketutil.h
|
|||
include/rudiments/private/unixsocketutilincludes.h
|
||||
include/rudiments/private/variablebuffer.h
|
||||
include/rudiments/private/variablebufferincludes.h
|
||||
include/rudiments/private/winsock.h
|
||||
include/rudiments/private/xmldom.h
|
||||
include/rudiments/private/xmldomincludes.h
|
||||
include/rudiments/private/xmldomnode.h
|
||||
|
@ -182,6 +185,7 @@ include/rudiments/serialportprofile.h
|
|||
include/rudiments/server.h
|
||||
include/rudiments/serversocket.h
|
||||
include/rudiments/serviceentry.h
|
||||
include/rudiments/shadowentry.h
|
||||
include/rudiments/sharedmemory.h
|
||||
${PLIST.shm}include/rudiments/shmfile.h
|
||||
include/rudiments/signalclasses.h
|
||||
|
@ -197,6 +201,7 @@ include/rudiments/xmldomnode.h
|
|||
include/rudiments/xmlsax.h
|
||||
lib/librudiments.la
|
||||
lib/pkgconfig/rudiments.pc
|
||||
man/man1/rudiments-config.1
|
||||
share/doc/rudiments/classes/character.h.html
|
||||
share/doc/rudiments/classes/charstring.h.html
|
||||
share/doc/rudiments/classes/chat.h.html
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.6 2006/04/19 17:20:59 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.7 2011/10/28 11:23:21 fhajny Exp $
|
||||
|
||||
SHA1 (rudiments-0.29.tar.gz) = f84c785dfc9fc9fc0645812b52a71b9e94e151b0
|
||||
RMD160 (rudiments-0.29.tar.gz) = 197bafb41a7607d2a20fb3f78aa3a5f99ee01b36
|
||||
Size (rudiments-0.29.tar.gz) = 605753 bytes
|
||||
SHA1 (patch-aa) = de5602b4536727a64fd2eb1fd5ab882b316ebcc0
|
||||
SHA1 (rudiments-0.34.tar.gz) = 90800a3538e0fa669c9d075600252a3f2d027a60
|
||||
RMD160 (rudiments-0.34.tar.gz) = 27e18698149a81f856c5dd152fe825b891506d20
|
||||
Size (rudiments-0.34.tar.gz) = 770725 bytes
|
||||
SHA1 (patch-aa) = 34b4b02c5b5dc4992d173f7f8478f1f38a0c53e8
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.4 2006/04/19 17:20:59 joerg Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2011/10/28 11:23:22 fhajny Exp $
|
||||
|
||||
--- configure.orig 2006-01-30 06:06:28.000000000 +0000
|
||||
--- configure.orig 2011-08-03 10:33:54.000000000 +0000
|
||||
+++ configure
|
||||
@@ -29751,7 +29751,7 @@ mlockall(0);
|
||||
@@ -22414,7 +22414,7 @@ mlockall(0);
|
||||
return 0;
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
- (eval $ac_compile) 2>conftest.er1
|
||||
+ (eval $ac_link) 2>conftest.er1
|
||||
ac_status=$?
|
||||
grep -v '^ *+' conftest.er1 >conftest.err
|
||||
rm -f conftest.er1
|
||||
@@ -29919,7 +29919,7 @@ munlockall();
|
||||
-if ac_fn_cxx_try_compile "$LINENO"; then :
|
||||
+if ac_fn_cxx_try_link "$LINENO"; then :
|
||||
|
||||
$as_echo "#define RUDIMENTS_HAVE_MLOCKALL 1" >>confdefs.h
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
@@ -22504,7 +22504,7 @@ munlockall();
|
||||
return 0;
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
- (eval $ac_compile) 2>conftest.er1
|
||||
+ (eval $ac_link) 2>conftest.er1
|
||||
ac_status=$?
|
||||
grep -v '^ *+' conftest.er1 >conftest.err
|
||||
rm -f conftest.er1
|
||||
-if ac_fn_cxx_try_compile "$LINENO"; then :
|
||||
+if ac_fn_cxx_try_link "$LINENO"; then :
|
||||
|
||||
$as_echo "#define RUDIMENTS_HAVE_MUNLOCKALL 1" >>confdefs.h
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
|
|
Loading…
Reference in a new issue