Fix Linux build.

This commit is contained in:
sbd 2012-02-04 09:26:10 +00:00
parent a0a8301ddc
commit a7467007f3
6 changed files with 66 additions and 5 deletions

View file

@ -1,8 +1,12 @@
$NetBSD: distinfo,v 1.4 2011/11/23 00:42:00 marino Exp $
$NetBSD: distinfo,v 1.5 2012/02/04 09:26:10 sbd Exp $
SHA1 (flactag-1.1.tar.gz) = 8b0b65068b2659eceb36831694657bf2210ca36b
RMD160 (flactag-1.1.tar.gz) = 975091ad58b1c88e972e0b99ae800c068bc668d7
Size (flactag-1.1.tar.gz) = 110567 bytes
SHA1 (patch-aa) = 8fe32dfe32c5e5ab7a88a96b1507b74d65dca788
SHA1 (patch-CommandLine.cc) = f677354989b98c26a613cfdf1f10ab8746ac6ec3
SHA1 (patch-ConfigFile.cc) = 3936aabe97b7660cbe5731e81317494782859877
SHA1 (patch-ErrorLog.cc) = 7ae1bbce462db4e7b776d976b14485be1a40d063
SHA1 (patch-FileNameBuilder.cc) = c7ba316bcf999670125c37573f29b7338804b15c
SHA1 (patch-aa) = 71425b556d64b828083f0738e61fb0b9ca15b1df
SHA1 (patch-ac) = cf71f4f68663ed9dc73662e32df55c0621fcaa14
SHA1 (patch-ad) = ff867a7acc08e08e3f109c63a235c13243a95cc6

View file

@ -0,0 +1,13 @@
$NetBSD: patch-CommandLine.cc,v 1.1 2012/02/04 09:26:11 sbd Exp $
--- CommandLine.cc.orig 2008-12-16 11:20:56.000000000 +0000
+++ CommandLine.cc
@@ -32,6 +32,8 @@
#include "ErrorLog.h"
+#include <cstdio>
+
CCommandLine::CCommandLine(int argc, char *const argv[])
: m_Valid(true),
m_Check(false),

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ConfigFile.cc,v 1.1 2012/02/04 09:26:11 sbd Exp $
--- ConfigFile.cc.orig 2008-12-16 11:20:56.000000000 +0000
+++ ConfigFile.cc
@@ -25,6 +25,7 @@
----------------------------------------------------------------------------*/
#include "ConfigFile.h"
+#include <cstdio>
CConfigFile::CConfigFile()
{

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ErrorLog.cc,v 1.1 2012/02/04 09:26:11 sbd Exp $
--- ErrorLog.cc.orig 2008-12-16 11:20:56.000000000 +0000
+++ ErrorLog.cc
@@ -25,6 +25,7 @@
----------------------------------------------------------------------------*/
#include "ErrorLog.h"
+#include <cstdio>
const std::vector<std::string>::size_type CErrorLog::m_cMaxSize=100;

View file

@ -0,0 +1,12 @@
$NetBSD: patch-FileNameBuilder.cc,v 1.1 2012/02/04 09:26:11 sbd Exp $
--- FileNameBuilder.cc.orig 2012-02-04 08:44:33.120854935 +0000
+++ FileNameBuilder.cc
@@ -27,6 +27,7 @@
#include "FileNameBuilder.h"
#include <stdlib.h>
+#include <cstdio>
#include <unac.h>

View file

@ -1,12 +1,20 @@
$NetBSD: patch-aa,v 1.2 2011/11/23 00:42:00 marino Exp $
$NetBSD: patch-aa,v 1.3 2012/02/04 09:26:11 sbd Exp $
--- UTF8Tag.cc.orig 2008-12-16 11:20:56.000000000 +0000
+++ UTF8Tag.cc
@@ -71,7 +71,11 @@ void CUTF8Tag::Convert()
@@ -32,6 +32,7 @@
#include <errno.h>
#include <string.h>
#include <stdlib.h>
+#include <cstdio>
#include <iconv.h>
@@ -71,7 +72,11 @@ void CUTF8Tag::Convert()
memset(Out,0,m_UTF8Value.length()*4);
size_t OutLeft=m_UTF8Value.length()*4;
+#if defined(__DragonFly__)
+#if defined(__DragonFly__) || (__linux__)
char *InBuff=In;
+#else
+ const char *InBuff=In;