Update to version 8.1.14.
Approved by maintainer. Changes since last packaged version (8.1.11): version 8.1.14 (Apr 9, 2006): - fixed rpm conserver.spec file - based on patch by Martin Evans <m.d.t.evans@qmul.ac.uk> - added 'uds' console type for unix domain socket connections - based on patch by DJ Gregor <dj@gregor.com> - probing of interfaces under cygwin (and possibly others?) now skips unconfigured interfaces (even if flagged as up!) - reported by Chris Riddoch <chrisr@digeo.com> - added the '!login' console option to prevent clients from connecting to a console - suggested by Greg Tillman <gregtillman@comcast.net> - added a 'noop' console type for consoles you'd like to name, but have no connection to - suggested by Greg Tillman <gregtillman@comcast.net> - deprecated escape commands removed from the code - added '^EcP' and '^EcR' sequences to set the playback and replay line lengths - new console config options 'playback' and 'replay' to let the client set prefered output lengths (with a special feature for a size of zero) - prefer strlcpy() over strcpy() - based on patch by Peter Valchev <pvalchev@openbsd.org> - fixed bug where '^Eco' by user on an 'exec' console with an 'initcmd' causes input by user to be ignored (could be other console types as well) - reported by Mark Wedel <Mark.Wedel@sun.com> - made POSIX termios code in autologin a requirement (since conserver requires it) and cleaned up a few other issues - based on reports by Arthur Clune <ajc22@york.ac.uk> version 8.1.13 (Jan 15, 2006): - use SIOCGIFNUM for interface count (if available) and catch EINVAL on Solaris - patch by Peter Jeremy <peter.jeremy@alcatel.com.au> - console output now resets idle timer - suggested by Peter Saunders <pajs@fodder.org.uk> - bug fix for conserver process running out of control and using up cpu - debugged with Alexandra N. Kossovsky <Alexandra.Kossovsky@oktetlabs.ru> version 8.1.12 (Sep 5, 2005): - printf() fix for autologin - patch by Menno Duursma <druiloor@zonnet.nl> - newly spawned (from SIGHUP) processes didn't properly close primary socket - SSL certificates now work again (anonymous ciphers are not allowed if a certificate is used) - client options -x, -u, -w, and -i can now take a console name to restrict output - suggested by Evan McClure <emcclure@internap.com> - convert program now installed in $libdir/conserver - patch by Petter Reinholdtsen <pere@hungry.com> - we now ignore SIGXFSZ, if it exists - added 'limited' access option to remove certain functionality from users - suggested by Sven Michels <sven@darkman.de> - added client option -z/-Z for sending commands to servers (reload, quit, etc) - based on suggestion by Joshua Pincus <Joshua.Pincus@Sun.COM> - added 'execrunas' and 'initrunas' console options to allow 'exec' and 'initcmd' execution as another user and/or group - based on patch by Gary Mills <mills@cc.umanitoba.ca> - the east coast mirror had to shut down (for now, at least) - crash from bad pointer manipulation during log replay - reported by Ryan Kirkpatrick <linux@rkirkpat.net>
This commit is contained in:
parent
9d880bfb2d
commit
a763c66219
5 changed files with 24 additions and 24 deletions
|
@ -1,5 +1,5 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2005/06/03 20:08:04 wiz Exp $
|
||||
$NetBSD: MESSAGE,v 1.2 2006/05/11 21:42:43 seb Exp $
|
||||
|
||||
NB: The console command from versions of conserver prior to 8 does not
|
||||
interoperate with conserver version 8.
|
||||
|
@ -9,12 +9,12 @@ conserver.
|
|||
|
||||
For instruction on how to convert your configurtion files from conserver
|
||||
version 7.x.x see ${PREFIX}/share/doc/conserver/INSTALL.
|
||||
The "convert" program was installed as ${PREFIX}/bin/conserverconvert.
|
||||
The "convert" program was installed as ${PREFIX}/lib/conserver/convert.
|
||||
|
||||
Briefly:
|
||||
mv ${PKG_SYSCONFDIR}/conserver.cf ${PKG_SYSCONFDIR}/conserver.cf-7
|
||||
mv ${PKG_SYSCONFDIR}/conserver.passwd ${PKG_SYSCONFDIR}/conserver.passwd-7
|
||||
${PREFIX}/bin/conserverconvert ${PKG_SYSCONFDIR}/conserver.cf-7 >\
|
||||
${PREFIX}/lib/conserver/convert ${PKG_SYSCONFDIR}/conserver.cf-7 >\
|
||||
${PKG_SYSCONFDIR}/conserver.cf
|
||||
awk -F: '{print $1 ":" $2}' < ${PKG_SYSCONFDIR}/conserver.passwd-7 > \
|
||||
${PKG_SYSCONFDIR}/conserver.passwd
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.4 2005/12/29 06:21:34 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2006/05/11 21:42:43 seb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= conserver-8.1.11
|
||||
PKGNAME= conserver8-8.1.11
|
||||
PKGREVISION= 1
|
||||
DISTNAME= conserver-8.1.14
|
||||
PKGNAME= conserver8-8.1.14
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= ftp://ftp.conserver.com/conserver/
|
||||
|
||||
|
@ -22,7 +21,7 @@ CONFIGURE_ARGS+= --with-master=${CONSERVER_DEFAULTHOST:Q}
|
|||
CONFIGURE_ARGS+= --with-port=${CONSERVER_DEFAULTPORT:Q}
|
||||
CONFIGURE_ARGS+= --with-regex
|
||||
CONFIGURE_ARGS+= --with-libwrap=${BUILDLINK_PREFIX.tcp_wrappers}
|
||||
CONFIGURE_ARGS+= --with-logfile=${VARBASE}/log/conserver
|
||||
CONFIGURE_ARGS+= --with-logfile=${VARBASE:Q}/log/conserver
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.conserver8
|
||||
PKG_SUPPORTED_OPTIONS= pam ssl uds
|
||||
|
@ -65,9 +64,8 @@ pre-install:
|
|||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/conserver/convert ${PREFIX}/bin/conserverconvert
|
||||
${INSTALL_DATA_DIR} ${DOCDIR}
|
||||
for File in INSTALL README PROTOCOL; do \
|
||||
set -e; for File in INSTALL README PROTOCOL; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$${File} ${DOCDIR}/$${File}; \
|
||||
done
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2005/08/12 14:35:15 he Exp $
|
||||
bin/conserverconvert
|
||||
@comment $NetBSD: PLIST,v 1.3 2006/05/11 21:42:43 seb Exp $
|
||||
bin/console
|
||||
lib/conserver/convert
|
||||
man/man1/console.1
|
||||
man/man5/conserver.cf.5
|
||||
man/man5/conserver.passwd.5
|
||||
|
@ -14,3 +14,5 @@ share/examples/conserver/conserver.passwd
|
|||
share/examples/conserver/conserver.rc
|
||||
share/examples/rc.d/conserver8
|
||||
@dirrm share/examples/conserver
|
||||
@dirrm share/doc/conserver
|
||||
@dirrm lib/conserver
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/08/12 14:39:06 he Exp $
|
||||
$NetBSD: distinfo,v 1.3 2006/05/11 21:42:43 seb Exp $
|
||||
|
||||
SHA1 (conserver-8.1.11.tar.gz) = d30d4c86b769d56707f6abfad47992cc59f128da
|
||||
RMD160 (conserver-8.1.11.tar.gz) = 380386c3f488787bf132809071b308bc9a00c89f
|
||||
Size (conserver-8.1.11.tar.gz) = 299281 bytes
|
||||
SHA1 (patch-aa) = 1747fbc95109db50b1acd003235fca9556f9d084
|
||||
SHA1 (conserver-8.1.14.tar.gz) = 3275ba140e5d157ab022f3de083a61a37f058bd6
|
||||
RMD160 (conserver-8.1.14.tar.gz) = 9d0961d837f03ddbdaddccf7f45097b6f4e452b8
|
||||
Size (conserver-8.1.14.tar.gz) = 308609 bytes
|
||||
SHA1 (patch-aa) = d0eebea0d126c611f6f60035730a0c2f97280b01
|
||||
SHA1 (patch-ab) = 7a507e428277cc6ccf14b961c44d4e6fd3abcde3
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/06/03 20:08:04 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2006/05/11 21:42:43 seb Exp $
|
||||
|
||||
--- conserver/main.c.orig 2004-07-14 01:28:42.000000000 -0400
|
||||
+++ conserver/main.c 2005-05-22 14:16:15.000000000 -0400
|
||||
@@ -460,7 +460,9 @@
|
||||
--- conserver/main.c.orig 2006-04-03 09:32:08.000000000 -0400
|
||||
+++ conserver/main.c 2006-05-07 22:24:26.000000000 -0400
|
||||
@@ -463,7 +463,9 @@
|
||||
int td;
|
||||
#endif
|
||||
|
||||
|
@ -12,17 +12,17 @@ $NetBSD: patch-aa,v 1.1.1.1 2005/06/03 20:08:04 wiz Exp $
|
|||
SimpleSignal(SIGQUIT, SIG_IGN);
|
||||
SimpleSignal(SIGINT, SIG_IGN);
|
||||
#if defined(SIGTTOU)
|
||||
@@ -1259,7 +1261,9 @@
|
||||
@@ -1284,7 +1286,9 @@
|
||||
Bye(EX_OK);
|
||||
}
|
||||
|
||||
+#if 0
|
||||
Msg("%s", THIS_VERSION);
|
||||
Msg(MyVersion());
|
||||
+#endif
|
||||
|
||||
#if HAVE_GETLOGIN
|
||||
origuser = getlogin();
|
||||
@@ -1286,7 +1290,9 @@
|
||||
@@ -1311,7 +1315,9 @@
|
||||
BuildStringPrint(startedMsg, "started as `%s' by `%s'", curuser,
|
||||
(origuser == (char *)0) ? curuser : origuser);
|
||||
endpwent();
|
||||
|
|
Loading…
Reference in a new issue