With newer Boost, this now must be built as C++11. Unrestrict make_pair
to help GCC 4.8 figure out the right template of make_pair.
This commit is contained in:
parent
96ba37f35f
commit
a781f2785d
3 changed files with 33 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.39 2016/03/05 11:28:58 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.40 2016/05/07 10:06:40 joerg Exp $
|
||||
|
||||
DISTNAME= rocs-${_KDE_VERSION}
|
||||
PKGREVISION= 5
|
||||
|
@ -9,6 +9,11 @@ COMMENT= KDE graph theory IDE
|
|||
|
||||
CMAKE_ARGS+= -DKDE4_BUILD_TESTS:BOOL=OFF
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
.if !empty(PKGSRC_COMPILER:Mclang) || !empty(PKGSRC_COMPILER:Mgcc)
|
||||
CXXFLAGS+= -std=c++11
|
||||
.endif
|
||||
|
||||
.include "../../meta-pkgs/kde4/kde4.mk"
|
||||
|
||||
.include "../../devel/boost-libs/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.11 2015/11/03 23:49:48 agc Exp $
|
||||
$NetBSD: distinfo,v 1.12 2016/05/07 10:06:40 joerg Exp $
|
||||
|
||||
SHA1 (rocs-4.14.3.tar.xz) = a6fac0cee375f8bdb8c9241bde4bf9dda0f38704
|
||||
RMD160 (rocs-4.14.3.tar.xz) = c148e7720239043b21d112ac32bfa47ca88accd0
|
||||
SHA512 (rocs-4.14.3.tar.xz) = f0c1d35fcd17473459a3f63ce731c3cf27da51d64b53383f1c4ff280e8df256b80c2797e0c9012cad92601e2155f3e79118a8b8af20af2b3ce10c7ab40ca9d53
|
||||
Size (rocs-4.14.3.tar.xz) = 1146328 bytes
|
||||
SHA1 (patch-RocsCore_DataStructures_Graph_GraphStructure.cpp) = 21b7e84ba223e120e01fd8eebf2393db28d23152
|
||||
SHA1 (patch-RocsCore_LoadSave_Plugins_CMakeLists.txt) = ae4d15f9aa8fc2f19715db544a15ddbc2f0d98fb
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-RocsCore_DataStructures_Graph_GraphStructure.cpp,v 1.1 2016/05/07 10:06:40 joerg Exp $
|
||||
|
||||
Don't force the argument types for std::make_pair, GCC 4.8 has problems
|
||||
figuring out the correct invocation.
|
||||
|
||||
--- RocsCore/DataStructures/Graph/GraphStructure.cpp.orig 2016-05-06 17:05:52.000000000 +0000
|
||||
+++ RocsCore/DataStructures/Graph/GraphStructure.cpp
|
||||
@@ -323,7 +323,7 @@ QMap<DataPtr,PointerList> Rocs::GraphStr
|
||||
counter = 0;
|
||||
foreach(PointerPtr p, pointerListAll) {
|
||||
edges[counter] = Edge(node_mapping[p->from()->identifier()], node_mapping[p->to()->identifier()]);
|
||||
- edge_mapping[std::make_pair < int, int > (node_mapping[p->from()->identifier()], node_mapping[p->to()->identifier()])] = p;
|
||||
+ edge_mapping[std::make_pair(node_mapping[p->from()->identifier()], node_mapping[p->to()->identifier()])] = p;
|
||||
if (!p->property("value").toString().isEmpty()) {
|
||||
weights[counter] = p->property("value").toDouble();
|
||||
} else {
|
||||
@@ -333,7 +333,7 @@ QMap<DataPtr,PointerList> Rocs::GraphStr
|
||||
// if graph is directed, also add back-edges
|
||||
if (p->direction() == PointerType::Bidirectional) {
|
||||
edges[counter] = Edge(node_mapping[p->to()->identifier()], node_mapping[p->from()->identifier()]);
|
||||
- edge_mapping[std::make_pair< int, int >(node_mapping[p->to()->identifier()], node_mapping[p->from()->identifier()])] = p;
|
||||
+ edge_mapping[std::make_pair(node_mapping[p->to()->identifier()], node_mapping[p->from()->identifier()])] = p;
|
||||
if (!p->property("value").toString().isEmpty()) {
|
||||
weights[counter] = p->property("value").toDouble();
|
||||
} else {
|
Loading…
Reference in a new issue