x11/lxqt-globalkeys: update to 0.16.0
-Added shortcut to configure display. -Silenced unused function parameters warnings. -Do not grab keys of disabled client actions. -Do not requite daemon restart for enabling shortcuts.
This commit is contained in:
parent
dc2f8ad3da
commit
a818d86e23
5 changed files with 38 additions and 16 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.7 2020/12/04 04:56:18 riastradh Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2020/12/07 12:25:25 pin Exp $
|
||||
|
||||
DISTNAME= lxqt-globalkeys-0.15.0
|
||||
PKGREVISION= 4
|
||||
DISTNAME= lxqt-globalkeys-0.16.0
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=lxqt/}
|
||||
GITHUB_RELEASE= ${PKGVERSION_NOREV}
|
||||
|
@ -19,10 +18,18 @@ USE_LANGUAGES= c c++
|
|||
CONFIGURE_DIRS= build
|
||||
CMAKE_ARG_PATH= ..
|
||||
|
||||
AUTOSTART_CONF= share/examples/autostart
|
||||
PKG_SYSCONFSUBDIR= xdg
|
||||
MAKE_DIRS= ${PKG_SYSCONFDIR}/autostart
|
||||
|
||||
CONF_FILES+= ${AUTOSTART_CONF}/lxqt-globalkeyshortcuts.desktop \
|
||||
${PKG_SYSCONFDIR}/autostart/lxqt-globalkeyshortcuts.desktop
|
||||
|
||||
|
||||
pre-configure:
|
||||
${MKDIR} -p ${WRKSRC}/build
|
||||
|
||||
TOOL_DEPENDS+= lxqt-build-tools-[0-9]*:../../devel/lxqt-build-tools
|
||||
TOOL_DEPENDS+= lxqt-build-tools>=0.8:../../devel/lxqt-build-tools
|
||||
TOOL_DEPENDS+= qt5-qttools-[0-9]*:../../x11/qt5-qttools
|
||||
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2020/06/01 12:01:42 pin Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2020/12/07 12:25:25 pin Exp $
|
||||
bin/lxqt-config-globalkeyshortcuts
|
||||
bin/lxqt-globalkeysd
|
||||
include/lxqt-globalkeys-ui/LXQtGlobalKeysUi/ShortcutSelector
|
||||
|
@ -13,10 +13,10 @@ include/lxqt-globalkeys/lxqt-globalkeys.h
|
|||
include/lxqt-globalkeys/lxqtglobalkeys.h
|
||||
lib/liblxqt-globalkeys-ui.so
|
||||
lib/liblxqt-globalkeys-ui.so.0
|
||||
lib/liblxqt-globalkeys-ui.so.0.15.1
|
||||
lib/liblxqt-globalkeys-ui.so.${PKGVERSION}
|
||||
lib/liblxqt-globalkeys.so
|
||||
lib/liblxqt-globalkeys.so.0
|
||||
lib/liblxqt-globalkeys.so.0.15.1
|
||||
lib/liblxqt-globalkeys.so.${PKGVERSION}
|
||||
lib/pkgconfig/lxqt-globalkeys-ui.pc
|
||||
lib/pkgconfig/lxqt-globalkeys.pc
|
||||
share/applications/lxqt-config-globalkeyshortcuts.desktop
|
||||
|
@ -28,7 +28,7 @@ share/cmake/lxqt-globalkeys/lxqt-globalkeys-config-version.cmake
|
|||
share/cmake/lxqt-globalkeys/lxqt-globalkeys-config.cmake
|
||||
share/cmake/lxqt-globalkeys/lxqt-globalkeys-targets-release.cmake
|
||||
share/cmake/lxqt-globalkeys/lxqt-globalkeys-targets.cmake
|
||||
share/examples/lxqt/xdg/autostart/lxqt-globalkeyshortcuts.desktop
|
||||
share/examples/autostart/lxqt-globalkeyshortcuts.desktop
|
||||
share/lxqt/globalkeyshortcuts.conf
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_ar.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_arn.qm
|
||||
|
@ -48,6 +48,7 @@ share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshor
|
|||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_fr.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_gl.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_he.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_hr.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_hu.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_id.qm
|
||||
share/lxqt/translations/lxqt-config-globalkeyshortcuts/lxqt-config-globalkeyshortcuts_it.qm
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.6 2020/12/04 04:56:18 riastradh Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.7 2020/12/07 12:25:25 pin Exp $
|
||||
|
||||
BUILDLINK_TREE+= lxqt-globalkeys
|
||||
|
||||
.if !defined(LXQT_GLOBALKEYS_BUILDLINK3_MK)
|
||||
LXQT_GLOBALKEYS_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.lxqt-globalkeys+= lxqt-globalkeys>=0.15.0
|
||||
BUILDLINK_ABI_DEPENDS.lxqt-globalkeys?= lxqt-globalkeys>=0.15.0nb4
|
||||
BUILDLINK_API_DEPENDS.lxqt-globalkeys+= lxqt-globalkeys>=0.16.0
|
||||
BUILDLINK_PKGSRCDIR.lxqt-globalkeys?= ../../x11/lxqt-globalkeys
|
||||
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2020/06/01 12:01:42 pin Exp $
|
||||
$NetBSD: distinfo,v 1.3 2020/12/07 12:25:25 pin Exp $
|
||||
|
||||
SHA1 (lxqt-globalkeys-0.15.0.tar.xz) = 0d9ac5f379db94c2a0f52d17804da913d366cc94
|
||||
RMD160 (lxqt-globalkeys-0.15.0.tar.xz) = 63f873c7819aeb193098a5a2d8767ba333020ccd
|
||||
SHA512 (lxqt-globalkeys-0.15.0.tar.xz) = 95beba4ce6c2324582d93a6f3f56d57681ec7d992db80a8d9fae34a637ba1612260932944e3865c3c749982e6aa111b3495558bc5d36e8b4c8e21027775e346e
|
||||
Size (lxqt-globalkeys-0.15.0.tar.xz) = 68932 bytes
|
||||
SHA1 (lxqt-globalkeys-0.16.0.tar.xz) = 82a28fa8bfcaee25b3902d879e61fb31ebe93002
|
||||
RMD160 (lxqt-globalkeys-0.16.0.tar.xz) = 38dee0ace98a13068db4e796da96ec842b8d1677
|
||||
SHA512 (lxqt-globalkeys-0.16.0.tar.xz) = a6b2de35e3deb4852e9a8462871ba0fd40c9168653b210e361ff16b7dc5c74f9c98c6427cc595578eb9bb2a34c9be702c0af65fdfb92053b1f3813070629e55b
|
||||
Size (lxqt-globalkeys-0.16.0.tar.xz) = 69812 bytes
|
||||
SHA1 (patch-autostart_CMakeLists.txt) = e5c4b76a3b116ee9b4781783a6ada3838f8e570c
|
||||
|
|
14
x11/lxqt-globalkeys/patches/patch-autostart_CMakeLists.txt
Normal file
14
x11/lxqt-globalkeys/patches/patch-autostart_CMakeLists.txt
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-autostart_CMakeLists.txt,v 1.1 2020/12/07 12:25:25 pin Exp $
|
||||
|
||||
Install config file to proper location
|
||||
|
||||
--- autostart/CMakeLists.txt.orig 2020-11-02 11:16:25.000000000 +0000
|
||||
+++ autostart/CMakeLists.txt
|
||||
@@ -10,6 +10,6 @@ add_custom_target(lxqt_globlalkeys_autos
|
||||
|
||||
install(FILES
|
||||
${DESKTOP_FILES}
|
||||
- DESTINATION "${LXQT_ETC_XDG_DIR}/autostart"
|
||||
+ DESTINATION "share/examples/autostart"
|
||||
COMPONENT Runtime
|
||||
)
|
Loading…
Reference in a new issue