Define TEST_TARGET; make the examples compilation use libtool, and
correct the library name on the example link line (!). XXX: 'make test' fails.
This commit is contained in:
parent
0195d76951
commit
a836f2b6fa
3 changed files with 64 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.8 2003/06/23 10:19:32 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2003/06/23 15:56:10 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gdchart0.11.4dev
|
||||
|
@ -16,6 +16,8 @@ MAKEFILE= makefile
|
|||
USE_BUILDLINK2= YES
|
||||
USE_LIBTOOL= YES
|
||||
|
||||
TEST_TARGET= gdc_samp1 gdc_samp2 gdc_pie_samp ft_samp
|
||||
|
||||
post-patch:
|
||||
for fn in ${WRKSRC}/*.[ch]; do \
|
||||
${SED} 's/^#ifdef HAVE_JPEG/#ifndef NO_JPEG/' $${fn} \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.5 2003/06/23 10:19:33 adam Exp $
|
||||
$NetBSD: distinfo,v 1.6 2003/06/23 15:56:11 wiz Exp $
|
||||
|
||||
SHA1 (gdchart0.11.4dev.tar.gz) = 639a04061c92f36140e877bc307b76878ee3f6d7
|
||||
Size (gdchart0.11.4dev.tar.gz) = 52031 bytes
|
||||
SHA1 (patch-ac) = 7fe4edb0dcf19b735918850089b1edf54f4638c9
|
||||
SHA1 (patch-ac) = 5c01ac78168b3be4a2222e5273de83a2e1db01f2
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: patch-ac,v 1.4 2003/06/23 10:19:34 adam Exp $
|
||||
$NetBSD: patch-ac,v 1.5 2003/06/23 15:56:12 wiz Exp $
|
||||
|
||||
--- makefile.orig 2003-03-11 04:03:06.000000000 +0100
|
||||
+++ makefile 2003-06-20 15:22:12.000000000 +0200
|
||||
--- makefile.orig Tue Mar 11 04:03:06 2003
|
||||
+++ makefile
|
||||
@@ -1,4 +1,4 @@
|
||||
-CC=gcc
|
||||
+LIB_OBJS= gifencode.o price_conv.o gdc.o gdc_pie.o gdchart.o array_alloc.o
|
||||
# gcc 2.7.1 or better is required
|
||||
# CFLAGS=
|
||||
# CFLAGS=-g -ansi -pedantic
|
||||
@@ -6,11 +6,11 @@
|
||||
@@ -6,11 +6,11 @@ CC=gcc
|
||||
# ----- build path -----
|
||||
GDC_INCL=./
|
||||
GDC_LD=./
|
||||
|
@ -23,7 +23,7 @@ $NetBSD: patch-ac,v 1.4 2003/06/23 10:19:34 adam Exp $
|
|||
|
||||
# INCLUDEDIRS=-I. -I/usr/include/freetype2 -I/usr/include/X11 -I/usr/X11R6/include/X11 -I/usr/local/include
|
||||
|
||||
@@ -18,9 +18,9 @@
|
||||
@@ -18,9 +18,9 @@ PREFIX_LIB = /usr/local/lib
|
||||
# GDChart requires the gd library - www.boutell.com/gd/
|
||||
# libgd 1.8.4 or better is required. Don't use 2.0.0
|
||||
# if it's not installed in a standard location edit these lines for your installation
|
||||
|
@ -36,7 +36,7 @@ $NetBSD: patch-ac,v 1.4 2003/06/23 10:19:34 adam Exp $
|
|||
# if you're using gd2.x, use these lines
|
||||
# (it's typically built as a shared lib)
|
||||
# GD_INCL = ../gd-2.0.0/
|
||||
@@ -66,7 +66,7 @@
|
||||
@@ -66,73 +66,72 @@ LIB_PATHS = -L$(GD_LD) -L$(GDC_LD)
|
||||
# LIB_PATHS = $(LIB_PATHS) -Xlinker -rpath -Xlinker $(PNG_LD) -Xlinker -rpath -Xlinker $(ZLIB_LD)
|
||||
|
||||
|
||||
|
@ -45,7 +45,58 @@ $NetBSD: patch-ac,v 1.4 2003/06/23 10:19:34 adam Exp $
|
|||
|
||||
# --- compile the samples ---
|
||||
gdc_pie_samp.o: $(GDC_INCL)gdc.h $(GDC_INCL)gdcpie.h gdc_pie_samp.c
|
||||
@@ -113,26 +113,25 @@
|
||||
- $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c gdc_pie_samp.c
|
||||
+ ${LIBTOOL} $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c gdc_pie_samp.c
|
||||
|
||||
gdc_samp1.o: $(GDC_INCL)gdc.h $(GDC_INCL)gdchart.h gdc_samp1.c
|
||||
- $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c gdc_samp1.c
|
||||
+ ${LIBTOOL} $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c gdc_samp1.c
|
||||
|
||||
gdc_samp2.o: $(GDC_INCL)gdc.h $(GDC_INCL)gdchart.h gdc_samp2.c
|
||||
- $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c gdc_samp2.c
|
||||
+ ${LIBTOOL} $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c gdc_samp2.c
|
||||
|
||||
ft_samp.o: $(GDC_INCL)gdc.h $(GDC_INCL)gdchart.h ft_samp.c
|
||||
- $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c ft_samp.c
|
||||
+ ${LIBTOOL} $(CC) $(CFLAGS) -I$(GDC_INCL) $(DEFS) -c ft_samp.c
|
||||
|
||||
# --- link the samples ---
|
||||
gdc_samp1: $(GDC_LD)libgdc.a gdc_samp1.o $(GD_LD)/$(GD_LIB) $(GDC_LD)/$(GDC_LIB)
|
||||
- $(CC) -o gdc_samp1 \
|
||||
+ ${LIBTOOL} $(CC) -o gdc_samp1 \
|
||||
gdc_samp1.o \
|
||||
$(LIB_PATHS) \
|
||||
- -lgdc -lgd -lz -lpng $(LIBS) -lm
|
||||
+ -lgdchart -lgd -lz -lpng $(LIBS) -lm
|
||||
|
||||
gdc_samp2: $(GDC_LD)libgdc.a gdc_samp2.o $(GD_LD)/$(GD_LIB) $(GDC_LD)/$(GDC_LIB)
|
||||
- $(CC) -o gdc_samp2 \
|
||||
+ ${LIBTOOL} $(CC) -o gdc_samp2 \
|
||||
gdc.o gdchart.o price_conv.o gifencode.o \
|
||||
gdc_samp2.o \
|
||||
$(LIB_PATHS) \
|
||||
- -lgdc -lgd -lz -lpng $(LIBS) -lm
|
||||
+ -lgdchart -lgd -lz -lpng $(LIBS) -lm
|
||||
|
||||
gdc_pie_samp: $(GDC_LD)libgdc.a gdc_pie_samp.o $(GD_LD)/$(GD_LIB) $(GDC_LD)/$(GDC_LIB)
|
||||
- $(CC) -o gdc_pie_samp \
|
||||
+ ${LIBTOOL} $(CC) -o gdc_pie_samp \
|
||||
gdc.o gdc_pie.o price_conv.o gifencode.o \
|
||||
gdc_pie_samp.o \
|
||||
$(LIB_PATHS) \
|
||||
- -lgdc -lgd -lz -lpng $(LIBS) -lm
|
||||
+ -lgdchart -lgd -lz -lpng $(LIBS) -lm
|
||||
|
||||
ft_samp: $(GDC_LD)libgdc.a ft_samp.o $(GD_LD)/$(GD_LIB) $(GDC_LD)/$(GDC_LIB)
|
||||
- $(CC) -o ft_samp \
|
||||
+ ${LIBTOOL} $(CC) -o ft_samp \
|
||||
gdc.o gdchart.o price_conv.o gifencode.o \
|
||||
ft_samp.o \
|
||||
$(LIB_PATHS) \
|
||||
- -lgdc -lgd -lz -lpng $(LIBS) -lm
|
||||
+ -lgdchart -lgd -lz -lpng $(LIBS) -lm
|
||||
|
||||
# --- compile the lib ---
|
||||
gdc.h: $(GD_INCL)gd.h $(GD_INCL)gdfonts.h $(GD_INCL)gdfontt.h $(GD_INCL)gdfontmb.h $(GD_INCL)gdfontg.h $(GD_INCL)gdfontl.h $(GDC_INCL)gifencode.h $(GDC_INCL)array_alloc.h
|
||||
|
||||
gifencode.o: gifencode.c gifencode.h $(GDC_INCL)gdc.h
|
||||
|
@ -80,7 +131,7 @@ $NetBSD: patch-ac,v 1.4 2003/06/23 10:19:34 adam Exp $
|
|||
|
||||
# --- supporting libraries ---
|
||||
# should be compile & installed separately
|
||||
@@ -140,9 +139,9 @@
|
||||
@@ -140,9 +139,9 @@ libgdc.a: gifencode.o price_conv.o gdc.o
|
||||
# cd $(GD_LD) ; make -f Makefile $(GD_LIB)
|
||||
|
||||
# ----- install -----
|
||||
|
|
Loading…
Reference in a new issue