Add DragonFly support. Fix errno.
This commit is contained in:
parent
c96b08eb0a
commit
a8c4256ca7
3 changed files with 62 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/02/24 12:14:03 agc Exp $
|
||||
$NetBSD: distinfo,v 1.7 2005/12/07 03:45:21 joerg Exp $
|
||||
|
||||
SHA1 (radiusd-cistron-1.6.7.tar.gz) = 54c6e08a0c82a8d16928c1410bf50f6a50ef7d99
|
||||
RMD160 (radiusd-cistron-1.6.7.tar.gz) = 12292d77c644b1f935a88e64135f3be9037bcf6f
|
||||
|
@ -6,4 +6,6 @@ Size (radiusd-cistron-1.6.7.tar.gz) = 198927 bytes
|
|||
SHA1 (patch-aa) = 53f331bde823f23a869c779df92a6e400a204746
|
||||
SHA1 (patch-ab) = a877e273f3d12228d4d0d6064115c5f55c044ad3
|
||||
SHA1 (patch-ac) = 95053cdb7cc8a1672d32a953147074ea948e535b
|
||||
SHA1 (patch-ad) = 32b8246f3303373139f8e0da1c5250088e6afd41
|
||||
SHA1 (patch-ae) = 2049cfa99b6392ed178e11e283b2749df819a35c
|
||||
SHA1 (patch-af) = 7d2973054817eb8eae320a8a1a026f658e1cc70f
|
||||
|
|
15
net/radiusd-cistron/patches/patch-ad
Normal file
15
net/radiusd-cistron/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.1 2005/12/07 03:45:21 joerg Exp $
|
||||
|
||||
--- src/radiusd.c.orig 2005-12-07 03:33:06.000000000 +0000
|
||||
+++ src/radiusd.c
|
||||
@@ -78,10 +78,6 @@ static time_t start_time;
|
||||
static AUTH_REQ *first_request;
|
||||
|
||||
|
||||
-#if !defined(__linux__) && !defined(__GNU_LIBRARY__)
|
||||
-extern int errno;
|
||||
-#endif
|
||||
-
|
||||
typedef int (*FUNP)(AUTH_REQ *, int);
|
||||
|
||||
static int config_init(void);
|
44
net/radiusd-cistron/patches/patch-ae
Normal file
44
net/radiusd-cistron/patches/patch-ae
Normal file
|
@ -0,0 +1,44 @@
|
|||
$NetBSD: patch-ae,v 1.1 2005/12/07 03:45:21 joerg Exp $
|
||||
|
||||
--- src/sysdep.h.orig 2005-12-07 03:35:42.000000000 +0000
|
||||
+++ src/sysdep.h
|
||||
@@ -13,7 +13,7 @@
|
||||
|
||||
#ifdef __GNUC__
|
||||
# define USE_LONGLONG 1
|
||||
-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi)
|
||||
+# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi) || defined(__DragonFly__)
|
||||
# define PERCENT_LONGLONG "%qu"
|
||||
# elif defined(__linux__)
|
||||
# define PERCENT_LONGLONG "%Lu"
|
||||
@@ -22,7 +22,7 @@
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi) || defined(M_UNIX)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi) || defined(M_UNIX) || defined(__DragonFly__)
|
||||
# ifndef NOSHADOW
|
||||
# define NOSHADOW
|
||||
# endif
|
||||
@@ -44,11 +44,7 @@ typedef unsigned long long UINT8;
|
||||
#include <string.h>
|
||||
#endif
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(bsdi)
|
||||
-# include <stdlib.h>
|
||||
-#else
|
||||
-# include <malloc.h>
|
||||
-#endif /* FreeBSD */
|
||||
+#include <stdlib.h>
|
||||
|
||||
#if defined(aix)
|
||||
#include <sys/select.h>
|
||||
@@ -83,7 +79,7 @@ typedef unsigned long long UINT8;
|
||||
# define __hpux__
|
||||
# endif
|
||||
#endif
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi) || defined(__DragonFly__)
|
||||
# ifndef UTMP_FILE
|
||||
# define UTMP_FILE "/var/run/utmp"
|
||||
# endif
|
Loading…
Reference in a new issue