A preexisting pkgsrc patch changed the "man page output suffix" from
.3o to just .3, so adapt this test's Makefile to follow suit. Brings the number of failing self-tests down from 1 to 0. Bump PKGREVISION.
This commit is contained in:
parent
713ecd4bb7
commit
a8dee92893
3 changed files with 29 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.109 2017/07/11 17:15:01 he Exp $
|
||||
# $NetBSD: Makefile,v 1.110 2017/07/12 07:52:28 he Exp $
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
|
||||
CONFIGURE_ENV+= disable_x11=yes
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.105 2017/07/11 17:15:01 he Exp $
|
||||
$NetBSD: distinfo,v 1.106 2017/07/12 07:52:28 he Exp $
|
||||
|
||||
SHA1 (ocaml-4.04.2.tar.gz) = 24281675ea90c9234e323d556f1d4cd7bdab8ec1
|
||||
RMD160 (ocaml-4.04.2.tar.gz) = 3d8f78cd544815233f814a0e24eba8d3c948b190
|
||||
|
@ -25,6 +25,7 @@ SHA1 (patch-otherlibs_systhreads_Makefile) = d731864c613383b36846cae4961b7a221bd
|
|||
SHA1 (patch-otherlibs_threads_Makefile) = 47331a06a93eac68403fa2114495782430087f1e
|
||||
SHA1 (patch-stdlib_Makefile) = 67591b1809dd72aac446238491e371d135466734
|
||||
SHA1 (patch-stdlib_Makefile.shared) = dac87da3b0461a2c816b862af3a0c0bdf740b749
|
||||
SHA1 (patch-testsuite_tests_tool-ocamldoc-man_Makefile) = 41c7d6ffa98ed4f4fe261d6ed890be045c55adaf
|
||||
SHA1 (patch-tools_Makefile.shared) = 517137929c9941df305f7f14ba5f17ec9e012822
|
||||
SHA1 (patch-tools_ocamlcp.ml) = 299c84c169bacfe0315a986d739b3e61d2491289
|
||||
SHA1 (patch-tools_ocamlmklib) = 49ea077e3f77527336548ae6515d135461b83080
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-testsuite_tests_tool-ocamldoc-man_Makefile,v 1.1 2017/07/12 07:52:28 he Exp $
|
||||
|
||||
Hm, the output lands in a different file than what the make job
|
||||
expects. The result is however as expected when that is taken into
|
||||
account.
|
||||
|
||||
--- testsuite/tests/tool-ocamldoc-man/Makefile.orig 2017-07-12 07:22:07.000000000 +0000
|
||||
+++ testsuite/tests/tool-ocamldoc-man/Makefile
|
||||
@@ -39,7 +39,7 @@ run: *.mli
|
||||
F="`basename $$file .mli`"; \
|
||||
$(OCAMLDOC) $(DOCFLAGS) -hide-warnings -man $ \
|
||||
-o index $$file; \
|
||||
- tail -n +2 $$F.3o > $$F.result; \
|
||||
+ tail -n +2 $$F.3 > $$F.result; \
|
||||
$(DIFF) $$F.reference $$F.result >/dev/null \
|
||||
&& echo " => passed" || echo " => failed"; \
|
||||
done
|
||||
@@ -49,6 +49,6 @@ promote: defaultpromote
|
||||
|
||||
.PHONY: clean
|
||||
clean: defaultclean
|
||||
- @rm -f *.result *.html *.tex *.log *.out *.sty *.toc *.css *.aux *.3o
|
||||
+ @rm -f *.result *.html *.tex *.log *.out *.sty *.toc *.css *.aux *.3
|
||||
|
||||
include $(BASEDIR)/makefiles/Makefile.common
|
Loading…
Reference in a new issue