Fix build with clang.
This commit is contained in:
parent
633d128feb
commit
a8f9d4cd0b
2 changed files with 11 additions and 30 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/11/25 21:29:31 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/05/04 16:00:00 joerg Exp $
|
||||
|
||||
SHA1 (adplug-2.1.tar.bz2) = 49dd798467f194ece1863f18019912f8089cb9df
|
||||
RMD160 (adplug-2.1.tar.bz2) = 8788c174507fe39d3415f36e1ac60df6b84c889f
|
||||
Size (adplug-2.1.tar.bz2) = 730686 bytes
|
||||
SHA1 (patch-adplugdb_adplugdb_cpp) = 06471351d5b263e515b115960ec0e3d3564dbd16
|
||||
SHA1 (patch-src_fmopl_c) = 39001c766492684323fb6b7f1f87b519ee084943
|
||||
SHA1 (patch-src_fmopl_c) = e5a081da04b9935a6c146c487bf578a5a78e5436
|
||||
SHA1 (patch-src_player.h) = a1bf12c872a244d56fa0cd776ecd22cc5af3bca4
|
||||
|
|
|
@ -1,34 +1,15 @@
|
|||
$NetBSD: patch-src_fmopl_c,v 1.1 2011/09/12 05:08:53 dholland Exp $
|
||||
$NetBSD: patch-src_fmopl_c,v 1.2 2012/05/04 16:00:01 joerg Exp $
|
||||
|
||||
- sprinkle static on inline functions not used outside this file, to
|
||||
fix clang build.
|
||||
Redefine INLINE to cover all inline functions for compilers with C99 semantic.
|
||||
|
||||
--- src/fmopl.c~ 2006-05-13 05:36:42.000000000 +0000
|
||||
+++ src/fmopl.c
|
||||
@@ -388,7 +388,7 @@ INLINE void CALC_FCSLOT(OPL_CH *CH,OPL_S
|
||||
}
|
||||
@@ -31,7 +31,7 @@
|
||||
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
/* set multi,am,vib,EG-TYP,KSR,mul */
|
||||
-INLINE void set_mul(FM_OPL *OPL,int slot,int v)
|
||||
+static INLINE void set_mul(FM_OPL *OPL,int slot,int v)
|
||||
{
|
||||
OPL_CH *CH = &OPL->P_CH[slot/2];
|
||||
OPL_SLOT *SLOT = &CH->SLOT[slot&1];
|
||||
@@ -452,7 +452,7 @@ INLINE void set_sl_rr(FM_OPL *OPL,int sl
|
||||
/* operator output calcrator */
|
||||
#define OP_OUT(slot,env,con) slot->wavetable[((slot->Cnt+con)/(0x1000000/SIN_ENT))&(SIN_ENT-1)][env]
|
||||
/* ---------- calcrate one of channel ---------- */
|
||||
-INLINE void OPL_CALC_CH( OPL_CH *CH )
|
||||
+static INLINE void OPL_CALC_CH( OPL_CH *CH )
|
||||
{
|
||||
UINT32 env_out;
|
||||
OPL_SLOT *SLOT;
|
||||
@@ -497,7 +497,7 @@ INLINE void OPL_CALC_CH( OPL_CH *CH )
|
||||
-#define INLINE __inline
|
||||
+#define INLINE static __inline
|
||||
#define HAS_YM3812 1
|
||||
|
||||
/* ---------- calcrate rythm block ---------- */
|
||||
#define WHITE_NOISE_db 6.0
|
||||
-INLINE void OPL_CALC_RH( OPL_CH *CH )
|
||||
+static INLINE void OPL_CALC_RH( OPL_CH *CH )
|
||||
{
|
||||
UINT32 env_tam,env_sd,env_top,env_hh;
|
||||
int whitenoise = (rand()&1)*(WHITE_NOISE_db/EG_STEP);
|
||||
#include <stdio.h>
|
||||
|
|
Loading…
Reference in a new issue