Update enma to 1.1.0.

* support DKIM (verification only) and DKIM ADSP
    * support exclusion address list to avoid authentication
This commit is contained in:
obache 2009-04-09 02:25:37 +00:00
parent a3a6ac9e15
commit a93047a4a8
7 changed files with 35 additions and 43 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/09/05 07:23:44 obache Exp $
# $NetBSD: Makefile,v 1.2 2009/04/09 02:25:37 obache Exp $
#
DISTNAME= enma-1.0.0
DISTNAME= enma-1.1.0
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=enma/}
@ -50,12 +50,16 @@ SUBST_SED.daemon= -e 's;daemon;${ENMA_USER};g'
OWN_DIRS_PERMS+= ${VARBASE}/run/enma ${ENMA_USER} ${ENMA_GROUP} 0700
INSTALLATION_DIRS+= ${PKGMANDIR}/ja_JP.EUC/man1
INSTALLATION_DIRS+= share/examples/enma
post-install:
${INSTALL_MAN} ${WRKSRC}/enma/man/enma.ja.1 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/ja_JP.EUC/man1/enma.1
${INSTALL_DATA} ${WRKSRC}/enma/etc/enma.conf.sample \
${DESTDIR}${PREFIX}/share/examples/enma/enma.conf.sample
.include "../../mail/libmilter/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.if ${OPSYS} == "DragonFly"
USE_BUILTIN.resolv= no
.endif
.include "../../mk/resolv.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,8 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/09/05 07:23:44 obache Exp $
bin/enma
@comment $NetBSD: PLIST,v 1.2 2009/04/09 02:25:37 obache Exp $
bin/sidfquery
man/ja_JP.EUC/man1/enma.1
libexec/enma
man/ja_JP.UTF-8/man1/enma.1
man/man1/enma.1
share/examples/enma/enma.conf.sample
share/examples/rc.d/enma
@dirrm share/examples/enma

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2008/09/05 07:23:44 obache Exp $
$NetBSD: distinfo,v 1.2 2009/04/09 02:25:37 obache Exp $
SHA1 (enma-1.0.0.tar.gz) = a792ea302df81aec7940dae8665584086145ec15
RMD160 (enma-1.0.0.tar.gz) = 35a9ff9ad0594561d9597788ddaca2b7d1ef8721
Size (enma-1.0.0.tar.gz) = 161566 bytes
SHA1 (patch-aa) = 0ab42bca38fbc52a1fffe00f9809da67ffb76eda
SHA1 (patch-ab) = 2f6413b6c167198de118741c41f29c6bf76b1f06
SHA1 (enma-1.1.0.tar.gz) = 4fe05c3a5f3cc7c1758958123c6ef6e56cdc803d
RMD160 (enma-1.1.0.tar.gz) = e30a301298a05aed0d347a37a2dfcd1a7ee9d863
Size (enma-1.1.0.tar.gz) = 238176 bytes
SHA1 (patch-ac) = 5ca90712fb1b2178b9dc77231f1772bac7e1fa85

View file

@ -1,6 +1,6 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: enma.sh,v 1.1.1.1 2008/09/05 07:23:44 obache Exp $
# $NetBSD: enma.sh,v 1.2 2009/04/09 02:25:37 obache Exp $
#
# PROVIDE: enma
# REQUIRE: NETWORK
@ -10,7 +10,7 @@
name="enma"
rcvar=${name}
command="@PREFIX@/bin/enma"
command="@PREFIX@/libexec/enma"
pidfile="@VARBASE@/run/enma/${name}.pid"
required_files="@PKG_SYSCONFDIR@/enma.conf"
command_args="-c @PKG_SYSCONFDIR@/enma.conf"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/09/05 07:23:44 obache Exp $
--- libsidf/src/sidfrequest.c.orig 2008-08-13 15:44:32.000000000 +0000
+++ libsidf/src/sidfrequest.c
@@ -18,6 +18,7 @@ RCSID("$Id: sidfrequest.c 348 2008-08-13
#include <assert.h>
#include <sys/socket.h>
#include <arpa/nameser.h>
+#include <netinet/in.h>
#include <netdb.h>
#include <resolv.h>
// #include <isc/misc.h>

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2008/09/05 07:23:44 obache Exp $
--- enma/etc/Makefile.in.orig 2008-08-21 14:22:29.000000000 +0000
+++ enma/etc/Makefile.in
@@ -29,8 +29,8 @@ OBJS := $(patsubst %.c,%.o,$(SRCS))
all:
install:
- $(INSTALL) -d $(sysconfdir)
- $(INSTALL_DATA) -c enma.conf.sample $(sysconfdir)
+ $(INSTALL) -d $(DESTDIR)$(sysconfdir)
+ $(INSTALL_DATA) -c enma.conf.sample $(DESTDIR)$(sysconfdir)
clean:
rm -rf *~

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ac,v 1.1 2009/04/09 02:25:38 obache Exp $
--- configure.orig 2009-03-02 05:01:02.000000000 +0000
+++ configure
@@ -4170,8 +4170,8 @@ fi
CFLAGS="$CFLAGS -std=gnu99 -Wall -Wextra"
-CPPFLAGS="$CPPFLAGS -I$includedir -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS"
-LDFLAGS="$LDFLAGS -L$libdir -lpthread"
+CPPFLAGS="$CPPFLAGS -I$includedir $PTHREAD_CFLAGS"
+LDFLAGS="$LDFLAGS -L$libdir $PTHREAD_LDFLAGS $PTHREAD_LIBS"
{ echo "$as_me:$LINENO: checking for __res_ndestroy in -lbind" >&5
echo $ECHO_N "checking for __res_ndestroy in -lbind... $ECHO_C" >&6; }