Add initial DragonFly support. Not tested yet.
This commit is contained in:
parent
e59a77899b
commit
a93f35c867
7 changed files with 105 additions and 6 deletions
|
@ -1,7 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.5 2007/01/26 17:38:31 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.6 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
SHA1 (xorg-server-1.2.0.tar.bz2) = 85fa0e8fa7d6bea6f1a73c66a57488ea68dffa17
|
||||
RMD160 (xorg-server-1.2.0.tar.bz2) = 0bbc5ccb5cbbe7627b4f09f17848b188e8be2a50
|
||||
Size (xorg-server-1.2.0.tar.bz2) = 6014596 bytes
|
||||
SHA1 (patch-ab) = be6748cac5db41bab46d02e2d8ab75bed6e11aa8
|
||||
SHA1 (patch-ab) = 115905eba320f294c68783bb704359d824460469
|
||||
SHA1 (patch-ad) = 67a94598ac23c23688caba23b851aec317a9e7a3
|
||||
SHA1 (patch-da) = 73faacda1088304025c5e05f3d58edaf9ae1145f
|
||||
SHA1 (patch-db) = 28913a094c8499536a71c8d4d7ca57a5efb25b39
|
||||
SHA1 (patch-dc) = 75df6f37b1cbc9574adb5ee66cb84d0f5ebac853
|
||||
SHA1 (patch-dd) = 4d0fd341ccfe1f1240faa8912beea3f15dc39207
|
||||
SHA1 (patch-de) = f887f3fd09406006b6165779b74be780b7fddd18
|
||||
|
|
|
@ -1,8 +1,28 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2006/11/14 16:59:30 joerg Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
--- configure.orig 2006-07-08 01:46:19.000000000 +0200
|
||||
--- configure.orig 2007-01-23 05:40:03.000000000 +0000
|
||||
+++ configure
|
||||
@@ -24340,6 +24340,11 @@ _ACEOF
|
||||
@@ -24300,6 +24300,10 @@ _ACEOF
|
||||
#define USE_DEV_IO 1
|
||||
_ACEOF
|
||||
;;
|
||||
+ *dragonfly*) cat >>confdefs.h <<\_ACEOF
|
||||
+#define USE_DEV_IO 1
|
||||
+_ACEOF
|
||||
+ ;;
|
||||
*netbsd*) cat >>confdefs.h <<\_ACEOF
|
||||
#define USE_I386_IOPL 1
|
||||
_ACEOF
|
||||
@@ -24406,7 +24410,7 @@ fi
|
||||
DRI=no
|
||||
KDRIVE_HW=no
|
||||
case $host_os in
|
||||
- *freebsd*)
|
||||
+ *freebsd* | *dragonfly*)
|
||||
case $host_os in
|
||||
kfreebsd*-gnu) ;;
|
||||
*)
|
||||
@@ -24445,6 +24449,11 @@ _ACEOF
|
||||
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
|
@ -14,7 +34,7 @@ $NetBSD: patch-ab,v 1.1.1.1 2006/11/14 16:59:30 joerg Exp $
|
|||
#define WSCONS_SUPPORT 1
|
||||
_ACEOF
|
||||
|
||||
@@ -27910,7 +27915,7 @@ _ACEOF
|
||||
@@ -27892,7 +27901,7 @@ _ACEOF
|
||||
|
||||
fi
|
||||
|
||||
|
@ -23,3 +43,12 @@ $NetBSD: patch-ab,v 1.1.1.1 2006/11/14 16:59:30 joerg Exp $
|
|||
|
||||
if test $VERSION_SNAP = "0"; then
|
||||
if test $VERSION_PATCH = "0"; then
|
||||
@@ -30642,7 +30651,7 @@ cat >>confdefs.h <<_ACEOF
|
||||
_ACEOF
|
||||
|
||||
;;
|
||||
- freebsd* | kfreebsd*-gnu)
|
||||
+ freebsd* | kfreebsd*-gnu | dragonfly*)
|
||||
XORG_OS="freebsd"
|
||||
XORG_OS_SUBDIR="bsd"
|
||||
XORG_OS_KBD="BSD"
|
||||
|
|
13
x11/modular-xorg-server/patches/patch-da
Normal file
13
x11/modular-xorg-server/patches/patch-da
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-da,v 1.1 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
--- Xext/shm.c.orig 2007-02-05 20:58:14.000000000 +0000
|
||||
+++ Xext/shm.c
|
||||
@@ -156,7 +156,7 @@ static ShmFuncs fbFuncs = {fbShmCreatePi
|
||||
}
|
||||
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__) || defined(__DragonFly__)
|
||||
#include <sys/signal.h>
|
||||
|
||||
static Bool badSysCall = FALSE;
|
13
x11/modular-xorg-server/patches/patch-db
Normal file
13
x11/modular-xorg-server/patches/patch-db
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-db,v 1.1 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
--- Xext/xf86bigfont.c.orig 2007-02-05 21:02:23.000000000 +0000
|
||||
+++ Xext/xf86bigfont.c
|
||||
@@ -104,7 +104,7 @@ static unsigned int pagesize;
|
||||
|
||||
static Bool badSysCall = FALSE;
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__) || defined(__DragonFly__)
|
||||
|
||||
#include <sys/signal.h>
|
||||
|
13
x11/modular-xorg-server/patches/patch-dc
Normal file
13
x11/modular-xorg-server/patches/patch-dc
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-dc,v 1.1 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
--- hw/xfree86/loader/os.c.orig 2007-02-05 21:03:59.000000000 +0000
|
||||
+++ hw/xfree86/loader/os.c
|
||||
@@ -42,6 +42,8 @@
|
||||
#define OSNAME "linux"
|
||||
#elif defined(__FreeBSD__)
|
||||
#define OSNAME "freebsd"
|
||||
+#elif defined(__DragonFly__)
|
||||
+#define OSNAME "dragonfly"
|
||||
#elif defined(__NetBSD__)
|
||||
#define OSNAME "netbsd"
|
||||
#elif defined(__OpenBSD__)
|
13
x11/modular-xorg-server/patches/patch-dd
Normal file
13
x11/modular-xorg-server/patches/patch-dd
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-dd,v 1.1 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
--- hw/xfree86/os-support/bus/Pci.h.orig 2007-02-05 21:08:10.000000000 +0000
|
||||
+++ hw/xfree86/os-support/bus/Pci.h
|
||||
@@ -235,7 +235,7 @@
|
||||
# if defined(linux)
|
||||
# define ARCH_PCI_INIT axpPciInit
|
||||
# define INCLUDE_XF86_MAP_PCI_MEM
|
||||
-# elif defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
+# elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
|
||||
# define ARCH_PCI_INIT freebsdPciInit
|
||||
# define INCLUDE_XF86_MAP_PCI_MEM
|
||||
# define INCLUDE_XF86_NO_DOMAIN
|
13
x11/modular-xorg-server/patches/patch-de
Normal file
13
x11/modular-xorg-server/patches/patch-de
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-de,v 1.1 2007/02/05 23:08:36 joerg Exp $
|
||||
|
||||
--- hw/xfree86/os-support/bus/freebsdPci.c.orig 2007-02-05 21:09:30.000000000 +0000
|
||||
+++ hw/xfree86/os-support/bus/freebsdPci.c
|
||||
@@ -83,7 +83,7 @@ static pciBusInfo_t freebsdPci0 = {
|
||||
/* bridge */ NULL
|
||||
};
|
||||
|
||||
-#if !defined(__OpenBSD__) && !defined(__FreeBSD__)
|
||||
+#if !defined(__OpenBSD__) && !defined(__FreeBSD__) && !defined(__DragonFly__)
|
||||
#if X_BYTE_ORDER == X_BIG_ENDIAN
|
||||
#ifdef __sparc__
|
||||
#ifndef ASI_PL
|
Loading…
Reference in a new issue