Update clamav to 0.60. Note the new home is sourceforge.
Also fix pkg/22714, clamav not building, this was due to it rerunning configure due to dependancy updates, which built a new libtool, replacing the one we had given it from pkgsrc. The fix is to run autoconf and automake on the patches, I would have done diff's post autoconf/automake, but the diffs are much bigger. Known issue, if you run fetchclam to update the databases you'll find that pkg_install won't remove the db files as the MD5 checksum has changed, I may move the db files into etc/clamav and copy them in, then fetchclam can update as needed. However I thought that given the current spate of viruses hitting people they maybe wanting the latest version.
This commit is contained in:
parent
1a82140103
commit
a95a4cfe8b
5 changed files with 57 additions and 49 deletions
|
@ -1,21 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.3 2003/06/07 17:39:15 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2003/09/20 01:27:17 chris Exp $
|
||||
|
||||
DISTNAME= clamav-0.54
|
||||
PKGREVISION= 2
|
||||
DISTNAME= clamav-0.60
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://clamav.elektrapro.com/stable/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=clamav/}
|
||||
|
||||
MAINTAINER= david@netbsd-fr.org
|
||||
HOMEPAGE= http://clamav.elektrapro.com/stable
|
||||
HOMEPAGE= http://clamav.elektrapro.com/
|
||||
COMMENT= Anti-virus toolkit
|
||||
|
||||
AUTOCONF_REQD= 2.53 # clamav used 2.53
|
||||
USE_BUILDLINK2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGINSTALL= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
# disable the configure check for user and group:
|
||||
CONFIGURE_ARGS+= --disable-clamav
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
CONFIGURE_ARGS+= --with-uid=${CLAMAV_USER}
|
||||
CONFIGURE_ARGS+= --with-group=${CLAMAV_GROUP}
|
||||
|
||||
BUILD_DEFS+= CLAMAV_USER CLAMAV_GROUP
|
||||
|
||||
PKG_GROUPS+= ${CLAMAV_GROUP}
|
||||
PKG_USERS+= ${CLAMAV_USER}:${CLAMAV_GROUP}::Clamav\\ User
|
||||
|
@ -24,12 +29,19 @@ EGDIR= ${PREFIX}/share/examples/clamav
|
|||
CONF_FILES= ${EGDIR}/clamav.conf ${PKG_SYSCONFDIR}/clamav.conf
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC}; ${AUTOCONF}
|
||||
cd ${WRKSRC}; \
|
||||
${ACLOCAL}; \
|
||||
${AUTOMAKE} -a --foreign -i; \
|
||||
${AUTOCONF}
|
||||
|
||||
# Remove the "annoying" strings.h in libclamav
|
||||
pre-build:
|
||||
${RM} ${WRKSRC}/libclamav/strings.h
|
||||
# for freshclam to work it must own the share/clamav dir
|
||||
post-install:
|
||||
${CHOWN} -R ${CLAMAV_USER}:${CLAMAV_GROUP} ${PREFIX}/share/examples/clamav
|
||||
|
||||
.include "../../devel/zlib/buildlink2.mk"
|
||||
.include "../../mail/libmilter/buildlink2.mk"
|
||||
.include "../../archivers/bzip2/buildlink2.mk"
|
||||
.include "../../mk/pthread.buildlink2.mk"
|
||||
.include "../../mk/autoconf.mk"
|
||||
.include "../../mk/automake.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2003/06/07 17:39:15 jmmv Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2003/09/20 01:27:18 chris Exp $
|
||||
bin/clamdscan
|
||||
bin/clamscan
|
||||
bin/freshclam
|
||||
bin/sigtool
|
||||
|
@ -7,13 +8,16 @@ lib/libclamav.a
|
|||
lib/libclamav.la
|
||||
lib/libclamav.so
|
||||
lib/libclamav.so.1
|
||||
lib/libclamav.so.1.2
|
||||
lib/libclamav.so.1.3
|
||||
man/man1/clamav-milter.1
|
||||
man/man1/clamdscan.1
|
||||
man/man1/clamscan.1
|
||||
man/man1/freshclam.1
|
||||
man/man1/sigtool.1
|
||||
man/man5/clamav.conf.5
|
||||
man/man8/clamd.8
|
||||
sbin/clamd
|
||||
share/clamav/mirrors.txt
|
||||
share/clamav/viruses.db
|
||||
share/clamav/viruses.db2
|
||||
share/examples/clamav/clamav.conf
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2003/06/07 17:39:15 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.3 2003/09/20 01:27:18 chris Exp $
|
||||
|
||||
SHA1 (clamav-0.54.tar.gz) = 895d96c56667e037479f918064b9ac4fd2a4604a
|
||||
Size (clamav-0.54.tar.gz) = 985170 bytes
|
||||
SHA1 (patch-aa) = 679df954d958046af7175af3d1ec5b759d3dae15
|
||||
SHA1 (patch-ab) = e0858b7d2f716a8aded21e96c968cd2d9fef22e0
|
||||
SHA1 (clamav-0.60.tar.gz) = d72547dc3027fcdd76ad9a4b6edd3aa655534e1c
|
||||
Size (clamav-0.60.tar.gz) = 1018727 bytes
|
||||
SHA1 (patch-aa) = 715de1a92ba5b148cebdd92c812d18cf9367c8bb
|
||||
SHA1 (patch-ab) = 0d1ef00c0c1c64642461e353f7e4ed7f81e3a042
|
||||
|
|
|
@ -1,33 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.2 2003/06/07 17:39:15 jmmv Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2003/09/20 01:27:19 chris Exp $
|
||||
|
||||
--- configure.in.orig Thu Nov 21 01:43:16 2002
|
||||
+++ configure.in Tue Mar 11 17:48:07 2003
|
||||
@@ -137,12 +137,7 @@
|
||||
AC_SUBST(DBDIR)
|
||||
|
||||
# config file
|
||||
-cfg_dir=`echo $sysconfdir | grep prefix`
|
||||
-if test -n "$cfg_dir"; then
|
||||
- cfg_dir="$ac_default_prefix/etc"
|
||||
-else
|
||||
- cfg_dir="$sysconfdir"
|
||||
-fi
|
||||
+cfg_dir=$sysconfdir
|
||||
|
||||
CFGDIR=$cfg_dir
|
||||
AC_SUBST(CFGDIR)
|
||||
@@ -224,9 +219,13 @@
|
||||
--- configure.in.orig 2003-09-20 00:27:32.000000000 +0100
|
||||
+++ configure.in 2003-09-20 00:32:19.000000000 +0100
|
||||
@@ -255,8 +255,12 @@
|
||||
AC_DEFINE(C_BSD)
|
||||
;;
|
||||
netbsd*)
|
||||
- AC_MSG_RESULT(NetBSD detected. Disabling thread support.)
|
||||
+ AC_MSG_RESULT(NetBSD detected. Adding pth stuff.)
|
||||
have_pthreads="no"
|
||||
- have_pthreads="no"
|
||||
+ if test "$have_pthreads" = "yes"; then
|
||||
+ LIBCLAMAV_LIBS="$LIBCLAMAV_LIBS -lpthread"
|
||||
+ CLAMD_LIBS="-lpthread"
|
||||
+ TH_SAFE="-thread-safe"
|
||||
+ AC_DEFINE(CL_THREAD_SAFE)
|
||||
+ fi
|
||||
AC_DEFINE(C_BSD)
|
||||
+ LIBCLAMAV_LIBS="$LIBCLAMAV_LIBS $LDFLAGS -lpthread"
|
||||
+ AC_DEFINE(CL_THREAD_SAFE)
|
||||
+ CLAMD_LIBS="-lpthread $LDFLAGS"
|
||||
+ CFLAGS="$CFLAGS"
|
||||
;;
|
||||
bsd*)
|
||||
AC_MSG_RESULT(Unknown BSD detected. Disabling thread support.)
|
||||
|
|
|
@ -1,13 +1,19 @@
|
|||
$NetBSD: patch-ab,v 1.1 2003/06/07 17:39:15 jmmv Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2003/09/20 01:27:19 chris Exp $
|
||||
|
||||
--- etc/Makefile.in.orig 2002-11-21 01:44:02.000000000 +0100
|
||||
+++ etc/Makefile.in
|
||||
@@ -118,7 +118,7 @@ am__quote = @am__quote@
|
||||
install_sh = @install_sh@
|
||||
--- etc/Makefile.am.orig 2000-02-16 20:21:00.000000000 +0000
|
||||
+++ etc/Makefile.am 2003-09-20 01:30:31.000000000 +0100
|
||||
@@ -18,11 +18,11 @@
|
||||
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
|
||||
EXTRA_DIST = clamav.conf
|
||||
-CFGINST = @CFGDIR@
|
||||
+CFGINST = $(datadir)/examples/clamav
|
||||
subdir = etc
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_CLEAN_FILES =
|
||||
|
||||
if INSTALL_CONF
|
||||
|
||||
install:
|
||||
- $(mkinstalldirs) $(DESTDIR)$(CFGINST)
|
||||
- @$(INSTALL_DATA) clamav.conf $(DESTDIR)$(CFGINST)
|
||||
+ $(mkinstalldirs) $(CFGINST)
|
||||
+ @$(INSTALL_DATA) clamav.conf $(CFGINST)
|
||||
endif
|
||||
|
|
Loading…
Reference in a new issue