Don't leak newly allocated memory. Bump revision.

This commit is contained in:
joerg 2013-12-08 22:33:33 +00:00
parent 437f2de71e
commit a95edc4af4
3 changed files with 20 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.42 2013/10/19 09:07:08 adam Exp $
# $NetBSD: Makefile,v 1.43 2013/12/08 22:33:33 joerg Exp $
#
DISTNAME= fuppes-0.660
PKGREVISION= 10
PKGREVISION= 11
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=fuppes/}

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.6 2013/04/30 22:34:31 joerg Exp $
$NetBSD: distinfo,v 1.7 2013/12/08 22:33:33 joerg Exp $
SHA1 (fuppes-0.660.tar.gz) = ca729343754e0d775fb8291fda8b3ac64ef64df2
RMD160 (fuppes-0.660.tar.gz) = 4a1f278fd4cb00d80ce2efae57201aaa73d11840
Size (fuppes-0.660.tar.gz) = 685373 bytes
SHA1 (patch-include_fuppes__plugin.h) = bfe692659f2b2033c5acf197845c3adfc9ed516f
SHA1 (patch-src_lib_Common_Common.cpp) = c9f1cfd036c9e5b95065bd28d75c497edfbfe32f
SHA1 (patch-src_lib_HTTP_HTTPParser.cpp) = ddc3feba5a0d381dd2896f18943a946b556f2812
SHA1 (patch-src_plugins_database__sqlite3.cpp) = 99408f855d5d0f09d8b620785022a205a7c1f621

View file

@ -0,0 +1,16 @@
$NetBSD: patch-include_fuppes__plugin.h,v 1.1 2013/12/08 22:33:33 joerg Exp $
--- include/fuppes_plugin.h.orig 2013-12-08 20:21:31.000000000 +0000
+++ include/fuppes_plugin.h
@@ -57,9 +57,9 @@ static inline arg_list_t* arg_list_creat
arg_list_t* list = (arg_list_t*)malloc(sizeof(arg_list_t));
list->key = (char*)malloc(sizeof(char));
- list->key = '\0';
+ list->key[0] = '\0';
list->value = (char*)malloc(sizeof(char));
- list->value = '\0';
+ list->value[0] = '\0';
list->next = NULL;