lang/php82: update to 8.2.17

PHP 8.2.17 (2024-03-14)

- Core:
  . Fix ZTS persistent resource crashes on shutdown. (nielsdos)

- Curl:
  . Fix failing tests due to string changes in libcurl 8.6.0. (Ayesh)

- DOM:
  . Fix reference access in dimensions for DOMNodeList and DOMNodeMap.
    (nielsdos)

- Fileinfo:
  . Fixed bug GH-13344 (finfo::buffer(): Failed identify data 0:(null),
    backport). (nielsdos)

- FPM:
  . Fixed bug #75712 (getenv in php-fpm should not read $_ENV, $_SERVER).
    (Jakub Zelenka)

- GD:
  . Fixed bug GH-12019 (detection of image formats in system gd library).
    (Michael Orlitzky)

- MySQLnd:
  . Fixed bug GH-11950 ([mysqlnd] Fixed not to set CR_MALFORMED_PACKET to error
    if CR_SERVER_GONE_ERROR is already set). (Saki Takamachi)

- PGSQL:
  . Fixed bug GH-13354 (pg_execute/pg_send_query_params/pg_send_execute
    with null value passed by reference). (George Barbarosie)

- Standard:
  . Fixed array key as hash to string (case insensitive) comparison typo
    for the second operand buffer size (albeit unused for now). (A. Slepykh)
This commit is contained in:
taca 2024-03-17 16:46:05 +00:00
parent b31da6574e
commit a9676f5ab4
3 changed files with 16 additions and 16 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: phpversion.mk,v 1.424 2024/02/19 15:42:29 taca Exp $
# $NetBSD: phpversion.mk,v 1.425 2024/03/17 16:46:05 taca Exp $
#
# This file selects a PHP version, based on the user's preferences and
# the installed packages. It does not add a dependency on the PHP
@ -92,7 +92,7 @@ PHP56_VERSION= 5.6.40
PHP74_VERSION= 7.4.33
PHP80_VERSION= 8.0.30
PHP81_VERSION= 8.1.27
PHP82_VERSION= 8.2.16
PHP82_VERSION= 8.2.17
PHP83_VERSION= 8.3.3
# Define API version or initial release of major version.

View File

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.18 2024/02/16 13:16:59 taca Exp $
$NetBSD: distinfo,v 1.19 2024/03/17 16:46:05 taca Exp $
BLAKE2s (php-8.2.16.tar.xz) = 614dd7361b8d9e4e11d9cfe47aa132304c2bca536a35d59ff3953ba7163b68d7
SHA512 (php-8.2.16.tar.xz) = 99e5c9eee4c5a35b3e1939c748ded87c8bff4a340d677516ed24dcf4207c51403d38524c46d6e79de5efe90d7368ba82052ec8a29dd5955f549e8198c1e917f6
Size (php-8.2.16.tar.xz) = 12085228 bytes
SHA1 (patch-configure) = be06e1a0450240beafad7de98f8b6309954989d8
BLAKE2s (php-8.2.17.tar.xz) = 8aa7f3dd3e671ce1aadf71668e71a5edc3ab95fab0a1d6cdb19744f5d30d30da
SHA512 (php-8.2.17.tar.xz) = 113cd8c6a481770aba7e21f1bc22500c93dfa41ff85a7b54e1abbfd5b5a32f51501c91eb45c29a5e2d8ec5f61861060c193a96e27224c97f8cad7979f378bde8
Size (php-8.2.17.tar.xz) = 12092404 bytes
SHA1 (patch-configure) = c80956e91c562a1035ba8ae93403f762e149ae47
SHA1 (patch-ext_enchant_enchant.c) = 7d999de1b2fde2ea11e4a6e16e7b59c085924b9b
SHA1 (patch-ext_phar_Makefile.frag) = 53ea5c58b0bc27d236118d5750a74b1cba43e5dd
SHA1 (patch-ext_standard_php__fopen__wrapper.c) = 0a2c19c18f089448a8d842e99738b292ab9e5640

View File

@ -1,12 +1,12 @@
$NetBSD: patch-configure,v 1.16 2024/02/16 13:16:59 taca Exp $
$NetBSD: patch-configure,v 1.17 2024/03/17 16:46:05 taca Exp $
* Do not include "PKG_CONFIG*" in CONFIGURE_OPTIONS.
* Don't autodetect maintainer-zts.
* Shell portability.
--- configure.orig 2024-02-13 15:22:59.000000000 +0000
--- configure.orig 2024-03-12 14:26:30.000000000 +0000
+++ configure
@@ -3732,6 +3732,10 @@ EOF
@@ -4365,6 +4365,10 @@ EOF
else
break
fi
@ -14,10 +14,10 @@ $NetBSD: patch-configure,v 1.16 2024/02/16 13:16:59 taca Exp $
+ \'PKG_CONFIG\=*) CURRENT_ARG="'PKG_CONFIG=@TOOLS_PATH.pkg-config@'";;
+ \'PKG_CONFIG_LIBDIR\=*) CURRENT_ARG="'PKG_CONFIG_LIBDIR=@PHP_PKGCONFIG_PATH@'";;
+ esac
$as_echo "$CURRENT_ARG \\" >>config.nice
printf "%s\n" "$CURRENT_ARG \\" >>config.nice
CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS $CURRENT_ARG"
done
@@ -7023,30 +7027,6 @@ EOF
@@ -7805,30 +7809,6 @@ EOF
;;
esac
@ -42,18 +42,18 @@ $NetBSD: patch-configure,v 1.16 2024/02/16 13:16:59 taca Exp $
-
- fi
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-printf "%s\n" "yes" >&6; }
-
PHP_VAR_SUBST="$PHP_VAR_SUBST APXS"
else
@@ -78642,7 +78622,7 @@ $as_echo "#define HAVE_TIDYBUFFIO_H 1" >
@@ -82926,7 +82906,7 @@ printf "%s\n" "#define HAVE_TIDYBUFFIO_H
fi
TIDY_LIBDIR=$TIDY_DIR/$PHP_LIBDIR
- if test "$TIDY_LIB_NAME" == 'tidyp'; then
+ if test "$TIDY_LIB_NAME" = 'tidyp'; then
$as_echo "#define HAVE_TIDYP_H 1" >>confdefs.h
printf "%s\n" "#define HAVE_TIDYP_H 1" >>confdefs.h