Update to 2.13.1

ChangeLog:
http://git.finalrewind.org/feh/plain/ChangeLog
Sun, 24 May 2015 11:45:18 +0200

* Release v2.13.1
    * Fix --scale-down breaking image centering in fullscreen mode

Sun, 17 May 2015 20:40:36 +0200  Daniel Friesel <derf+feh@finalrewind.org>

* Release v2.13
    * print --verbose output to stderr
    * Show progress when using --verbose and --loadable / --unloadable
    * ~/.fehbg is now a shell script and can be executed directly
      (sourcing it still works)
    * --max-dimension: ignore width/height limit of 0 pixels
    * Do not re-render images when toggling keep_zoom_vp
    * feh/themes: Support quoting with '' too (previously, only "" worked)
    * Fix potential out of bounds array access in EXIF code
      (when built with exif=1)

Wed, 08 Apr 2015 11:18:41 +0200  Daniel Friesel <derf+feh@finalrewind.org>

* Release v2.12.1
    * Handle missing HOME in environment
    * Fix memory leak when a slideshow contains many unloadable images
    * Fix memory leak when --prelaod removes files from the filelist
This commit is contained in:
szptvlfn 2015-06-14 08:09:35 +00:00
parent 8fa1bb8808
commit a97e392034
3 changed files with 6 additions and 19 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.66 2014/09/27 10:52:38 szptvlfn Exp $
# $NetBSD: Makefile,v 1.67 2015/06/14 08:09:35 szptvlfn Exp $
DISTNAME= feh-2.12
DISTNAME= feh-2.13.1
CATEGORIES= graphics
MASTER_SITES= http://feh.finalrewind.org/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.29 2014/09/27 10:52:38 szptvlfn Exp $
$NetBSD: distinfo,v 1.30 2015/06/14 08:09:35 szptvlfn Exp $
SHA1 (feh-2.12.tar.bz2) = 30eb2b778858b1f4ce97e44c8225758185b0c588
RMD160 (feh-2.12.tar.bz2) = 515073a9ead457c89137689af08e35f54c45a5eb
Size (feh-2.12.tar.bz2) = 2090538 bytes
SHA1 (feh-2.13.1.tar.bz2) = 3f333c1ea26346a3f5481653c8a2e4633cde3a1a
RMD160 (feh-2.13.1.tar.bz2) = 540e54edca941336dc7192d3278a977893ef9fd1
Size (feh-2.13.1.tar.bz2) = 2117354 bytes
SHA1 (patch-config.mk) = 7f99ff19820a62c8a7a9d3b0fb9c7f1a8151f6c5
SHA1 (patch-src_getopt.c) = 337fd15564c1d5b5596fe7d0d2f9bd6b0ca44ca7
SHA1 (patch-src_imlib_c) = 925d2536b69f99acc949cb6bd67422d001335492

View file

@ -1,12 +0,0 @@
$NetBSD: patch-src_getopt.c,v 1.1 2011/05/25 19:44:27 gls Exp $
--- src/getopt.c.orig 2011-05-19 20:36:13.000000000 +0000
+++ src/getopt.c
@@ -36,6 +36,7 @@
#endif
#include <stdio.h>
+#include <string.h>
/* Comment out all this code if we are using the GNU C Library, and are not
actually compiling the library itself. This code is part of the GNU C