Update lsof to 4.77.

Include official patch to fix build on Solaris 10 06/06 or newer.
Fix HOMEPAGE.

The April 10, 2006 revision (4.77): adds Solaris 10 and above -X option
selection of the display of unlinked file cached paths; improved
reporting of Solaris 10 cached path names of questionable accuracy;
has FreeBSD 7.0-CURRENT update; fixes name addition spacing bug; has
limited SAMFS support for Solaris 10; fixes an HP-UX 11 file "chunk"
size problem; updates for FreeBSD 6.0; updates scripts/sort_res.perl5;
corrects +|-M man page error; improves FreeBSD user device random seed
generation; documents in 00FAQ bundled C and gcc compilation failures
on HP-UX 11.23 dated May 2005 or later; corrects bugs and eliminates
compiler warnings in PSTAT-based HP-UX lsof and in the lsof test
suite; changed the method of reporting unknown file types; dropped
the *claim* that lsof works on BSDI BSD/OS; enables compilation on
Solaris 10 1/06; adjusts to FreeBSD 5.5-PRELELEASE and 6.1-PRERELEASE;
fixes locating AIX ATI sockets by their associated TCP/IP addresses;
adjusts to OpenBSD 3.[89]; ends 32 bit Solaris 8 testing (testing on
64 bit Solaris 8 continues.)
This commit is contained in:
markd 2007-03-14 11:36:25 +00:00
parent 78e83ffe7e
commit a9a5afbacd
4 changed files with 24 additions and 21 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.89 2007/01/07 09:14:12 rillig Exp $
# $NetBSD: Makefile,v 1.90 2007/03/14 11:36:25 markd Exp $
#
DISTNAME= lsof_4.76
DISTNAME= lsof_4.77
PKGNAME= ${DISTNAME:S/_/-/}.${OS_VERSION}
CATEGORIES= sysutils
MASTER_SITES= ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/ \
@ -14,7 +14,7 @@ MASTER_SITES= ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/ \
EXTRACT_SUFX= .tar.bz2
MAINTAINER= atatat@NetBSD.org
HOMEPAGE= http://www-rcd.cc.purdue.edu/~abe/
HOMEPAGE= http://people.freebsd.org/~abe/
COMMENT= Lists information about open files
WRKSRC= ${WRKDIR}/${DISTNAME}/${SRCBALL_NAME}

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.63 2006/08/01 12:29:59 tron Exp $
$NetBSD: distinfo,v 1.64 2007/03/14 11:36:25 markd Exp $
SHA1 (lsof_4.76.tar.bz2) = 75e1b81d8498a0dbe818e952ebada985c08ab2db
RMD160 (lsof_4.76.tar.bz2) = deee519e0f43349252951495c53ef6c2b57a7f59
Size (lsof_4.76.tar.bz2) = 704578 bytes
SHA1 (lsof_4.77.tar.bz2) = 603c35a7ade01edf5efcea45abe4b5857aa66a58
RMD160 (lsof_4.77.tar.bz2) = e71ecec2e3281197846658b5ac774ae80b59de3d
Size (lsof_4.77.tar.bz2) = 708416 bytes
SHA1 (patch-aa) = 332eb1ac95d86023dde66d1b99b9335c8f54b81f
SHA1 (patch-ab) = 1501d8b0e6fd2c61949ba0d447c7b726655725c4
SHA1 (patch-ac) = 2fd3810d79e2e534a06eef446562e9e3a95b2ffe
SHA1 (patch-ad) = e543d447ea3946f0f7b856e20420cda89e31d14b
SHA1 (patch-ae) = ba3804e89101fb504edd33983f35904559a63dbf
SHA1 (patch-af) = 5ea8f1f34ded91a0553c9a8faef5ce87eeebdcf3

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.27 2005/11/09 08:06:32 tron Exp $
--- dialects/n+obsd/dlsof.h.orig 2005-08-08 20:53:27.000000000 +0100
+++ dialects/n+obsd/dlsof.h 2005-11-09 08:04:05.000000000 +0000
@@ -69,7 +69,7 @@
# endif /* (defined(OPENBSDV) && OPENBSDV>=3030)
|| (defined(NETBSDV) && __NetBSD_Version__>=106060000) */
-# if defined(NETBSDV)
+# if defined(NETBSDV) && __NetBSD_Version__<399001100
#include <sys/buf.h>
# endif /* defined(NETBSDV) */

View file

@ -0,0 +1,16 @@
$NetBSD: patch-af,v 1.6 2007/03/14 11:36:26 markd Exp $
Official lsof patch to fix build with newer Solaris 10s.
*** /tmp/T0dLaqXT Tue Jul 18 23:11:15 2006
--- dialects/sun/machine.h Mon Jul 10 19:59:17 2006
***************
*** 76,81 ****
--- 76,82 ----
# if solaris>=80000
#include <sys/wait.h>
+ #include <sys/types32.h>
#define _KERNEL 1
#include <netinet/in.h>
#undef _KERNEL