Added a patch for SunPro, which does not accept the -Dfoo()=bar command

line argument.
This commit is contained in:
rillig 2006-11-28 18:57:25 +00:00
parent 753aa4b3f9
commit a9ae11ad59
3 changed files with 42 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.12 2005/11/09 06:42:58 martti Exp $
$NetBSD: distinfo,v 1.13 2006/11/28 18:57:25 rillig Exp $
SHA1 (xfce4-mixer-4.2.3.tar.gz) = 80e0da399bf7cb9617f914b285f87266e9b1428f
RMD160 (xfce4-mixer-4.2.3.tar.gz) = 00a98e28e6cdba183f860b453745097f73fe6c87
Size (xfce4-mixer-4.2.3.tar.gz) = 614377 bytes
SHA1 (patch-aa) = 813b37e41c8a19c8ce2d2b4ed9fc5e53601dd025
SHA1 (patch-ab) = 37ab3665b42e64723f5b40b2a5e26f4d12b5f1a6

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1 2006/11/28 18:57:25 rillig Exp $
--- panel-plugin/plugin.c.orig 2006-11-28 19:25:31.314565636 +0100
+++ panel-plugin/plugin.c 2006-11-28 19:27:08.972814548 +0100
@@ -18,6 +18,14 @@
/* DO: timeout -> update volume */
#define UPDATE_TIMEOUT 1000
+#ifdef XFCE_PANEL_THREADED
+# define XFCE_PANEL_LOCK() gdk_threads_enter()
+# define XFCE_PANEL_UNLOCK() gdk_threads_leave()
+#else
+# define XFCE_PANEL_LOCK() do { } while (0)
+# define XFCE_PANEL_UNLOCK() do { } while (0)
+#endif
+
typedef struct
{
GtkWidget *box;

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1 2006/11/28 18:57:25 rillig Exp $
SunPro cannot handle function-like macros on the command line.
--- configure.orig 2005-11-05 19:16:48.000000000 +0100
+++ configure 2006-11-28 19:28:51.822140712 +0100
@@ -23898,13 +23898,9 @@ echo $ECHO_N "checking whether the Xfce
echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6
xdt_cv_CFLAGS="$xdt_cv_CFLAGS -DXFCE_PANEL_THREADED=1"
- xdt_cv_CFLAGS="$xdt_cv_CFLAGS -DXFCE_PANEL_LOCK\(\)=gdk_threads_enter\(\)"
- xdt_cv_CFLAGS="$xdt_cv_CFLAGS -DXFCE_PANEL_UNLOCK\(\)=gdk_threads_leave\(\)"
else
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
- xdt_cv_CFLAGS="$xdt_cv_CFLAGS -DXFCE_PANEL_LOCK\(\)=do{}while\(0\)"
- xdt_cv_CFLAGS="$xdt_cv_CFLAGS -DXFCE_PANEL_UNLOCK\(\)=do{}while\(0\)"
fi
XFCE4_PANEL_CFLAGS="$xdt_cv_CFLAGS"