ocaml-findlib: use upstream DESTDIR variable called 'prefix'
Bump PKGREVISION to be on the safe side.
This commit is contained in:
parent
b68a21b5ba
commit
a9b5ad3171
6 changed files with 41 additions and 50 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.50 2022/01/23 22:21:45 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.51 2022/02/02 14:35:34 wiz Exp $
|
||||
|
||||
DISTNAME= findlib-1.9.2
|
||||
PKGNAME= ocaml-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://download.camlcity.org/download/
|
||||
|
||||
|
@ -41,6 +42,7 @@ BUILD_TARGET+= opt
|
|||
|
||||
EGDIR= ${PREFIX}/share/examples/ocaml-findlib
|
||||
INSTALL_MAKE_FLAGS+= OCAMLFIND_CONF=${EGDIR}/ocamlfind.conf
|
||||
INSTALL_MAKE_FLAGS+= prefix=${DESTDIR}
|
||||
INSTALLATION_DIRS= lib/ocaml libexec bin ${OCAML_SITELIBDIR}
|
||||
|
||||
CONF_FILES= ${EGDIR}/ocamlfind.conf ${PKG_SYSCONFDIR}/ocamlfind.conf
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.24 2022/01/23 22:21:45 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.25 2022/02/02 14:35:34 wiz Exp $
|
||||
|
||||
BLAKE2s (findlib-1.9.2.tar.gz) = 8c2480d8a2b30c0550d42510ed3ed622f9d523728247318a3066b3208ccb2625
|
||||
SHA512 (findlib-1.9.2.tar.gz) = c43d43e502869d52e7eb0e5fcf900039fd4ce0c997a4c823f8d5d9ead0c62120447a787723b884bda0db210e9e60fb513d767c4ea6c18bb38effdc8e35a4b75e
|
||||
Size (findlib-1.9.2.tar.gz) = 266692 bytes
|
||||
SHA1 (patch-Makefile) = 449237f90ee19862109f52d2f2be1d10fafc0e2c
|
||||
SHA1 (patch-Makefile) = 010603d61be7b3b2e90cb173187ce4003d5f6ba4
|
||||
SHA1 (patch-configure) = b5730cab9598dda0a1f12ea77474612fe580e4ab
|
||||
SHA1 (patch-src_bytes_Makefile) = f2aa1e2ae60c63bfd2b8a00981202a7453bdd8a3
|
||||
SHA1 (patch-src_findlib-toolbox_Makefile) = 621e478386516c751968f517f8824c9f4d6d62a1
|
||||
SHA1 (patch-src_findlib_Makefile) = f8cb5b6d67df50017efb89eec94883144011202d
|
||||
SHA1 (patch-src_bytes_Makefile) = 6cba1af5bb70bb66bf29d906484081a2f8aa8433
|
||||
SHA1 (patch-src_findlib-toolbox_Makefile) = 71830cf8412d446a081b0e318b2a38dac64764c2
|
||||
SHA1 (patch-src_findlib_Makefile) = 3151148441a04ed2a95cca554f5615c391af7c00
|
||||
|
|
|
@ -1,23 +1,15 @@
|
|||
$NetBSD: patch-Makefile,v 1.7 2021/03/18 08:30:43 jaapb Exp $
|
||||
$NetBSD: patch-Makefile,v 1.8 2022/02/02 14:35:34 wiz Exp $
|
||||
|
||||
make package support DESTDIR; use BSD_INSTALL_* instead of mkdir and cp
|
||||
use BSD_INSTALL_* instead of mkdir and cp
|
||||
|
||||
--- Makefile.orig 2021-03-16 11:43:00.000000000 +0000
|
||||
--- Makefile.orig 2022-01-19 22:39:27.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -18,13 +18,13 @@ opt:
|
||||
for p in $(PARTS); do ( cd src/$$p; $(MAKE) opt ) || exit; done
|
||||
|
||||
install: check-installation
|
||||
- mkdir -p "$(prefix)$(OCAMLFIND_BIN)"
|
||||
- mkdir -p "$(prefix)$(OCAMLFIND_MAN)"
|
||||
+ mkdir -p "$(DESTDIR)$(prefix)$(OCAMLFIND_BIN)"
|
||||
+ mkdir -p "$(DESTDIR)$(prefix)$(OCAMLFIND_MAN)"
|
||||
$(MAKE) install-config
|
||||
@@ -24,7 +24,7 @@ install: check-installation
|
||||
for p in $(PARTS); do ( cd src/$$p; $(MAKE) install ); done
|
||||
$(MAKE) install-meta
|
||||
test ! -f 'site-lib-src/num-top/META' || { cd src/findlib; $(MAKE) install-num-top; }
|
||||
- test ! -f 'site-lib-src/camlp4/META' || cp tools/safe_camlp4 "$(prefix)$(OCAMLFIND_BIN)"
|
||||
+ test ! -f 'site-lib-src/camlp4/META' || $(BSD_INSTALL_SCRIPT) tools/safe_camlp4 "$(DESTDIR)$(prefix)$(OCAMLFIND_BIN)"
|
||||
+ test ! -f 'site-lib-src/camlp4/META' || $(BSD_INSTALL_SCRIPT) tools/safe_camlp4 "$(prefix)$(OCAMLFIND_BIN)"
|
||||
$(MAKE) install-doc
|
||||
|
||||
uninstall: check-installation
|
||||
|
@ -28,9 +20,9 @@ make package support DESTDIR; use BSD_INSTALL_* instead of mkdir and cp
|
|||
- mkdir -p "$(prefix)$(OCAMLFIND_MAN)/man1" "$(prefix)$(OCAMLFIND_MAN)/man3" "$(prefix)$(OCAMLFIND_MAN)/man5"
|
||||
- -cp doc/ref-man/ocamlfind.1 "$(prefix)$(OCAMLFIND_MAN)/man1"
|
||||
- -cp doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "$(prefix)$(OCAMLFIND_MAN)/man5"
|
||||
+ $(BSD_INSTALL_MAN_DIR) "$(DESTDIR)$(prefix)$(OCAMLFIND_MAN)/man1" "$(DESTDIR)$(prefix)$(OCAMLFIND_MAN)/man3" "$(DESTDIR)$(prefix)$(OCAMLFIND_MAN)/man5"
|
||||
+ -$(BSD_INSTALL_MAN) doc/ref-man/ocamlfind.1 "$(DESTDIR)$(prefix)$(OCAMLFIND_MAN)/man1"
|
||||
+ -$(BSD_INSTALL_MAN) doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "$(DESTDIR)$(prefix)$(OCAMLFIND_MAN)/man5"
|
||||
+ $(BSD_INSTALL_MAN_DIR) "$(prefix)$(OCAMLFIND_MAN)/man1" "$(prefix)$(OCAMLFIND_MAN)/man3" "$(prefix)$(OCAMLFIND_MAN)/man5"
|
||||
+ -$(BSD_INSTALL_MAN) doc/ref-man/ocamlfind.1 "$(prefix)$(OCAMLFIND_MAN)/man1"
|
||||
+ -$(BSD_INSTALL_MAN) doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "$(prefix)$(OCAMLFIND_MAN)/man5"
|
||||
|
||||
.PHONY: uninstall-doc
|
||||
uninstall-doc:
|
||||
|
@ -40,8 +32,8 @@ make package support DESTDIR; use BSD_INSTALL_* instead of mkdir and cp
|
|||
install-meta:
|
||||
- for x in $(SITELIB_META); do mkdir -p "$(prefix)$(OCAML_SITELIB)/$$x"; cp site-lib-src/$$x/META "$(prefix)$(OCAML_SITELIB)/$$x"; done
|
||||
- mkdir -p "$(prefix)$(OCAML_SITELIB)/findlib"; cp Makefile.packages "$(prefix)$(OCAML_SITELIB)/findlib/Makefile.packages"
|
||||
+ for x in $(SITELIB_META); do $(BSD_INSTALL_LIB_DIR) -p "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$$x"; $(BSD_INSTALL_DATA) site-lib-src/$$x/META "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$$x"; done
|
||||
+ $(BSD_INSTALL_LIB_DIR) -p "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/findlib"; $(BSD_INSTALL_DATA) Makefile.packages "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/findlib/Makefile.packages"
|
||||
+ for x in $(SITELIB_META); do $(BSD_INSTALL_LIB_DIR) -p "$(prefix)$(OCAML_SITELIB)/$$x"; $(BSD_INSTALL_DATA) site-lib-src/$$x/META "$(prefix)$(OCAML_SITELIB)/$$x"; done
|
||||
+ $(BSD_INSTALL_LIB_DIR) -p "$(prefix)$(OCAML_SITELIB)/findlib"; $(BSD_INSTALL_DATA) Makefile.packages "$(prefix)$(OCAML_SITELIB)/findlib/Makefile.packages"
|
||||
|
||||
.PHONY: uninstall-meta
|
||||
uninstall-meta:
|
||||
|
@ -50,11 +42,10 @@ make package support DESTDIR; use BSD_INSTALL_* instead of mkdir and cp
|
|||
.PHONY: install-config
|
||||
install-config:
|
||||
- mkdir -p "`dirname \"$(prefix)$(OCAMLFIND_CONF)\"`"
|
||||
- @if [ -f "$(prefix)$(OCAMLFIND_CONF)" ]; then echo "!!! Keeping old $(prefix)$(OCAMLFIND_CONF) !!!"; fi
|
||||
+ $(BSD_INSTALL_DATA_DIR) "`dirname \"$(prefix)$(OCAMLFIND_CONF)\"`"
|
||||
@if [ -f "$(prefix)$(OCAMLFIND_CONF)" ]; then echo "!!! Keeping old $(prefix)$(OCAMLFIND_CONF) !!!"; fi
|
||||
- test -f "$(prefix)$(OCAMLFIND_CONF)" || cp findlib.conf "$(prefix)$(OCAMLFIND_CONF)"
|
||||
+ $(BSD_INSTALL_DATA_DIR) "`dirname \"$(DESTDIR)$(prefix)$(OCAMLFIND_CONF)\"`"
|
||||
+ @if [ -f "$(DESTDIR)$(prefix)$(OCAMLFIND_CONF)" ]; then echo "!!! Keeping old $(prefix)$(OCAMLFIND_CONF) !!!"; fi
|
||||
+ test -f "$(DESTDIR)$(prefix)$(OCAMLFIND_CONF)" || $(BSD_INSTALL_DATA) findlib.conf "$(DESTDIR)$(prefix)$(OCAMLFIND_CONF)"
|
||||
+ test -f "$(prefix)$(OCAMLFIND_CONF)" || $(BSD_INSTALL_DATA) findlib.conf "$(prefix)$(OCAMLFIND_CONF)"
|
||||
|
||||
.PHONY: uninstall-config
|
||||
uninstall-config:
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-src_bytes_Makefile,v 1.2 2022/01/23 22:21:45 wiz Exp $
|
||||
$NetBSD: patch-src_bytes_Makefile,v 1.3 2022/02/02 14:35:34 wiz Exp $
|
||||
|
||||
Install into DESTDIR, use BSD install commands
|
||||
use BSD install commands
|
||||
|
||||
--- src/bytes/Makefile.orig 2022-01-19 22:39:27.000000000 +0000
|
||||
+++ src/bytes/Makefile
|
||||
|
@ -11,9 +11,9 @@ Install into DESTDIR, use BSD install commands
|
|||
- mkdir -p "$(prefix)$(OCAML_SITELIB)/bytes"
|
||||
- cp META $(BYTE_FILES) "$(prefix)$(OCAML_SITELIB)/bytes"
|
||||
- for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then cp $$f "$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
|
||||
+ $(BSD_INSTALL_LIB_DIR) -p "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"
|
||||
+ $(BSD_INSTALL_LIB_DIR) -p "$(prefix)$(OCAML_SITELIB)/bytes"
|
||||
+ $(BSD_INSTALL_DATA) META $(BYTE_FILES) "$(prefix)$(OCAML_SITELIB)/bytes"
|
||||
+ for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then $(BSD_INSTALL_LIB) $$f "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
|
||||
+ for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then $(BSD_INSTALL_LIB) $$f "$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
|
||||
|
||||
uninstall:
|
||||
rm -rf "$(prefix)$(OCAML_SITELIB)/bytes"
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
$NetBSD: patch-src_findlib-toolbox_Makefile,v 1.1 2021/03/18 08:30:43 jaapb Exp $
|
||||
$NetBSD: patch-src_findlib-toolbox_Makefile,v 1.2 2022/02/02 14:35:34 wiz Exp $
|
||||
|
||||
Install into DESTDIR, use BSD install commands
|
||||
use BSD install commands
|
||||
|
||||
--- src/findlib-toolbox/Makefile.orig 2021-03-16 11:43:01.000000000 +0000
|
||||
--- src/findlib-toolbox/Makefile.orig 2022-01-19 22:39:27.000000000 +0000
|
||||
+++ src/findlib-toolbox/Makefile
|
||||
@@ -13,7 +13,7 @@ make_wizard$(EXEC_SUFFIX): make_wizard.m
|
||||
findlib.cma make_wizard.ml
|
||||
|
||||
install:
|
||||
- cp make_wizard$(EXEC_SUFFIX) make_wizard.pattern $(prefix)$(OCAML_SITELIB)/findlib
|
||||
+ $(BSD_INSTALL_SCRIPT) make_wizard$(EXEC_SUFFIX) make_wizard.pattern $(DESTDIR)$(prefix)$(OCAML_SITELIB)/findlib
|
||||
+ $(BSD_INSTALL_SCRIPT) make_wizard$(EXEC_SUFFIX) make_wizard.pattern $(prefix)$(OCAML_SITELIB)/findlib
|
||||
|
||||
# uninstall: Nothing to do, because the removal of the findlib core also
|
||||
# deinstalls the make_wizard
|
||||
|
|
|
@ -1,39 +1,37 @@
|
|||
$NetBSD: patch-src_findlib_Makefile,v 1.10 2021/03/18 08:30:43 jaapb Exp $
|
||||
$NetBSD: patch-src_findlib_Makefile,v 1.11 2022/02/02 14:35:34 wiz Exp $
|
||||
|
||||
Install into DESTDIR, use BSD install commands
|
||||
use BSD install commands
|
||||
|
||||
--- src/findlib/Makefile.orig 2019-07-29 12:06:35.000000000 +0000
|
||||
--- src/findlib/Makefile.orig 2022-01-19 22:39:27.000000000 +0000
|
||||
+++ src/findlib/Makefile
|
||||
@@ -118,23 +118,23 @@ clean:
|
||||
@@ -121,22 +121,22 @@ clean:
|
||||
ocamlfind$(EXEC_SUFFIX) ocamlfind_opt$(EXEC_SUFFIX)
|
||||
|
||||
install: all
|
||||
- mkdir -p "$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
||||
- mkdir -p "$(prefix)$(OCAMLFIND_BIN)"
|
||||
- test $(INSTALL_TOPFIND) -eq 0 || cp topfind "$(prefix)$(OCAML_CORE_STDLIB)"
|
||||
+ $(BSD_INSTALL_DATA_DIR) "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
||||
+ $(BSD_INSTALL_PROGRAM_DIR) "$(DESTDIR)$(prefix)$(OCAMLFIND_BIN)"
|
||||
+ test $(INSTALL_TOPFIND) -eq 0 || $(BSD_INSTALL_SCRIPT) topfind "$(DESTDIR)$(prefix)$(OCAML_CORE_STDLIB)"
|
||||
+ $(BSD_INSTALL_DATA_DIR) "$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
||||
+ $(BSD_INSTALL_PROGRAM_DIR) "$(prefix)$(OCAMLFIND_BIN)"
|
||||
+ test $(INSTALL_TOPFIND) -eq 0 || $(BSD_INSTALL_SCRIPT) topfind "$(prefix)$(OCAML_CORE_STDLIB)"
|
||||
files=`$(SH) $(TOP)/tools/collect_files $(TOP)/Makefile.config findlib.cmi findlib.mli findlib.cma findlib.cmxa findlib$(LIB_SUFFIX) findlib.cmxs topfind.cmi topfind.mli fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi fl_metatoken.cmi findlib_top.cma findlib_top.cmxa findlib_top$(LIB_SUFFIX) findlib_top.cmxs findlib_dynload.cma findlib_dynload.cmxa findlib_dynload$(LIB_SUFFIX) findlib_dynload.cmxs fl_dynload.mli fl_dynload.cmi META` && \
|
||||
- cp $$files "$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
||||
+ $(BSD_INSTALL_DATA) $$files "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
||||
+ $(BSD_INSTALL_DATA) $$files "$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
||||
f="ocamlfind$(EXEC_SUFFIX)"; { test -f ocamlfind_opt$(EXEC_SUFFIX) && f="ocamlfind_opt$(EXEC_SUFFIX)"; }; \
|
||||
- cp $$f "$(prefix)$(OCAMLFIND_BIN)/ocamlfind$(EXEC_SUFFIX)"
|
||||
+ $(BSD_INSTALL_SCRIPT) $$f "$(DESTDIR)$(prefix)$(OCAMLFIND_BIN)/ocamlfind$(EXEC_SUFFIX)"
|
||||
+ $(BSD_INSTALL_SCRIPT) $$f "$(prefix)$(OCAMLFIND_BIN)/ocamlfind$(EXEC_SUFFIX)"
|
||||
# the following "if" block is only needed for 4.00beta2
|
||||
if [ $(OCAML_REMOVE_DIRECTORY) -eq 0 -a -f "$(OCAML_CORE_STDLIB)/compiler-libs/topdirs.cmi" ]; then \
|
||||
cd "$(OCAML_CORE_STDLIB)/compiler-libs/"; \
|
||||
- cp topdirs.cmi toploop.cmi "$(prefix)$(OCAML_SITELIB)/$(NAME)/"; \
|
||||
+ $(BSD_INSTALL_DATA) topdirs.cmi toploop.cmi "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/$(NAME)/"; \
|
||||
+ $(BSD_INSTALL_DATA) topdirs.cmi toploop.cmi "$(prefix)$(OCAML_SITELIB)/$(NAME)/"; \
|
||||
fi
|
||||
|
||||
install-num-top:
|
||||
- mkdir -p "$(prefix)$(OCAML_SITELIB)/num-top"
|
||||
- cp num_top.cma num_top.cmi num_top_printers.cmi \
|
||||
- "$(prefix)$(OCAML_SITELIB)/num-top"
|
||||
+ $(BSD_INSTALL_DATA_DIR) "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/num-top"
|
||||
+ $(BSD_INSTALL_DATA_DIR) "$(prefix)$(OCAML_SITELIB)/num-top"
|
||||
+ $(BSD_INSTALL_DATA) num_top.cma num_top.cmi num_top_printers.cmi \
|
||||
+ "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/num-top"
|
||||
"$(prefix)$(OCAML_SITELIB)/num-top"
|
||||
|
||||
# Note: uninstall-num-top is part of the removal of the META files.
|
||||
|
||||
|
|
Loading…
Reference in a new issue