Updte cyrus-imapd24 to 2.4.7.

bugs and security fix release.

Changes to the Cyrus IMAP Server since 2.4.6

      * Fixed Bug #3357 - lmtpd offering STARTTLS in pre-authorized mode.
      * Fixed Bug #3392 - allowing INBOX.INBOX to be created if the case
        didn't match
      * Fixed Bug #3404 - incorrect LIST "" "user" response
      * Fixed Bug #3417 - crash on zero-byte quota file
      * Fixed numberous bugs with mailbox upgrades
      * Fixed replication errors, which have been reported many times on
        the mailing list, but don't have bug numbers.
      * Increated "paranoia" about record ordering in mailbox, which would
        have detected some bad bugs in replication that caused the infinite
        runaway mailbox filling reported in 2.4.6 and below
      * Increased syslogging detail about replication issues
      * Fixed reconstruct crash with zero-byte index file
      * Fixed cyradm perl library path finding
      * Fixed incorrect use of LITERAL+ formats in our responses to
        clients. Unreported, but could be causing wierd hard-to-track-down
        bugs out there
      * Fixed append immediately on create
      * Upgraded Unicode database to version 6.0
      * Fixed reconstruct crash on folder names with many digits (i.e. ebay
        auction numbers)
      * Fixed reconstruct crash with file called '0.'
      * Made reconstruct '-n' option actually exist, as advertised in the
        man page
      * Fixed bug #3423 - STARTTLS plaintext command injection
        vulnerability
      * Bug #3382 Added "failedloginpause" config option
      * Bugs #3383/3385 Removed some obsolete config options
      * Bug #3389 $confdir/proc not created on the fly
      * Bug #3394 fix imtest parsing of MECHLIST
      * Bug #3399 fix with_ldap option default
      * Bug #3307 fix mbpath crash on remote mailbox
      * Bug #3420 use getpassphrase on Solaris, now passwords over 8
        characters long work with cyrus tools
      * Bug #3400 and others - lots of bugs with XFER between different
        versions in murder clusters fixed, including a bug that caused only
        mailboxes with zero messages to be rejected for upgrade
      * Bug #3391 fix rename which just moves between partitions
      * Bug #3103 fix imtest using plain authentication when it must not
      * Bug #3426 fix TLS on sockets other than stdin
      * Added support for BDB versions 5 and above
This commit is contained in:
obache 2011-03-31 01:28:37 +00:00
parent 80be3ae609
commit a9cdf88124
3 changed files with 6 additions and 58 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2010/12/20 14:05:32 obache Exp $
# $NetBSD: Makefile,v 1.6 2011/03/31 01:28:37 obache Exp $
DISTNAME= cyrus-imapd-2.4.6
DISTNAME= cyrus-imapd-2.4.7
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-imapd/ \
ftp://ftp.cyrusimap.org/cyrus-imapd/OLD-VERSIONS/ \

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.5 2010/12/20 14:05:32 obache Exp $
$NetBSD: distinfo,v 1.6 2011/03/31 01:28:37 obache Exp $
SHA1 (cyrus-imapd-2.4.6.tar.gz) = 2e28543c3ccaad79e2490b7a698630d92b756973
RMD160 (cyrus-imapd-2.4.6.tar.gz) = 47f0eb0750f364b0fd6bbf970873bc1012ed2abf
Size (cyrus-imapd-2.4.6.tar.gz) = 2377895 bytes
SHA1 (cyrus-imapd-2.4.7.tar.gz) = 8a83395ccae4381347234d3112c81594b3615d69
RMD160 (cyrus-imapd-2.4.7.tar.gz) = abb7d7e382475d69163490efb3ba0d43d3947c03
Size (cyrus-imapd-2.4.7.tar.gz) = 2444382 bytes
SHA1 (patch-aa) = 68bc0f58dd6afd585dcfb1d38e4d131457cddb12
SHA1 (patch-ab) = f4762aaf7b8b929c28d63c666e6e8ea700681974
SHA1 (patch-ac) = d6b2e8c00a3605773bf7718d29ccfb0b82f59323
@ -18,6 +18,5 @@ SHA1 (patch-al) = 0eaef55760e9a071802bba157a00bdacc84c1932
SHA1 (patch-am) = e100e13d5137116f5bd7674e954031b2615e5ab1
SHA1 (patch-an) = 31d008c732f71e0b6960f8e4206ce466a689c558
SHA1 (patch-ao) = c01c9d32b4d73cbc32d2ad8bfca8b8b021ca2474
SHA1 (patch-ap) = c736e36f2bbe9e2026044a3ab0d13bec57d951a6
SHA1 (patch-aq) = 8afd83691256cfb32b8ae0370185635bcff90283
SHA1 (patch-ar) = 4ac95c029794afba0f4d398643f354b71efd9ac3

View file

@ -1,51 +0,0 @@
$NetBSD: patch-ap,v 1.1.1.1 2010/10/30 12:12:35 obache Exp $
Fix building with db5.
--- lib/cyrusdb_berkeley.c.orig 2010-10-19 03:08:28.000000000 +0000
+++ lib/cyrusdb_berkeley.c
@@ -108,7 +108,7 @@ static void db_panic(DB_ENV *dbenv __att
exit(EC_TEMPFAIL);
}
-#if (DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)
+#if (DB_VERSION_MAJOR > 4) || ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3))
static void db_err(const DB_ENV *dbenv __attribute__((unused)),
const char *db_prfx, const char *buffer)
#else
@@ -163,7 +163,7 @@ static int init(const char *dbdir, int m
#endif
}
-#if (DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)
+#if (DB_VERSION_MAJOR > 4) || ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3))
dbenv->set_msgcall(dbenv, db_msg);
#endif
dbenv->set_errcall(dbenv, db_err);
@@ -281,7 +281,7 @@ static int mysync(void)
assert(dbinit);
-#if !(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
+#if !((DB_VERSION_MAJOR > 4) || ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 1)))
do {
#endif
#if (DB_VERSION_MAJOR > 3) || ((DB_VERSION_MAJOR == 3) && (DB_VERSION_MINOR > 0))
@@ -289,7 +289,7 @@ static int mysync(void)
#else
r = txn_checkpoint(dbenv, 0, 0);
#endif
-#if !(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
+#if !((DB_VERSION_MAJOR > 4) || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1))
} while (r == DB_INCOMPLETE); /* Never returned by BDB 4.1 */
#endif
if (r) {
@@ -412,7 +412,7 @@ static int myopen(const char *fname, DBT
/* xxx set comparator! */
if (flags & CYRUSDB_MBOXSORT) db->set_bt_compare(db, mbox_compar);
-#if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1
+#if (DB_VERSION_MAJOR > 4) || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
r = (db->open)(db, NULL, fname, NULL, type, dbflags | DB_AUTO_COMMIT, 0664);
#else
r = (db->open)(db, fname, NULL, type, dbflags, 0664);