Update to gmp-4.2.3.
Changes between GMP version 4.2.2 and 4.2.3: Bugs: * Fix x86 CPU recognition code to properly identify recent AMD and Intel 64-bit processors. * The >> operator of the C++ wrapper gmpxx.h now does floor rounding, not truncation. * Inline semantics now follow the C99 standard, and works with recent GCC releases. * C++ bitwise logical operations work for more types. * For C++, gmp.h now includes cstdio, improving compiler compatibility. * Bases > 36 now work properly in mpf_set_str. Speedups: * None, except that proper processor recognition helps affected processors. Features: * The allocation functions now detect overflow of the mpz_t type. This means that overflow will now cause an abort, except when the allocation computation itself overflows. (Such overflow can probably only happen in powering functions; we will detect powering overflow in the future.)
This commit is contained in:
parent
fd4278fbc4
commit
a9d0388552
3 changed files with 18 additions and 21 deletions
|
@ -1,14 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.51 2008/04/01 00:57:09 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.52 2008/08/17 07:56:11 bjs Exp $
|
||||
|
||||
DISTNAME= gmp-4.2.2
|
||||
PKGREVISION= 1
|
||||
DISTNAME= gmp-4.2.3
|
||||
CATEGORIES= devel math
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gmp/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
PATCHFILES= mpf_set_str.c.diff
|
||||
PATCH_SITES+= http://www.gmplib.org/patches/
|
||||
PATCH_DIST_STRIP= -p0
|
||||
#PATCHFILES=
|
||||
#PATCH_SITES+= http://www.gmplib.org/patches/
|
||||
#PATCH_DIST_STRIP= -p0
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://gmplib.org/
|
||||
|
@ -18,12 +17,13 @@ COMMENT= Library for arbitrary precision arithmetic
|
|||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
USE_LANGUAGES= c c++ c99
|
||||
USE_TOOLS+= gm4 autoconf
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
INFO_FILES= yes
|
||||
USE_LANGUAGES= c c++ c99
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gm4 autoconf
|
||||
|
||||
CONFIGURE_ARGS+= --enable-cxx --without-readline
|
||||
INFO_FILES= # PLIST
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
|
|
|
@ -1,11 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.22 2008/07/14 13:06:23 tonio Exp $
|
||||
$NetBSD: distinfo,v 1.23 2008/08/17 07:56:11 bjs Exp $
|
||||
|
||||
SHA1 (gmp-4.2.2.tar.bz2) = 8c5f9798956f9b0162a25a56477a3566a92abc72
|
||||
RMD160 (gmp-4.2.2.tar.bz2) = 4021720f78b02244197c0c49522289e7fe81aad9
|
||||
Size (gmp-4.2.2.tar.bz2) = 1747068 bytes
|
||||
SHA1 (mpf_set_str.c.diff) = 8e5133ec2dbf4c19738faf90f8df5343cf2533f1
|
||||
RMD160 (mpf_set_str.c.diff) = 455375f049ff8ef809e796441ec7a83ec648287b
|
||||
Size (mpf_set_str.c.diff) = 1062 bytes
|
||||
SHA1 (gmp-4.2.3.tar.bz2) = 0106bae14a96d13819a0833e9938a994df230d3b
|
||||
RMD160 (gmp-4.2.3.tar.bz2) = 01d73df59ae87bff995dd4cf3f20788627715a5e
|
||||
Size (gmp-4.2.3.tar.bz2) = 1710314 bytes
|
||||
SHA1 (patch-aa) = a53db34c8ecf38d6556a59a0fa7382456c30fab6
|
||||
SHA1 (patch-ab) = e768eca25c117871041d12a618e38d9d252f25e5
|
||||
SHA1 (patch-ac) = aba76fe105ed971e09901c5fc3d756529094b618
|
||||
SHA1 (patch-ac) = 3120f7d207d65942910f8776786c0dbf6ee4d1b2
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-ac,v 1.7 2008/07/14 13:06:23 tonio Exp $
|
||||
$NetBSD: patch-ac,v 1.8 2008/08/17 07:56:11 bjs Exp $
|
||||
|
||||
Apple's gcc build >5400 (since Xcode 3.0) doesn't support GNU inline in C99 mode
|
||||
|
||||
--- gmp-h.in.orig 2007-09-03 18:05:40.000000000 +0200
|
||||
--- gmp-h.in.orig 2008-07-23 06:22:16.000000000 -0400
|
||||
+++ gmp-h.in
|
||||
@@ -423,8 +423,11 @@ typedef __mpq_struct *mpq_ptr;
|
||||
#ifdef __GNUC_STDC_INLINE__
|
||||
#if (defined __GNUC_STDC_INLINE__) || (__GNUC__ == 4 && __GNUC_MINOR__ == 2)
|
||||
#define __GMP_EXTERN_INLINE extern __inline__ __attribute__ ((__gnu_inline__))
|
||||
#else
|
||||
+#if defined(__APPLE_CC__) && __APPLE_CC__ > 5400 && __STDC_VERSION__ >= 199901L
|
||||
|
|
Loading…
Reference in a new issue