py-qt5: Fix patch to apply to source file instead of generated file.
This commit is contained in:
parent
a5b98931d7
commit
a9d8abf6c2
3 changed files with 16 additions and 48 deletions
|
@ -1,10 +1,10 @@
|
||||||
$NetBSD: distinfo,v 1.9 2018/06/23 11:23:46 wiz Exp $
|
$NetBSD: distinfo,v 1.10 2018/06/23 17:49:36 wiz Exp $
|
||||||
|
|
||||||
SHA1 (PyQt5_gpl-5.10.1.tar.gz) = 638a80519f3250e813ebd5a669651f43f416f14b
|
SHA1 (PyQt5_gpl-5.10.1.tar.gz) = 638a80519f3250e813ebd5a669651f43f416f14b
|
||||||
RMD160 (PyQt5_gpl-5.10.1.tar.gz) = 4e0d454172288d26d40ebf2c15a70e0e271da57e
|
RMD160 (PyQt5_gpl-5.10.1.tar.gz) = 4e0d454172288d26d40ebf2c15a70e0e271da57e
|
||||||
SHA512 (PyQt5_gpl-5.10.1.tar.gz) = 04cd0292f7a088f9c0d088d7c73ec96cfc40253f771dfdf194eb92be7635e6fcaf04863fa24215e9c34a096658549bb2feeb8d8fdca1e39ed87f0256ef0f790b
|
SHA512 (PyQt5_gpl-5.10.1.tar.gz) = 04cd0292f7a088f9c0d088d7c73ec96cfc40253f771dfdf194eb92be7635e6fcaf04863fa24215e9c34a096658549bb2feeb8d8fdca1e39ed87f0256ef0f790b
|
||||||
Size (PyQt5_gpl-5.10.1.tar.gz) = 3110469 bytes
|
Size (PyQt5_gpl-5.10.1.tar.gz) = 3110469 bytes
|
||||||
SHA1 (patch-QtTest_sipQtTestQTest.cpp) = 040ac6327bb2b8d84170859ad7e6e931b22e54ab
|
|
||||||
SHA1 (patch-configure.py) = d04e6be9b505a039b934a613de09becf127e1c64
|
SHA1 (patch-configure.py) = d04e6be9b505a039b934a613de09becf127e1c64
|
||||||
SHA1 (patch-designer_designer.pro-in) = 8b7d885c4a5c5336dbdbead2bd88a4da02026ee2
|
SHA1 (patch-designer_designer.pro-in) = 8b7d885c4a5c5336dbdbead2bd88a4da02026ee2
|
||||||
SHA1 (patch-qmlscene_qmlscene.pro-in) = 055ad9670d9d67dd8fca2f293a0b8b8c71512a4d
|
SHA1 (patch-qmlscene_qmlscene.pro-in) = 055ad9670d9d67dd8fca2f293a0b8b8c71512a4d
|
||||||
|
SHA1 (patch-sip_QtTest_qtestmouse.sip) = ed279d265dea44d43093cae0c501d512f588f2e5
|
||||||
|
|
|
@ -1,46 +0,0 @@
|
||||||
$NetBSD: patch-QtTest_sipQtTestQTest.cpp,v 1.1 2018/06/23 11:23:46 wiz Exp $
|
|
||||||
|
|
||||||
Fix build with Qt 5.11, where QTest::waitForEvents was removed.
|
|
||||||
|
|
||||||
--- QtTest/sipQtTestQTest.cpp.orig 2018-06-23 09:55:45.858337471 +0000
|
|
||||||
+++ QtTest/sipQtTestQTest.cpp
|
|
||||||
@@ -265,31 +265,6 @@ static PyObject *meth_QTest_qWait(PyObje
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
-PyDoc_STRVAR(doc_QTest_waitForEvents, "waitForEvents()");
|
|
||||||
-
|
|
||||||
-extern "C" {static PyObject *meth_QTest_waitForEvents(PyObject *, PyObject *);}
|
|
||||||
-static PyObject *meth_QTest_waitForEvents(PyObject *, PyObject *sipArgs)
|
|
||||||
-{
|
|
||||||
- PyObject *sipParseErr = NULL;
|
|
||||||
-
|
|
||||||
- {
|
|
||||||
- if (sipParseArgs(&sipParseErr, sipArgs, ""))
|
|
||||||
- {
|
|
||||||
- Py_BEGIN_ALLOW_THREADS
|
|
||||||
- ::QTest::waitForEvents();
|
|
||||||
- Py_END_ALLOW_THREADS
|
|
||||||
-
|
|
||||||
- Py_INCREF(Py_None);
|
|
||||||
- return Py_None;
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- /* Raise an exception if the arguments couldn't be parsed. */
|
|
||||||
- sipNoFunction(sipParseErr, sipName_waitForEvents, doc_QTest_waitForEvents);
|
|
||||||
-
|
|
||||||
- return NULL;
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
|
|
||||||
PyDoc_STRVAR(doc_QTest_mouseEvent, "mouseEvent(QTest.MouseAction, QWidget, Qt.MouseButton, Union[Qt.KeyboardModifiers, Qt.KeyboardModifier], QPoint, delay: int = -1)\n"
|
|
||||||
"mouseEvent(QTest.MouseAction, QWindow, Qt.MouseButton, Union[Qt.KeyboardModifiers, Qt.KeyboardModifier], QPoint, delay: int = -1)");
|
|
||||||
@@ -1311,7 +1286,6 @@ static PyMethodDef methods_QTest[] = {
|
|
||||||
{SIP_MLNAME_CAST(sipName_qWaitForWindowActive), (PyCFunction)meth_QTest_qWaitForWindowActive, METH_VARARGS|METH_KEYWORDS, SIP_MLDOC_CAST(doc_QTest_qWaitForWindowActive)},
|
|
||||||
{SIP_MLNAME_CAST(sipName_qWaitForWindowExposed), (PyCFunction)meth_QTest_qWaitForWindowExposed, METH_VARARGS|METH_KEYWORDS, SIP_MLDOC_CAST(doc_QTest_qWaitForWindowExposed)},
|
|
||||||
{SIP_MLNAME_CAST(sipName_touchEvent), meth_QTest_touchEvent, METH_VARARGS, SIP_MLDOC_CAST(doc_QTest_touchEvent)},
|
|
||||||
- {SIP_MLNAME_CAST(sipName_waitForEvents), meth_QTest_waitForEvents, METH_VARARGS, SIP_MLDOC_CAST(doc_QTest_waitForEvents)}
|
|
||||||
};
|
|
||||||
|
|
||||||
static sipEnumMemberDef enummembers_QTest[] = {
|
|
14
x11/py-qt5/patches/patch-sip_QtTest_qtestmouse.sip
Normal file
14
x11/py-qt5/patches/patch-sip_QtTest_qtestmouse.sip
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
$NetBSD: patch-sip_QtTest_qtestmouse.sip,v 1.1 2018/06/23 17:49:36 wiz Exp $
|
||||||
|
|
||||||
|
Fix build with Qt 5.11, which removed this symbol.
|
||||||
|
|
||||||
|
--- sip/QtTest/qtestmouse.sip.orig 2018-02-27 10:43:53.000000000 +0000
|
||||||
|
+++ sip/QtTest/qtestmouse.sip
|
||||||
|
@@ -41,7 +41,6 @@ namespace QTest
|
||||||
|
void mousePress(QWidget *widget, Qt::MouseButton button, Qt::KeyboardModifiers modifier = 0, QPoint pos = QPoint(), int delay = -1);
|
||||||
|
void mouseRelease(QWidget *widget, Qt::MouseButton button, Qt::KeyboardModifiers modifier = 0, QPoint pos = QPoint(), int delay = -1);
|
||||||
|
void mouseEvent(QTest::MouseAction action, QWidget *widget, Qt::MouseButton button, Qt::KeyboardModifiers modifier, QPoint pos, int delay = -1);
|
||||||
|
- void waitForEvents() /ReleaseGIL/;
|
||||||
|
void mouseEvent(QTest::MouseAction action, QWindow *window, Qt::MouseButton button, Qt::KeyboardModifiers modifier, QPoint pos, int delay = -1);
|
||||||
|
void mousePress(QWindow *window, Qt::MouseButton button, Qt::KeyboardModifiers modifier = Qt::KeyboardModifiers(), QPoint pos = QPoint(), int delay = -1);
|
||||||
|
void mouseRelease(QWindow *window, Qt::MouseButton button, Qt::KeyboardModifiers modifier = Qt::KeyboardModifiers(), QPoint pos = QPoint(), int delay = -1);
|
Loading…
Reference in a new issue