Correct the name of the "makefile.x11" file in a patch and the package

Makefile.

Ensure that a patch to convert.sh applies cleanly by diff'ing against a
clean copy of the original file.

Also, strip the DOS-style \r\n line-terminators on cpu.c before building,
so that ordinary cpp line continuations work properly.

Fixes a problem shown up on latest 1.5.2 bulk build.
This commit is contained in:
agc 2001-12-30 21:44:25 +00:00
parent 89790776df
commit a9f8e1342d
4 changed files with 21 additions and 18 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2001/03/27 03:19:56 hubertf Exp $
# $NetBSD: Makefile,v 1.5 2001/12/30 21:44:25 agc Exp $
#
DISTNAME= xm71010s
@ -24,11 +24,14 @@ LHA= lha
EXTRACT_CMD= ${LHA} xqte ${DOWNLOADED_DISTFILE}
NO_CONFIGURE= yes
MAKEFILE= Makefile.X11
MAKEFILE= makefile.x11
post-extract:
@cd ${WRKDIR}; ${MV} linux/* vm
pre-build:
cd ${WRKSRC}; ${MV} cpu.c cpu.c-msdos && ${SED} -e 's|.$$||g' cpu.c-msdos > cpu.c
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/vm/xm7 ${PREFIX}/bin

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.2 2001/04/20 10:50:01 agc Exp $
$NetBSD: distinfo,v 1.3 2001/12/30 21:44:26 agc Exp $
SHA1 (xm71010s.lzh) = 1afad6f530e05545505582d47bb0aa92965e6f71
Size (xm71010s.lzh) = 273065 bytes
SHA1 (patch-aa) = 99c4a1714d5e8a6ea684d47a2163d6cf1d6e0968
SHA1 (patch-ab) = 08fafb6ab554c2ff9ab1af5adbb4144247359c75
SHA1 (patch-aa) = 599288e3e3d1598b1f3371f1bfc3705a61a39e39
SHA1 (patch-ab) = 412dfa3bd2ff9227a58c7bb183ca683d66e27435
SHA1 (patch-ac) = f35662d6c8b794b5a1c052cebd53a9b96ad32c37
SHA1 (patch-ad) = dfeb6e5f824b99f5464c719e8a658a7c501ff8fc

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
$NetBSD: patch-aa,v 1.2 2001/12/30 21:44:26 agc Exp $
--- Makefile.X11.orig Thu Mar 23 01:01:00 2000
+++ Makefile.X11 Sat Aug 12 12:54:54 2000
--- makefile.x11.orig Thu Mar 23 01:01:00 2000
+++ makefile.x11 Sat Aug 12 12:54:54 2000
@@ -6,21 +6,29 @@
COMMONSRC = \

View file

@ -1,12 +1,12 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
$NetBSD: patch-ab,v 1.2 2001/12/30 21:44:26 agc Exp $
--- convert.sh.orig Sat Aug 12 12:17:15 2000
+++ convert.sh Sat Aug 12 12:18:36 2000
--- convert.sh.orig Wed Mar 22 16:01:00 2000
+++ convert.sh Sun Dec 30 21:34:03 2001
@@ -7,3 +7,7 @@
rm t t.lzh
done
+for X in *.cpp;do
+nkf -e < $X > t
+mv t $X
+done
rm t t.lzh
done
+for X in *.cpp;do
+nkf -e < $X > t
+mv t $X
+done