reimport of ELinks 0.4.3 after the 0.9.0

ELinks is an advanced and well-established text-mode web (HTTP/FTP/..) browser
with a wide range of additional features and extensibility by the possibility
to plug in own scripts in Lua language. This project aims to provide
feature-rich version of Links, with more open patches/features inclusion
policy. This OpenSource project is covered by the GNU General Public License.
This commit is contained in:
recht 2004-01-22 11:09:54 +00:00
parent afe8dc1028
commit aa438840d8
7 changed files with 89 additions and 0 deletions

5
www/elinks04/DESCR Normal file
View file

@ -0,0 +1,5 @@
ELinks is an advanced and well-established text-mode web (HTTP/FTP/..) browser
with a wide range of additional features and extensibility by the possibility
to plug in own scripts in Lua language. This project aims to provide
feature-rich version of Links, with more open patches/features inclusion
policy. This OpenSource project is covered by the GNU General Public License.

22
www/elinks04/Makefile Normal file
View file

@ -0,0 +1,22 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/01/22 11:09:54 recht Exp $
DISTNAME= elinks-0.4.3
CATEGORIES= www
MASTER_SITES= http://elinks.or.cz/download/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= dawszy@arhea.net
HOMEPAGE= http://elinks.or.cz/
COMMENT= Extended/Enhanced Links
USE_BUILDLINK2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-x
.include "../../archivers/bzip2/buildlink2.mk"
.include "../../devel/zlib/buildlink2.mk"
.include "../../lang/lua4/buildlink2.mk"
.include "../../security/openssl/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

5
www/elinks04/PLIST Normal file
View file

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/01/22 11:09:54 recht Exp $
bin/elinks
man/man1/elinks.1
man/man5/elinks.conf.5
man/man5/elinkskeys.5

7
www/elinks04/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2004/01/22 11:09:54 recht Exp $
SHA1 (elinks-0.4.3.tar.bz2) = 714fceaf57327849cdb3986ca937018624af6b5e
Size (elinks-0.4.3.tar.bz2) = 767828 bytes
SHA1 (patch-aa) = 848266272ba4a4dfb6490b3c701ee20575121cb0
SHA1 (patch-ab) = afa6a0000e8fbe2d33669c9b34a3f157c087b42c
SHA1 (patch-ac) = b0041facbc15997bf272ada854ddfea94ef8158f

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/01/22 11:09:54 recht Exp $
--- configure.orig 2003-12-13 18:28:39.000000000 -0800
+++ configure 2003-12-13 18:30:09.000000000 -0800
@@ -4262,7 +4262,7 @@
if test "$xyz_piggyswitch" = "cow"; then
LIBS="-llua40 -llualib40 -lm $LIBS_X"
else
- LIBS="-llua -llualib -lm $LIBS_X"
+ LIBS="-llua4 -llualib4 -lm $LIBS_X"
fi
if test ! -z "$luadir"; then
@@ -4280,7 +4280,7 @@
cat > conftest.$ac_ext <<EOF
#line 4282 "configure"
#include "confdefs.h"
-#include <lua.h>
+#include <lua4.h>
int main() {
lua_open(0)
; return 0; }

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/01/22 11:09:54 recht Exp $
--- src/lua/core.c.orig
+++ src/lua/core.c
@@ -15,8 +15,8 @@
#include <unistd.h>
#endif
-#include <lua.h>
-#include <lualib.h>
+#include <lua4.h>
+#include <lualib4.h>
#include "elinks.h"

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 2004/01/22 11:09:54 recht Exp $
--- src/lua/core.h.orig
+++ src/lua/core.h
@@ -5,7 +5,7 @@
#ifdef HAVE_LUA
-#include <lua.h> /* This is standart include. */
+#include <lua4.h> /* This is standart include. */
#include "document/session.h"
extern lua_State *lua_state;