Move editors/emacs to editors/emacs23.
This commit is contained in:
parent
0934050e39
commit
aa52c9bdf7
22 changed files with 0 additions and 4323 deletions
|
@ -1,18 +0,0 @@
|
|||
GNU Emacs is an extensible, customizable editor textand more. At its
|
||||
core is an interpreter for Emacs Lisp, a dialect of the Lisp
|
||||
programming language with extensions to support text editing. The
|
||||
features of GNU Emacs include:
|
||||
|
||||
- Content-sensitive editing modes, including syntax coloring, for a
|
||||
wide variety of file types including plain text, source code, and
|
||||
HTML.
|
||||
- Complete built-in documentation, including a tutorial for new users.
|
||||
- Support for many languages and their scripts, including all scripts,
|
||||
Russian, Greek, Japanese, Chinese, Korean, Thai, Vietnamese, Lao,
|
||||
Ethiopian, and some Indian scripts.
|
||||
- Highly customizable, using Emacs Lisp code or a graphical
|
||||
customization interface.
|
||||
- A large number of extensions that add other functionality, including
|
||||
a project planner, mail and news reader, debugger interface,
|
||||
calendar, and more. Many of these extensions are distributed with
|
||||
GNU Emacs; others are available separately.
|
|
@ -1,25 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.156 2013/02/16 11:20:54 wiz Exp $
|
||||
|
||||
CONFLICTS+= emacs-nox11-[0-9]*
|
||||
|
||||
.include "../../editors/emacs/Makefile.common"
|
||||
PKGREVISION= 12
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
SUBST_CLASSES+= prefix
|
||||
SUBST_STAGE.prefix= pre-configure
|
||||
SUBST_VARS.prefix= PREFIX
|
||||
SUBST_FILES.prefix= src/s/netbsd.h
|
||||
|
||||
# Replace manual page which only includes another one with a symbolic link
|
||||
# if manual compression is activated. The manual page won't work otherwise.
|
||||
.if defined(MANZ)
|
||||
post-install:
|
||||
${RM} -f ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/ctags.1
|
||||
${LN} -s etags.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/ctags.1
|
||||
.endif
|
||||
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,78 +0,0 @@
|
|||
# $NetBSD: Makefile.common,v 1.36 2012/10/03 11:43:32 asau Exp $
|
||||
#
|
||||
# used by editors/emacs/Makefile
|
||||
# used by editors/emacs-nox11/Makefile
|
||||
|
||||
DISTNAME= emacs-${EMACS_VERSION}
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=emacs/}
|
||||
|
||||
MAINTAINER= minskim@NetBSD.org
|
||||
HOMEPAGE= http://www.gnu.org/software/emacs/emacs.html
|
||||
COMMENT= GNU editing macros (editor)
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/b$//}
|
||||
MAKE_JOBS_SAFE= no
|
||||
|
||||
CONFLICTS+= emacs-nox11-[0-9]*
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INFO_FILES= yes
|
||||
USE_TOOLS+= gmake makeinfo gzip
|
||||
|
||||
CONFIGURE_ARGS+= --srcdir=${WRKSRC}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
CONFIGURE_ENV+= GAMEOWN=${GAMES_USER}
|
||||
|
||||
SETGIDGAME= yes
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
BUILD_DEFS+= GAMEDATAMODE
|
||||
PLIST_SRC+= ../../editors/emacs/PLIST
|
||||
|
||||
.include "../../editors/emacs/version.mk"
|
||||
|
||||
BUILD_TARGET= bootstrap
|
||||
EMACS_VERSION= ${_EMACS_VERSION_MAJOR}.${_EMACS_VERSION_MINOR}
|
||||
PLIST_SUBST+= EMACS_VERSION=${EMACS_VERSION}
|
||||
|
||||
REPLACE_PERL= lib-src/grep-changelog
|
||||
CHECK_INTERPRETER_SKIP= bin/grep-changelog
|
||||
|
||||
MAKE_DIRS_PERMS+= ${VARBASE}/games/emacs ${GAMES_USER} ${GAMES_GROUP} ${GAMEDIRMODE}
|
||||
CONF_FILES_PERMS+= /dev/null ${VARBASE}/games/emacs/snake-scores \
|
||||
${GAMES_USER} ${GAMES_GROUP} ${GAMEDATAMODE}
|
||||
CONF_FILES_PERMS+= /dev/null ${VARBASE}/games/emacs/tetris-scores \
|
||||
${GAMES_USER} ${GAMES_GROUP} ${GAMEDATAMODE}
|
||||
|
||||
SPECIAL_PERMS+= libexec/emacs/${EMACS_VERSION}/${MACHINE_GNU_PLATFORM}/update-game-score ${SETGID_GAMES_PERMS}
|
||||
|
||||
# build PATH in the dumped emacs is not a problem
|
||||
CHECK_WRKREF_SKIP+= bin/emacs
|
||||
CHECK_WRKREF_SKIP+= bin/emacs-${EMACS_VERSION}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if (${OPSYS} == "Darwin")
|
||||
# Disable address randomization to fix build with Xcode 4.1. This is from
|
||||
# upstream bug #8395. Details in:
|
||||
# http://lists.gnu.org/archive/html/emacs-bug-tracker/2011-07/msg00445.html
|
||||
CFLAGS+= -fno-pie
|
||||
.endif
|
||||
|
||||
.if (${OPSYS} == "NetBSD") && exists(/usr/include/term.h)
|
||||
CPPFLAGS+= -DTERMINFO
|
||||
.elif ${OPSYS} == "DragonFly" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "Linux" || ${OPSYS} == "OpenBSD"
|
||||
.include "../../mk/curses.buildlink3.mk"
|
||||
.else
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
|
||||
post-extract:
|
||||
cp ${.CURDIR}/../../editors/emacs/files/site-init.el ${WRKSRC}/lisp
|
||||
cp ${FILESDIR}/dragonfly.h ${WRKSRC}/src/s
|
||||
${CHMOD} -R go-w ${WRKSRC}
|
||||
${CHMOD} ugo+rx ${WRKSRC}/leim/ja-dic ${WRKSRC}/leim/quail
|
3625
editors/emacs/PLIST
3625
editors/emacs/PLIST
File diff suppressed because it is too large
Load diff
|
@ -1,8 +0,0 @@
|
|||
@comment $NetBSD: PLIST.cocoa,v 1.1 2009/08/05 22:04:50 minskim Exp $
|
||||
Applications/Emacs.app/Contents/Info.plist
|
||||
Applications/Emacs.app/Contents/MacOS/Emacs
|
||||
Applications/Emacs.app/Contents/PkgInfo
|
||||
Applications/Emacs.app/Contents/Resources/Credits.html
|
||||
Applications/Emacs.app/Contents/Resources/Emacs.icns
|
||||
Applications/Emacs.app/Contents/Resources/English.lproj/InfoPlist.strings
|
||||
Applications/Emacs.app/Contents/Resources/document.icns
|
|
@ -1,6 +0,0 @@
|
|||
@comment $NetBSD: PLIST.gnustep,v 1.1 2009/08/05 22:04:50 minskim Exp $
|
||||
share/GNUstep/Local/Applications/Emacs.app/Emacs
|
||||
share/GNUstep/Local/Applications/Emacs.app/Resources/Emacs.desktop
|
||||
share/GNUstep/Local/Applications/Emacs.app/Resources/Info-gnustep.plist
|
||||
share/GNUstep/Local/Applications/Emacs.app/Resources/emacstiff
|
||||
share/GNUstep/Local/Applications/Emacs.app/library_paths.openapp
|
|
@ -1,15 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.4 2009/08/05 22:04:50 minskim Exp $
|
||||
|
||||
BUILDLINK_TREE+= emacs
|
||||
|
||||
.if !defined(EMACS_BUILDLINK3_MK)
|
||||
EMACS_BUILDLINK3_MK:=
|
||||
|
||||
.include "../../editors/emacs/modules.mk"
|
||||
BUILDLINK_API_DEPENDS.emacs+= ${_EMACS_REQD}
|
||||
BUILDLINK_PKGSRCDIR.emacs?= ${_EMACS_PKGDIR}
|
||||
|
||||
BUILDLINK_CONTENTS_FILTER.emacs= ${EGREP} '.*\.el$$|.*\.elc$$'
|
||||
.endif # EMACS_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -emacs
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.58 2012/08/13 06:53:06 wiz Exp $
|
||||
|
||||
SHA1 (emacs-23.4.tar.gz) = 0a78466fff52d1f43c0db0ea66651a0b13b7e473
|
||||
RMD160 (emacs-23.4.tar.gz) = 5fb7e4cd4270a524b8723ad86a145a0e47336bf7
|
||||
Size (emacs-23.4.tar.gz) = 47721193 bytes
|
||||
SHA1 (patch-aa) = 951c1d9fe90fbe2c2366ba230106f8d165068d50
|
||||
SHA1 (patch-ab) = 053243431964def524b7ba2f82ee78680ff7011e
|
||||
SHA1 (patch-ad) = e37f73048273801b8fd330d6897346b1f6e55fe9
|
||||
SHA1 (patch-ae) = 116394051b3e2f4220ff5a3de3402923857940b9
|
||||
SHA1 (patch-ag) = f462ad22762469360d90060afbc73e660e9f7db5
|
||||
SHA1 (patch-bf) = 9ff58581e7b9c865397729169fadd3baecc4a1e3
|
||||
SHA1 (patch-lisp_files.el) = e10c6949029ca7933ea632693843a911b7e010c2
|
||||
SHA1 (patch-src_config.in) = c1f7b608dc49da704571a71f96067a0ffac01df9
|
||||
SHA1 (patch-src_m_amdx86-64.h) = 0928f4e80c456e5b94a74cfeb3589e411a134507
|
||||
SHA1 (patch-src_xgselect.c) = 4a0b246eae2e43fc1e544210fc97c0170e3cffdc
|
|
@ -1,124 +0,0 @@
|
|||
/* System description header for DragonFly systems.
|
||||
This file describes the parameters that system description files
|
||||
should define or not.
|
||||
Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
|
||||
Free Software Foundation, Inc.
|
||||
|
||||
This file is part of GNU Emacs.
|
||||
|
||||
GNU Emacs is free software; you can redistribute it and/or modify
|
||||
it under the terms of the GNU General Public License as published by
|
||||
the Free Software Foundation; either version 2, or (at your option)
|
||||
any later version.
|
||||
|
||||
GNU Emacs is distributed in the hope that it will be useful,
|
||||
but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
GNU General Public License for more details.
|
||||
|
||||
You should have received a copy of the GNU General Public License
|
||||
along with GNU Emacs; see the file COPYING. If not, write to
|
||||
the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
Boston, MA 02111-1307, USA. */
|
||||
|
||||
/* Get most of the stuff from bsd-common */
|
||||
#include "bsd-common.h"
|
||||
|
||||
/* For mem-limits.h. */
|
||||
#define BSD4_2
|
||||
|
||||
/* These aren't needed, since we have getloadavg. */
|
||||
#undef KERNEL_FILE
|
||||
#undef LDAV_SYMBOL
|
||||
|
||||
#define PENDING_OUTPUT_COUNT(FILE) __fpending(FILE)
|
||||
|
||||
#define LIBS_DEBUG
|
||||
#define LIBS_SYSTEM -lutil
|
||||
#define TERMINFO
|
||||
#define LIBS_TERMCAP -lncurses
|
||||
#define SYSV_SYSTEM_DIR
|
||||
|
||||
/* freebsd has POSIX-style pgrp behavior. */
|
||||
#undef BSD_PGRPS
|
||||
#define GETPGRP_NO_ARG
|
||||
|
||||
#define ORDINARY_LINK
|
||||
#define START_FILES
|
||||
#define LIB_STANDARD -lc
|
||||
|
||||
#define LD_SWITCH_SYSTEM_1
|
||||
#define UNEXEC unexelf.o
|
||||
#undef LIB_GCC
|
||||
#define LIB_GCC
|
||||
|
||||
#define HAVE_WAIT_HEADER
|
||||
#define HAVE_GETLOADAVG 1
|
||||
#define HAVE_TERMIOS
|
||||
#define NO_TERMIO
|
||||
#define DECLARE_GETPWUID_WITH_UID_T
|
||||
|
||||
/* freebsd uses OXTABS instead of the expected TAB3. */
|
||||
#define TABDLY OXTABS
|
||||
#define TAB3 OXTABS
|
||||
|
||||
/* this silences a few compilation warnings */
|
||||
#undef BSD_SYSTEM
|
||||
#define BSD_SYSTEM 199506
|
||||
|
||||
/* Needed to avoid hanging when child process writes an error message
|
||||
and exits -- enami tsugutomo <enami@ba2.so-net.or.jp>. */
|
||||
#define vfork fork
|
||||
|
||||
/* Don't close pty in process.c to make it as controlling terminal.
|
||||
It is already a controlling terminal of subprocess, because we did
|
||||
ioctl TIOCSCTTY. */
|
||||
#define DONT_REOPEN_PTY
|
||||
|
||||
/* If the system's imake configuration file defines `NeedWidePrototypes'
|
||||
as `NO', we must define NARROWPROTO manually. Such a define is
|
||||
generated in the Makefile generated by `xmkmf'. If we don't
|
||||
define NARROWPROTO, we will see the wrong function prototypes
|
||||
for X functions taking float or double parameters. */
|
||||
|
||||
#define NARROWPROTO 1
|
||||
|
||||
#define C_SWITCH_SYSTEM
|
||||
#define LD_SWITCH_SYSTEM
|
||||
|
||||
/* Circumvent a bug in FreeBSD. In the following sequence of
|
||||
writes/reads on a PTY, read(2) returns bogus data:
|
||||
|
||||
write(2) 1022 bytes
|
||||
write(2) 954 bytes, get EAGAIN
|
||||
read(2) 1024 bytes in process_read_output
|
||||
read(2) 11 bytes in process_read_output
|
||||
|
||||
That is, read(2) returns more bytes than have ever been written
|
||||
successfully. The 1033 bytes read are the 1022 bytes written
|
||||
successfully after processing (for example with CRs added if the
|
||||
terminal is set up that way which it is here). The same bytes will
|
||||
be seen again in a later read(2), without the CRs. */
|
||||
|
||||
#define BROKEN_PTY_READ_AFTER_EAGAIN 1
|
||||
|
||||
/* Tell that garbage collector that setjmp is known to save all
|
||||
registers relevant for conservative garbage collection in the
|
||||
jmp_buf. */
|
||||
|
||||
#define GC_SETJMP_WORKS 1
|
||||
|
||||
/* Use the GC_MAKE_GCPROS_NOOPS (see lisp.h) method for marking the
|
||||
stack. */
|
||||
|
||||
#define GC_MARK_STACK GC_MAKE_GCPROS_NOOPS
|
||||
|
||||
/* Define USE_MMAP_FOR_BUFFERS to let Emacs use mmap(2) to allocate
|
||||
buffer text. This overrides REL_ALLOC. */
|
||||
|
||||
#define USE_MMAP_FOR_BUFFERS 1
|
||||
|
||||
/* Use sigprocmask(2) and friends instead of sigblock(2); the man page
|
||||
of sigblock says it is obsolete. */
|
||||
|
||||
#define POSIX_SIGNALS 1
|
|
@ -1,4 +0,0 @@
|
|||
;; $NetBSD: site-init.el,v 1.3 2003/06/02 08:12:25 epg Exp $
|
||||
|
||||
(autoload 'send-pr "/usr/share/gnats/send-pr.el"
|
||||
"Command to create and send a problem report." t)
|
|
@ -1,137 +0,0 @@
|
|||
# $NetBSD: options.mk,v 1.12 2011/03/09 16:28:21 drochner Exp $
|
||||
#
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.emacs
|
||||
PKG_SUPPORTED_OPTIONS= dbus xft2 svg
|
||||
PKG_OPTIONS_OPTIONAL_GROUPS+= window-system
|
||||
PKG_OPTIONS_GROUP.window-system= x11 nextstep
|
||||
PKG_OPTIONS_OPTIONAL_GROUPS+= toolkit
|
||||
PKG_OPTIONS_GROUP.toolkit= gtk motif xaw
|
||||
PKG_SUGGESTED_OPTIONS= dbus svg x11 xft2
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
###
|
||||
### Support D-BUS
|
||||
###
|
||||
. if !empty(PKG_OPTIONS:Mdbus)
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
. else
|
||||
CONFIGURE_ARGS+= --without-dbus
|
||||
. endif
|
||||
|
||||
###
|
||||
### Support SVG
|
||||
###
|
||||
. if !empty(PKG_OPTIONS:Msvg) && empty(PKG_OPTIONS:Mnextstep)
|
||||
.include "../../graphics/librsvg/buildlink3.mk"
|
||||
. else
|
||||
CONFIGURE_ARGS+= --without-rsvg
|
||||
. endif
|
||||
|
||||
###
|
||||
### Any of the "toolkit" options with no window-system option implies "x11"
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mgtk) || !empty(PKG_OPTIONS:Mmotif) || !empty(PKG_OPTIONS:Mxaw) || !empty(PKG_OPTIONS:Mxft2)
|
||||
. if empty(PKG_OPTIONS:Mx11) && empty(PKG_OPTIONS:Mnextstep)
|
||||
PKG_OPTIONS+= x11
|
||||
. endif
|
||||
.endif
|
||||
|
||||
###
|
||||
### Default to using the Xaw X11 toolkit if none is specified.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
. if empty(PKG_OPTIONS:Mgtk) && empty(PKG_OPTIONS:Mmotif) && empty(PKG_OPTIONS:Mxaw)
|
||||
PKG_OPTIONS+= gtk
|
||||
. endif
|
||||
.endif
|
||||
|
||||
###
|
||||
### Support drawing pretty X11 widgets.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
|
||||
CONFIGURE_ARGS+= --with-x
|
||||
CONFIGURE_ARGS+= --with-xpm
|
||||
CONFIGURE_ARGS+= --with-jpeg
|
||||
CONFIGURE_ARGS+= --with-tiff
|
||||
CONFIGURE_ARGS+= --with-gif
|
||||
CONFIGURE_ARGS+= --with-png
|
||||
|
||||
.include "../../mk/jpeg.buildlink3.mk"
|
||||
.include "../../graphics/tiff/buildlink3.mk"
|
||||
.include "../../mk/giflib.buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../x11/libSM/buildlink3.mk"
|
||||
.include "../../x11/libXpm/buildlink3.mk"
|
||||
|
||||
###
|
||||
### Enable font backend
|
||||
###
|
||||
. if !empty(PKG_OPTIONS:Mxft2)
|
||||
.include "../../fonts/fontconfig/buildlink3.mk"
|
||||
.include "../../graphics/libotf/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../x11/libXft/buildlink3.mk"
|
||||
.include "../../devel/m17n-lib/buildlink3.mk"
|
||||
. else
|
||||
CONFIGURE_ARGS+= --without-xft --without-otf --without-m17n-flt
|
||||
. endif
|
||||
|
||||
###
|
||||
### Support using GTK X11 widgets.
|
||||
###
|
||||
. if !empty(PKG_OPTIONS:Mgtk)
|
||||
USE_TOOLS+= pkg-config
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=gtk
|
||||
|
||||
###
|
||||
### Support using Motif X11 widgets.
|
||||
###
|
||||
. elif !empty(PKG_OPTIONS:Mmotif)
|
||||
.include "../../mk/motif.buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=motif
|
||||
|
||||
###
|
||||
### Support using Xaw (Lucid) X11 widgets.
|
||||
###
|
||||
. elif !empty(PKG_OPTIONS:Mxaw)
|
||||
.include "../../mk/xaw.buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=athena
|
||||
. endif
|
||||
|
||||
###
|
||||
### Support using NextStep (Cocoa or GNUstep) windowing system
|
||||
###
|
||||
.elif !empty(PKG_OPTIONS:Mnextstep)
|
||||
. if exists(/System/Library/Frameworks/Cocoa.framework)
|
||||
APPLICATIONS_DIR= Applications
|
||||
PLIST_SRC+= PLIST.cocoa
|
||||
CHECK_WRKREF_SKIP+= Applications/Emacs.app/Contents/MacOS/Emacs
|
||||
. else
|
||||
.include "../../x11/gnustep-gui/buildlink3.mk"
|
||||
MAKE_FILE= Makefile
|
||||
APPLICATIONS_DIR= share/GNUstep/Local/Applications
|
||||
PLIST_SRC+= PLIST.gnustep
|
||||
. endif
|
||||
CONFIGURE_ARGS+= --without-x
|
||||
CONFIGURE_ARGS+= --with-ns
|
||||
CONFIGURE_ARGS+= --disable-ns-self-contained
|
||||
|
||||
INSTALLATION_DIRS+= ${APPLICATIONS_DIR}
|
||||
USE_TOOLS+= pax
|
||||
|
||||
post-install:
|
||||
cd ${WRKSRC}/nextstep && \
|
||||
pax -rw -pp -pm Emacs.app ${DESTDIR}${PREFIX}/${APPLICATIONS_DIR}
|
||||
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-x
|
||||
CONFIGURE_ARGS+= --without-xpm
|
||||
CONFIGURE_ARGS+= --without-jpeg
|
||||
CONFIGURE_ARGS+= --without-tiff
|
||||
CONFIGURE_ARGS+= --without-gif
|
||||
CONFIGURE_ARGS+= --without-png
|
||||
.endif
|
|
@ -1,39 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.17 2010/06/01 21:44:54 minskim Exp $
|
||||
|
||||
--- work/emacs-23.2/configure.in~ 2010-05-08 12:09:12.000000000 +0900
|
||||
+++ ./configure.in 2010-05-12 20:23:07.000000000 +0900
|
||||
@@ -39,7 +39,7 @@
|
||||
docdir='${datadir}/emacs/${version}/etc'
|
||||
gamedir='${localstatedir}/games/emacs'
|
||||
|
||||
-gameuser=games
|
||||
+gameuser=${GAMEOWN}
|
||||
|
||||
dnl OPTION_DEFAULT_OFF(NAME, HELP-STRING)
|
||||
dnl Create a new --with option that defaults to being disabled.
|
||||
@@ -387,6 +387,14 @@
|
||||
amd64-*-freebsd*|x86_64-*-freebsd*) machine=amdx86-64 ;;
|
||||
esac
|
||||
;;
|
||||
+ ## DragonFly ports
|
||||
+ *-*-dragonfly*)
|
||||
+ opsys=dragonfly
|
||||
+ case "${canonical}" in
|
||||
+ i[3456]86-*-dragonfly*) machine=intel386 ;;
|
||||
+ amd64-*-dragonfly*|x86_64-*-dragonfly*) machine=amdx86-64 ;;
|
||||
+ esac
|
||||
+ ;;
|
||||
|
||||
## FreeBSD kernel + glibc based userland
|
||||
*-*-kfreebsd*gnu* )
|
||||
@@ -1391,9 +1399,9 @@
|
||||
window_system=nextstep
|
||||
with_xft=no
|
||||
# set up packaging dirs
|
||||
+ if test "${EN_NS_SELF_CONTAINED}" = yes; then
|
||||
exec_prefix=${ns_appbindir}
|
||||
libexecdir=${ns_appbindir}/libexec
|
||||
- if test "${EN_NS_SELF_CONTAINED}" = yes; then
|
||||
prefix=${ns_appresdir}
|
||||
fi
|
||||
fi
|
|
@ -1,39 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.29 2010/06/01 21:44:54 minskim Exp $
|
||||
|
||||
--- work/emacs-23.2/configure.orig 2010-05-08 12:10:16.000000000 +0900
|
||||
+++ configure 2010-05-12 20:32:23.000000000 +0900
|
||||
@@ -1995,7 +1995,7 @@
|
||||
docdir='${datadir}/emacs/${version}/etc'
|
||||
gamedir='${localstatedir}/games/emacs'
|
||||
|
||||
-gameuser=games
|
||||
+gameuser=${GAMEOWN}
|
||||
|
||||
|
||||
|
||||
@@ -2652,6 +2652,14 @@
|
||||
amd64-*-freebsd*|x86_64-*-freebsd*) machine=amdx86-64 ;;
|
||||
esac
|
||||
;;
|
||||
+ ## DragonFly ports
|
||||
+ *-*-dragonfly*)
|
||||
+ opsys=dragonfly
|
||||
+ case "${canonical}" in
|
||||
+ i[3456]86-*-dragonfly*) machine=intel386 ;;
|
||||
+ amd64-*-dragonfly*|x86_64-*-dragonfly*) machine=amdx86-64 ;;
|
||||
+ esac
|
||||
+ ;;
|
||||
|
||||
## FreeBSD kernel + glibc based userland
|
||||
*-*-kfreebsd*gnu* )
|
||||
@@ -9849,9 +9857,9 @@
|
||||
window_system=nextstep
|
||||
with_xft=no
|
||||
# set up packaging dirs
|
||||
+ if test "${EN_NS_SELF_CONTAINED}" = yes; then
|
||||
exec_prefix=${ns_appbindir}
|
||||
libexecdir=${ns_appbindir}/libexec
|
||||
- if test "${EN_NS_SELF_CONTAINED}" = yes; then
|
||||
prefix=${ns_appresdir}
|
||||
fi
|
||||
fi
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.9 2010/06/01 21:44:54 minskim Exp $
|
||||
|
||||
--- lisp/cus-dep.el.orig 2010-04-03 22:26:07.000000000 +0000
|
||||
+++ lisp/cus-dep.el
|
||||
@@ -59,6 +59,7 @@ Usage: emacs -batch -l ./cus-dep.el -f c
|
||||
(unless (or (string-match custom-dependencies-no-scan-regexp file)
|
||||
(string-match preloaded file)
|
||||
(not (file-exists-p file)))
|
||||
+ (message file)
|
||||
(erase-buffer)
|
||||
(insert-file-contents file)
|
||||
(goto-char (point-min))
|
|
@ -1,45 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.14 2010/06/01 21:44:54 minskim Exp $
|
||||
|
||||
--- Makefile.in.orig 2010-04-04 07:26:08.000000000 +0900
|
||||
+++ Makefile.in 2010-05-14 21:51:03.000000000 +0900
|
||||
@@ -141,7 +141,7 @@
|
||||
infodir=@infodir@
|
||||
INFO_FILES=ada-mode auth autotype calc ccmode cl dbus dired-x ebrowse \
|
||||
ede ediff edt eieio efaq eintr elisp emacs emacs-mime epa erc \
|
||||
- eshell eudc flymake forms gnus idlwave info mairix-el \
|
||||
+ eshell eudc flymake forms gnus idlwave mairix-el \
|
||||
message mh-e newsticker nxml-mode org pcl-cvs pgg rcirc \
|
||||
reftex remember sasl sc semantic ses sieve smtpmail speedbar \
|
||||
tramp url vip viper widget woman
|
||||
@@ -403,7 +403,7 @@
|
||||
install: all install-arch-indep install-arch-dep install-leim blessmail
|
||||
@true
|
||||
|
||||
-MV_DIRS = for i in $$dir; do rm -fr `basename "$$i"` ; mv "$$i" . ; done
|
||||
+MV_DIRS = for i in $$dir; do if test -e $$i ; then rm -fr `basename "$$i"` ; mv "$$i" . ; fi; done
|
||||
|
||||
### Install the executables that were compiled specifically for this machine.
|
||||
### It would be nice to do something for a parallel make
|
||||
@@ -574,21 +574,11 @@
|
||||
test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
|
||||
for f in `ls $$elt $$elt-[1-9] $$elt-[1-9][0-9] 2>/dev/null`; do \
|
||||
${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f; \
|
||||
- chmod a+r $(DESTDIR)${infodir}/$$f; \
|
||||
done; \
|
||||
done); \
|
||||
else true; fi
|
||||
-unset CDPATH; \
|
||||
- thisdir=`/bin/pwd`; \
|
||||
- if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd $(DESTDIR)${infodir} && /bin/pwd)` ]; \
|
||||
- then \
|
||||
- for elt in $(INFO_FILES); do \
|
||||
- test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
|
||||
- (cd $${thisdir}; \
|
||||
- ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt); \
|
||||
- done; \
|
||||
- else true; fi
|
||||
- -chmod -R a+r $(DESTDIR)${datadir}/emacs/${version} ${COPYDESTS}
|
||||
+ chmod -R a+r $(DESTDIR)${datadir}/emacs/${version} ${COPYDESTS}
|
||||
thisdir=`/bin/pwd`; \
|
||||
cd ${mansrcdir}; \
|
||||
for page in ${MAN_PAGES}; do \
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.13 2010/05/15 10:00:57 roy Exp $
|
||||
|
||||
When running terminfo but compiled for termcap, we cannot assume
|
||||
that we actually have anything useable in termcap_term_buffer so just
|
||||
use the terminfo fixed size defined ealier.
|
||||
|
||||
--- src/term.c 2010-01-06 10:11:04.000000000 +0000
|
||||
+++ src/term.c 2010-01-06 10:11:53.000000000 +0000
|
||||
@@ -3590,11 +3590,6 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
-#ifndef TERMINFO
|
||||
- if (strlen (tty->termcap_term_buffer) >= buffer_size)
|
||||
- abort ();
|
||||
- buffer_size = strlen (tty->termcap_term_buffer);
|
||||
-#endif
|
||||
tty->termcap_strings_buffer = area = (char *) xmalloc (buffer_size);
|
||||
tty->TS_ins_line = tgetstr ("al", address);
|
||||
tty->TS_ins_multi_lines = tgetstr ("AL", address);
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-bf,v 1.8 2010/10/21 12:05:49 obache Exp $
|
||||
|
||||
* honor PREFIX
|
||||
* reorder rpath so that additional librares will be prefered than builtin X.
|
||||
|
||||
--- src/s/netbsd.h.orig 2010-04-03 22:26:08.000000000 +0000
|
||||
+++ src/s/netbsd.h
|
||||
@@ -75,8 +75,8 @@ along with GNU Emacs. If not, see <http
|
||||
/* Here is how to find X Windows. LD_SWITCH_X_SITE_AUX gives an -R option
|
||||
says where to find X windows at run time. We convert it to a -rpath option
|
||||
which is what OSF1 uses. */
|
||||
-#define LD_SWITCH_SYSTEM_tmp `echo LD_SWITCH_X_SITE_AUX | sed -e 's/-R/-Wl,-rpath,/'`
|
||||
-#define LD_SWITCH_SYSTEM LD_SWITCH_SYSTEM_tmp -Wl,-rpath,/usr/pkg/lib -L/usr/pkg/lib -Wl,-rpath,/usr/local/lib -L/usr/local/lib
|
||||
+#define LD_SWITCH_SYSTEM_tmp -Wl,-rpath,@PREFIX@/lib -L@PREFIX@/lib
|
||||
+#define LD_SWITCH_SYSTEM LD_SWITCH_SYSTEM_tmp `echo LD_SWITCH_X_SITE_AUX | sed -e 's/-R/-Wl,-rpath,/'`
|
||||
|
||||
/* The following is needed to make `configure' find Xpm, Xaw3d and
|
||||
image include and library files if using /usr/bin/gcc. That
|
|
@ -1,37 +0,0 @@
|
|||
$NetBSD: patch-lisp_files.el,v 1.1 2012/08/13 06:53:06 wiz Exp $
|
||||
|
||||
CVE-2012-3479:
|
||||
When the Emacs user option `enable-local-variables' is set to `:safe'
|
||||
(the default value is t), Emacs should automatically refuse to evaluate
|
||||
`eval' forms in file-local variable sections. Due to the bug, Emacs
|
||||
instead automatically evaluates such `eval' forms. Thus, if the user
|
||||
changes the value of `enable-local-variables' to `:safe', visiting a
|
||||
malicious file can cause automatic execution of arbitrary Emacs Lisp
|
||||
code with the permissions of the user.
|
||||
|
||||
Bug tracker ref: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=12155
|
||||
|
||||
--- lisp/files.el.orig 2012-01-11 12:35:01.000000000 +0000
|
||||
+++ lisp/files.el
|
||||
@@ -2986,11 +2986,16 @@ DIR-NAME is a directory name if these se
|
||||
;; Obey `enable-local-eval'.
|
||||
((eq var 'eval)
|
||||
(when enable-local-eval
|
||||
- (push elt all-vars)
|
||||
- (or (eq enable-local-eval t)
|
||||
- (hack-one-local-variable-eval-safep (eval (quote val)))
|
||||
- (safe-local-variable-p var val)
|
||||
- (push elt unsafe-vars))))
|
||||
+ (let ((safe (or (hack-one-local-variable-eval-safep
|
||||
+ (eval (quote val)))
|
||||
+ ;; In case previously marked safe (bug#5636).
|
||||
+ (safe-local-variable-p var val))))
|
||||
+ ;; If not safe and e-l-v = :safe, ignore totally.
|
||||
+ (when (or safe (not (eq enable-local-variables :safe)))
|
||||
+ (push elt all-vars)
|
||||
+ (or (eq enable-local-eval t)
|
||||
+ safe
|
||||
+ (push elt unsafe-vars))))))
|
||||
;; Ignore duplicates (except `mode') in the present list.
|
||||
((and (assq var all-vars) (not (eq var 'mode))) nil)
|
||||
;; Accept known-safe variables.
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-src_config.in,v 1.1 2011/12/11 21:00:43 marino Exp $
|
||||
|
||||
--- src/config.in.orig 2011-11-26 03:20:20.000000000 +0000
|
||||
+++ src/config.in
|
||||
@@ -1181,6 +1181,7 @@ extern char *getenv ();
|
||||
#ifdef HAVE_STDLIB_H
|
||||
#include <stdlib.h>
|
||||
#endif
|
||||
+#if !defined(__DragonFly__)
|
||||
#ifdef HAVE_ALLOCA_H
|
||||
# include <alloca.h>
|
||||
#elif defined __GNUC__
|
||||
@@ -1194,6 +1195,7 @@ extern "C"
|
||||
# endif
|
||||
void *alloca (size_t);
|
||||
#endif
|
||||
+#endif /* __DragonFly__ */
|
||||
#ifndef HAVE_SIZE_T
|
||||
typedef unsigned size_t;
|
||||
#endif
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_m_amdx86-64.h,v 1.1 2011/12/11 21:00:43 marino Exp $
|
||||
|
||||
--- src/m/amdx86-64.h.orig 2011-11-26 03:20:20.000000000 +0000
|
||||
+++ src/m/amdx86-64.h
|
||||
@@ -101,6 +101,10 @@ along with GNU Emacs. If not, see <http
|
||||
|
||||
/* LIB_STANDARD and START_FILES set correctly in s/netbsd.h */
|
||||
|
||||
+#elif defined(__DragonFly__)
|
||||
+
|
||||
+/* LIB_STANDARD and START_FILES set correctly in s/dragonfly.h */
|
||||
+
|
||||
#elif defined(SOLARIS2)
|
||||
|
||||
#undef START_FILES
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-src_xgselect.c,v 1.1 2012/05/09 09:30:07 wiz Exp $
|
||||
|
||||
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=10631
|
||||
|
||||
--- src/xgselect.c.orig 2012-01-11 12:35:01.000000000 +0000
|
||||
+++ src/xgselect.c
|
||||
@@ -55,6 +55,9 @@ xg_select (max_fds, rfds, wfds, efds, ti
|
||||
do {
|
||||
if (n_gfds > gfds_size)
|
||||
{
|
||||
+ if (gfds_size == 0)
|
||||
+ xgselect_initialize ();
|
||||
+
|
||||
while (n_gfds > gfds_size)
|
||||
gfds_size *= 2;
|
||||
xfree (gfds);
|
|
@ -1,7 +0,0 @@
|
|||
# $NetBSD: version.mk,v 1.8 2012/02/19 17:44:35 minskim Exp $
|
||||
|
||||
_EMACS_FLAVOR= emacs
|
||||
_EMACS_REQD= emacs>=23.2<24
|
||||
|
||||
_EMACS_VERSION_MAJOR= 23
|
||||
_EMACS_VERSION_MINOR= 4
|
Loading…
Reference in a new issue