Update from version 1.11 to 1.15.
Pkgsrc changes: o Add new dependencies; and p5-HTML-Stream appears to be not only a build-time dependency o Fix Pod::Tree::HTML to actually write to a referenced string, using IO::String o Get rid of the half-assed IO::String dummy in the html test, and adapt to using IO::String instead This makes the self-tests pass. Diffs reported upstream. Upstream changes: 1.15 2007 Jun 24 Rename pod2html -> podtree2html (RT 18742) Pod::Tree::HTML - Changed destination resolution to accept a scalar reference, or anything with a 'print' method. (RT 12335) podtree2html, pods2html - documented HTML elements for CSS rules (RT 6118) pod.css - add example style sheet 1.14 2007 Jun 12 Pod::Tree::HTML - remove use vars qw(&isa); (RT 14530) - document translate() error conditions (RT 12336) Makefile.PL - add Text::Template prerequisite (RT 26440) 1.13 2007 Apr 06 Pod::Tree - rename the Stream package Pod::Tree::HTML - change the X<> markup to render as empty, per the perlpod manpage - rename the BitBucket package - add template support Pod::Tree:PerlUtil - handle malformed NAME paragraphs more gracefully pod2html - add template support pods2html - add template support 1.12 2006 Apr 22 Pod::Tree::PerlBin - ignore non-existant directories on $PATH - protect File::Find::find from empty directory list Pod::Tree:PerlFunc - find the pod/ directory under either perl/ or perl/lib/ (Win32 issue) Pod::Tree::PerlLib - increase default col_width to 30 Pod::Tree:PerlTop - find the pod/ directory under either perl/ or perl/lib/ (Win32 issue) Pod::Tree:PerlUtil - clean up whitespace in module names and descriptions pods2html - recursion check compares absolute paths instead of inodes (Win32 issue) t/pods2html.t - use rmtree instead of system "rm -r" (Win32 issue)
This commit is contained in:
parent
4ec5a1e7de
commit
aa596c0383
6 changed files with 99 additions and 8 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.3 2008/06/12 02:14:48 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2008/08/07 23:26:01 he Exp $
|
||||
|
||||
DISTNAME= Pod-Tree-1.11
|
||||
DISTNAME= Pod-Tree-1.15
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
CATEGORIES= textproc devel perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Pod/}
|
||||
|
@ -11,8 +11,10 @@ COMMENT= Create a static syntax tree for a POD
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILD_DEPENDS+= p5-HTML-Stream>=1.49:../../www/p5-HTML-Stream
|
||||
DEPENDS+= p5-HTML-Stream>=1.49:../../www/p5-HTML-Stream
|
||||
DEPENDS+= p5-Pod-Escapes>=1.02:../../textproc/p5-Pod-Escapes
|
||||
DEPENDS+= p5-Text-Template>=1.0:../../textproc/p5-Text-Template
|
||||
DEPENDS+= p5-IO-String-[0-9]*:../../devel/p5-IO-String
|
||||
|
||||
PERL5_PACKLIST= auto/Pod/Tree/.packlist
|
||||
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/08/06 22:57:53 he Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/08/07 23:26:01 he Exp $
|
||||
|
||||
SHA1 (Pod-Tree-1.11.tar.gz) = e7dedd08a8bb885247d1cbb4150bf18f38f297b2
|
||||
RMD160 (Pod-Tree-1.11.tar.gz) = 4774d700885fffbe86a82a501bf6682b0ce3a360
|
||||
Size (Pod-Tree-1.11.tar.gz) = 56445 bytes
|
||||
SHA1 (patch-aa) = da39a3ee5e6b4b0d3255bfef95601890afd80709
|
||||
SHA1 (Pod-Tree-1.15.tar.gz) = 408227e0ae5e828b9fce79c65f9aefc2ef7969fd
|
||||
RMD160 (Pod-Tree-1.15.tar.gz) = fb6e5bace9fbd91e4f05b171b583defcdd677b26
|
||||
Size (Pod-Tree-1.15.tar.gz) = 65505 bytes
|
||||
SHA1 (patch-ab) = 5b03d559a10071232b1ac162393d71ec42ce9cd7
|
||||
SHA1 (patch-ac) = e935edd9ca7eecc68b2d4fc0eea9795ecc1f594c
|
||||
SHA1 (patch-ad) = d3b22d9ed8f92930b6fa3244511c2fc69a2cac09
|
||||
|
|
26
textproc/p5-Pod-Tree/patches/patch-ab
Normal file
26
textproc/p5-Pod-Tree/patches/patch-ab
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-ab,v 1.1 2008/08/07 23:26:01 he Exp $
|
||||
|
||||
--- lib/Pod/Tree/HTML.pm.orig 2007-06-24 16:51:41.000000000 +0200
|
||||
+++ lib/Pod/Tree/HTML.pm
|
||||
@@ -5,6 +5,7 @@
|
||||
use strict;
|
||||
use HTML::Stream;
|
||||
use IO::File;
|
||||
+use IO::String;
|
||||
use Pod::Tree;
|
||||
use Text::Template;
|
||||
|
||||
@@ -120,7 +121,12 @@ sub _resolve_dest
|
||||
isa($dest, 'IO::File' ) and return ($dest, new HTML::Stream $dest);
|
||||
can($dest, 'print' ) and return ($dest, new HTML::Stream $dest);
|
||||
|
||||
- if (ref $dest eq 'SCALAR' or ref $dest eq '' and $dest)
|
||||
+ if (ref $dest eq 'SCALAR')
|
||||
+ {
|
||||
+ my $fh = new IO::String $dest;
|
||||
+ return ($fh, new HTML::Stream $fh);
|
||||
+ }
|
||||
+ if (ref $dest eq '' and $dest)
|
||||
{
|
||||
my $fh = new IO::File;
|
||||
$fh->open($dest, '>') or die "Pod::Tree::HTML::new: Can't open $dest: $!\n";
|
50
textproc/p5-Pod-Tree/patches/patch-ac
Normal file
50
textproc/p5-Pod-Tree/patches/patch-ac
Normal file
|
@ -0,0 +1,50 @@
|
|||
$NetBSD: patch-ac,v 1.1 2008/08/07 23:26:01 he Exp $
|
||||
|
||||
--- t/html.t.orig 2007-06-24 16:57:52.000000000 +0200
|
||||
+++ t/html.t
|
||||
@@ -3,6 +3,7 @@
|
||||
use strict;
|
||||
use diagnostics;
|
||||
use HTML::Stream;
|
||||
+use IO::String;
|
||||
use Pod::Tree;
|
||||
use Pod::Tree::HTML;
|
||||
|
||||
@@ -97,7 +98,7 @@ sub Dest1
|
||||
$html->translate;
|
||||
|
||||
my $expected = ReadFile("$Dir/paragraph.exp");
|
||||
- $$actual eq $expected or Not; OK;
|
||||
+ ${$actual->string_ref} eq $expected or Not; OK;
|
||||
}
|
||||
|
||||
sub Dest2
|
||||
@@ -122,7 +123,7 @@ sub Dest3
|
||||
$html->translate;
|
||||
|
||||
my $expected = ReadFile("$Dir/paragraph.exp");
|
||||
- my $actual = $$string;
|
||||
+ my $actual = ${$string->string_ref};
|
||||
$actual eq $expected or Not; OK;
|
||||
}
|
||||
|
||||
@@ -265,19 +266,3 @@ sub WriteFile
|
||||
close FILE;
|
||||
chmod 0644, $file or die "Can't chmod $file: $!\n";
|
||||
}
|
||||
-
|
||||
-
|
||||
-package IO::String;
|
||||
-
|
||||
-sub new
|
||||
-{
|
||||
- my $self = '';
|
||||
- bless \$self, shift;
|
||||
-}
|
||||
-
|
||||
-sub print
|
||||
-{
|
||||
- my $self = shift;
|
||||
- $$self .= join('', @_);
|
||||
-}
|
||||
-
|
11
textproc/p5-Pod-Tree/patches/patch-ad
Normal file
11
textproc/p5-Pod-Tree/patches/patch-ad
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ad,v 1.1 2008/08/07 23:26:01 he Exp $
|
||||
|
||||
--- Makefile.PL.orig 2008-08-08 01:02:27.000000000 +0200
|
||||
+++ Makefile.PL
|
||||
@@ -16,5 +16,6 @@ WriteMakefile(NAME => 'Pod::Tree',
|
||||
EXE_FILES => [qw(podtree2html pods2html perl2html)],
|
||||
PREREQ_PM => { HTML::Stream => 1.49,
|
||||
Pod::Escapes => 1.02,
|
||||
+ IO::String => 0,
|
||||
Text::Template => 1 },
|
||||
);
|
Loading…
Reference in a new issue