Update postgresql to 7.0. Also closes PR#8616. Changes from 6.5.3:
A HUGE number of bug/performance fixes and minor enhancements. Foreign Keys Foreign keys are now implemented, with the exception of PARTIAL MATCH foreign keys. Many users have been asking for this feature, and we are pleased to offer it. Optimizer Overhaul Continuing on work started a year ago, the optimizer has been overhauled, allowing improved query execution and better performance with less memory usage. Updated psql psql, our interactive terminal monitor, has been updated with a variety of new features. See the psql manual page for details. Upcoming Features In 7.1 or 7.2, we plan to have outer joins, storage for very long rows, and a write-ahead logging system. A dump/restore using pg_dump is required for those wishing to migrate data from any previous release. For those upgrading from 6.5.*, you can use pg_upgrade to upgrade to this release.
This commit is contained in:
parent
9a969d709c
commit
aa73a794dd
30 changed files with 964 additions and 1287 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.48 2000/04/09 03:53:16 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.49 2000/05/20 19:32:18 jlam Exp $
|
||||
# FreeBSD Id: Makefile,v 1.22 1997/12/24 01:21:37 alex Exp
|
||||
#
|
||||
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/bison:../../devel/bison
|
||||
DEPENDS+= ncurses>=4.2:../../devel/ncurses
|
||||
DEPENDS+= readline-*:../../devel/readline
|
||||
|
||||
MAKEFILE= GNUmakefile
|
||||
|
@ -37,9 +36,7 @@ PLIST_SUBST= PGUSER=${PGUSER}
|
|||
CONFIGURE_ARGS+= --without-perl --without-odbc --without-tcl
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include # ncurses.h, readline.h
|
||||
|
||||
INSTALL_TARGET= install install-man
|
||||
CPPFLAGS+= -I${LOCALBASE}/include # readline.h
|
||||
|
||||
pre-install:
|
||||
@case "X${PGUSER}" in \
|
||||
|
@ -64,10 +61,9 @@ pre-install:
|
|||
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} PRE-INSTALL
|
||||
|
||||
post-install:
|
||||
cd ${PREFIX}; ${MV} include/pgsql/libpq++.H include/pgsql/libpq++.h
|
||||
cd ${PREFIX}/include/pgsql; ${RMDIR} -p port/netbsd
|
||||
|
||||
.for PROG in ecpg pg_dump pg_id pg_passwd pg_version postgres psql
|
||||
.for PROG in ecpg pg_dump pg_encoding pg_id pg_passwd pg_version postgres psql
|
||||
strip ${PREFIX}/bin/${PROG}
|
||||
.endfor
|
||||
${SED} -e 's|@PATH@|${PATH}|g' \
|
||||
|
@ -85,13 +81,22 @@ post-install:
|
|||
${INSTALL} -c -o root -g ${PGGROUP} -m 554 \
|
||||
${WRKDIR}/pgsql.sh ${PREFIX}/etc/rc.d/pgsql.sh
|
||||
|
||||
${CAT} ${FILESDIR}/exclude ${FILESDIR}/man.tcl ${FILESDIR}/man.tk \
|
||||
| ${SED} "s,^#.*,," \
|
||||
| ${GTAR} zxCXf ${PREFIX}/man - \
|
||||
${WRKDIR}/${DISTNAME}/doc/man.tar.gz
|
||||
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/postgresql
|
||||
cd ${WRKDIR}/${DISTNAME}/doc; \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} ${MAKE_FLAGS} all
|
||||
cd ${WRKDIR}/${DISTNAME}/doc; ${INSTALL_DATA} \
|
||||
FAQ FAQ_DEV README.fsync TODO bug.template internals.ps \
|
||||
admin.ps.gz programmer.ps.gz tutorial.ps.gz user.ps.gz \
|
||||
FAQ FAQ_DEV README.Charsets README.fsync README.inet \
|
||||
README.locale README.mb README.mb.jp TODO admin.ps.gz \
|
||||
bug.template internals.ps programmer.ps.gz tutorial.ps.gz \
|
||||
user.ps.gz \
|
||||
${PREFIX}/share/doc/postgresql
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/postgresql
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/html/postgresql
|
||||
|
||||
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} POST-INSTALL
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2000/03/18 17:43:16 jlam Exp $
|
||||
# $NetBSD: Makefile.common,v 1.2 2000/05/20 19:32:18 jlam Exp $
|
||||
|
||||
DISTNAME= postgresql-6.5.3
|
||||
DISTNAME= postgresql-${PG_VERS}
|
||||
PG_VERS= 7.0
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ftp://ftp.PostgreSQL.org/pub/ \
|
||||
|
@ -12,8 +13,8 @@ HOMEPAGE= http://www.PostgreSQL.ORG/
|
|||
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/autoreconf:../../devel/autoconf
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= # defined
|
||||
GNU_CONFIGURE= # defined
|
||||
|
||||
FILESDIR= ${.CURDIR}/../../databases/postgresql/files
|
||||
PATCHDIR= ${.CURDIR}/../../databases/postgresql/patches
|
||||
|
@ -23,12 +24,21 @@ PATCHDIR= ${.CURDIR}/../../databases/postgresql/patches
|
|||
CONFIGURE_ARGS+= --with-template="${LOWER_OPSYS}" \
|
||||
--enable-locale
|
||||
|
||||
# PG_MB_ENCODING may be set to any of:
|
||||
#
|
||||
# SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL,
|
||||
# LATIN1, LATIN2, LATIN3, LATIN4, LATIN5, KOI8, WIN, ALT
|
||||
#
|
||||
# This variable controls the language encoding on the backend process.
|
||||
|
||||
.if defined(PG_MB_ENCODING)
|
||||
CONFIGURE_ARGS+= --enable-multibyte=${PG_MB_ENCODING}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --enable-multibyte # accept default
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@${CP} ${FILESDIR}/Makefile.custom ${WRKSRC}
|
||||
@${LN} -sf bsd.c ${WRKSRC}/backend/port/dynloader/netbsd.c
|
||||
@${LN} -sf bsd.h ${WRKSRC}/backend/port/dynloader/netbsd.h
|
||||
@${LN} -sf bsd.h ${WRKSRC}/include/port/netbsd.h
|
||||
@${LN} -sf Makefile.bsd ${WRKSRC}/makefiles/Makefile.netbsd
|
||||
${CP} ${FILESDIR}/Makefile.custom ${WRKSRC}
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC}; ${LOCALBASE}/bin/autoreconf
|
||||
|
|
|
@ -4,17 +4,17 @@
|
|||
# sub-Makefile in the build tree. Makefiles for shared libraries include
|
||||
# Makefile.global then Makefile.shlib.
|
||||
#
|
||||
# $NetBSD: Makefile.custom,v 1.3 2000/04/09 03:53:17 jlam Exp $
|
||||
# $NetBSD: Makefile.custom,v 1.4 2000/05/20 19:32:19 jlam Exp $
|
||||
|
||||
# Where the database templates are stored
|
||||
#
|
||||
TEMPLATEDIR= $(POSTGRESDIR)/share/postgresql
|
||||
TEMPLATEDIR= $(POSTGRESDIR)/share/postgresql
|
||||
|
||||
# installation directory for documentation
|
||||
PGDOCS= $(POSTGRESDIR)/share/doc/postgresql
|
||||
PGDOCS= $(POSTGRESDIR)/share/doc/html/postgresql
|
||||
|
||||
# Where the header files necessary to build frontend programs get installed.
|
||||
HEADERDIR= $(POSTGRESDIR)/include/pgsql
|
||||
HEADERDIR= $(POSTGRESDIR)/include/pgsql
|
||||
|
||||
# Where the ODBC installation-wide configuration file gets installed.
|
||||
ODBCINST= etc
|
||||
|
|
4
databases/postgresql/files/exclude
Normal file
4
databases/postgresql/files/exclude
Normal file
|
@ -0,0 +1,4 @@
|
|||
# $NetBSD: exclude,v 1.1 2000/05/20 19:32:20 jlam Exp $
|
||||
#
|
||||
man1/pgaccess.1
|
||||
man1/pgadmin.1
|
3
databases/postgresql/files/man.tcl
Normal file
3
databases/postgresql/files/man.tcl
Normal file
|
@ -0,0 +1,3 @@
|
|||
# $NetBSD: man.tcl,v 1.1 2000/05/20 19:32:21 jlam Exp $
|
||||
#
|
||||
man1/pgtclsh.1
|
3
databases/postgresql/files/man.tk
Normal file
3
databases/postgresql/files/man.tk
Normal file
|
@ -0,0 +1,3 @@
|
|||
# $NetBSD: man.tk,v 1.1 2000/05/20 19:32:22 jlam Exp $
|
||||
#
|
||||
man1/pgtksh.1
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.7 1999/12/02 01:47:06 darcy Exp $
|
||||
$NetBSD: md5,v 1.8 2000/05/20 19:32:22 jlam Exp $
|
||||
|
||||
MD5 (postgresql-6.5.3.tar.gz) = 098d1ee4316500a2d033ced3ebd5b831
|
||||
MD5 (postgresql-7.0.tar.gz) = 7fefc2f9d9430a4012aac6c78497db85
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
; $NetBSD: odbc.ini,v 1.1 2000/03/18 17:43:16 jlam Exp $
|
||||
; $NetBSD: odbcinst.ini,v 1.1 2000/05/20 19:32:26 jlam Exp $
|
||||
;
|
||||
; /etc/odbc.ini - site-wide ODBC configuration file
|
||||
|
|
@ -1,22 +1,8 @@
|
|||
$NetBSD: patch-sum,v 1.9 2000/03/18 17:43:16 jlam Exp $
|
||||
$NetBSD: patch-sum,v 1.10 2000/05/20 19:32:27 jlam Exp $
|
||||
|
||||
MD5 (patch-aa) = bc49aa9d9fce8df90213078d92761249
|
||||
MD5 (patch-ab) = 8ca4b77d8e1b817ebc034572fbe2b1fc
|
||||
MD5 (patch-ac) = 70fd9e904ad4991a9f69f1e8afcc3d4a
|
||||
MD5 (patch-ad) = c9065a8a153f76ae8d673847d94a307b
|
||||
MD5 (patch-ae) = c5e24d270c84b2578e2a401ff21f8741
|
||||
MD5 (patch-af) = f83f4fe4788297ce80961a3bbe80d5ab
|
||||
MD5 (patch-ag) = bd973c4082172fee6ec5d4e27bd2efc5
|
||||
MD5 (patch-ah) = 4a61e815a957790c494ff8465ef2c706
|
||||
MD5 (patch-ai) = eb34208242c64709ebaa569368a8693d
|
||||
MD5 (patch-aj) = 936e6e472154183587af08a273dd5596
|
||||
MD5 (patch-ak) = a4dd0fa1e1854007f452a45e79a83436
|
||||
MD5 (patch-al) = cfbc7e6e7929bd9d97dd1333e06bc97f
|
||||
MD5 (patch-am) = 20bdf8b311fad190c40b35a27d0d0f35
|
||||
MD5 (patch-an) = 5896789239612120cb87d218b375c921
|
||||
MD5 (patch-ao) = 1705f355ea045f2742115a8035333df9
|
||||
MD5 (patch-ap) = 56a512c3e9aef5e09c37eef18097fcd8
|
||||
MD5 (patch-aq) = 9c3500fe79d72d4417af9137c76540d6
|
||||
MD5 (patch-ar) = fc00fb16650ec4c68f74d39b7f03a3e9
|
||||
MD5 (patch-as) = 4df43103e0a4346e2cf0ec7724192844
|
||||
MD5 (patch-at) = 0cef1d02ee234cc9a8a0a9db26810e3b
|
||||
MD5 (patch-aa) = f64a0fc59be9b4aaed41376ac8870a4f
|
||||
MD5 (patch-ab) = f81b6a1f8459eae323dbf141f6d617ab
|
||||
MD5 (patch-ac) = eb26d0e3cec52fa4b17d6486314ebd05
|
||||
MD5 (patch-ad) = 1eff11ecb293cf8817851708cb4f5a5b
|
||||
MD5 (patch-ae) = 86929b61d882df8993d54b69e481fbbe
|
||||
MD5 (patch-af) = fb46bcb6524f8479f50e07bf9fc5d516
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- Makefile.global.in.orig Mon Nov 1 23:45:47 1999
|
||||
+++ Makefile.global.in Thu Mar 16 17:49:44 2000
|
||||
@@ -54,6 +54,11 @@
|
||||
ELF_SYSTEM= @ELF_SYS@
|
||||
|
||||
LIBPQDIR:= $(SRCDIR)/interfaces/libpq
|
||||
+LIBPGTCLDIR:= $(SRCDIR)/interfaces/libpgtcl
|
||||
+
|
||||
+LIBPQ:= -L$(LIBPQDIR) -lpq
|
||||
+LIBPGTCL:= -L$(LIBPGTCLDIR) -lpgtcl
|
||||
+
|
||||
|
||||
# For convenience, POSTGRESDIR is where BINDIR, and LIBDIR
|
||||
# and other target destinations are rooted. Of course, each of these is
|
||||
@@ -69,6 +74,10 @@
|
||||
# can just put the absolute pathname to the library at the end of your
|
||||
# command line.
|
||||
LIBDIR= $(POSTGRESDIR)/lib
|
||||
+
|
||||
+# Where the database templates are stored
|
||||
+#
|
||||
+TEMPLATEDIR= $(POSTGRESDIR)/lib
|
||||
|
||||
# This is the directory where IPC utilities ipcs and ipcrm are located
|
||||
#
|
|
@ -1,29 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.8 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- Makefile.shlib.orig Fri Jul 30 00:13:44 1999
|
||||
+++ Makefile.shlib Thu Mar 16 17:49:44 2000
|
||||
@@ -109,6 +109,24 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
+ifeq ($(PORTNAME), netbsd)
|
||||
+ ifdef BSD_SHLIB
|
||||
+ install-shlib-dep := install-shlib
|
||||
+ soname := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
||||
+ shlib := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
||||
+ ifdef ELF_SYSTEM
|
||||
+ LD := $(CC)
|
||||
+ LDFLAGS_SL := -shared -Wl,-soname -Wl,$(soname)
|
||||
+ ifneq ($(SHLIB_LINK),)
|
||||
+ LDFLAGS_SL += -Wl,-R$(LIBDIR)
|
||||
+ endif
|
||||
+ else
|
||||
+ LDFLAGS_SL := -x -Bshareable -Bforcearchive
|
||||
+ endif
|
||||
+ CFLAGS += $(CFLAGS_SL)
|
||||
+ endif
|
||||
+endif
|
||||
+
|
||||
ifeq ($(PORTNAME), hpux)
|
||||
install-shlib-dep := install-shlib
|
||||
# HPUX doesn't believe in version numbers for shlibs
|
|
@ -1,58 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.5 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- backend/Makefile.orig Sun Mar 7 18:05:56 1999
|
||||
+++ backend/Makefile Thu Mar 16 17:56:36 2000
|
||||
@@ -156,10 +156,11 @@
|
||||
# and (2) the parameters of a database system should be set at initdb time,
|
||||
# not at postgres build time.
|
||||
|
||||
-.PHONY: install install-bin install-lib install-headers
|
||||
+.PHONY: install install-bin install-templates install-headers
|
||||
|
||||
-install: $(LIBDIR) $(BINDIR) $(HEADERDIR) postgres $(POSTGRES_IMP) \
|
||||
- install-bin install-lib install-headers
|
||||
+install: $(LIBDIR) $(BINDIR) $(HEADERDIR) $(TEMPLATEDIR) \
|
||||
+ postgres $(POSTGRES_IMP) \
|
||||
+ install-bin install-templates install-headers
|
||||
|
||||
install-bin: $(BINDIR) postgres$(X) $(POSTGRES_IMP)
|
||||
$(INSTALL) $(INSTL_EXE_OPTS) postgres$(X) $(BINDIR)/postgres$(X)
|
||||
@@ -175,22 +176,22 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
-install-lib: $(LIBDIR) \
|
||||
+install-templates: $(TEMPLATEDIR) \
|
||||
global1.bki.source local1_template1.bki.source \
|
||||
global1.description local1_template1.description \
|
||||
libpq/pg_hba.conf.sample optimizer/geqo/pg_geqo.sample
|
||||
$(INSTALL) $(INSTLOPTS) global1.bki.source \
|
||||
- $(LIBDIR)/global1.bki.source
|
||||
+ $(TEMPLATEDIR)/global1.bki.source
|
||||
$(INSTALL) $(INSTLOPTS) global1.description \
|
||||
- $(LIBDIR)/global1.description
|
||||
+ $(TEMPLATEDIR)/global1.description
|
||||
$(INSTALL) $(INSTLOPTS) local1_template1.bki.source \
|
||||
- $(LIBDIR)/local1_template1.bki.source
|
||||
+ $(TEMPLATEDIR)/local1_template1.bki.source
|
||||
$(INSTALL) $(INSTLOPTS) local1_template1.description \
|
||||
- $(LIBDIR)/local1_template1.description
|
||||
+ $(TEMPLATEDIR)/local1_template1.description
|
||||
$(INSTALL) $(INSTLOPTS) libpq/pg_hba.conf.sample \
|
||||
- $(LIBDIR)/pg_hba.conf.sample
|
||||
+ $(TEMPLATEDIR)/pg_hba.conf.sample
|
||||
$(INSTALL) $(INSTLOPTS) optimizer/geqo/pg_geqo.sample \
|
||||
- $(LIBDIR)/pg_geqo.sample
|
||||
+ $(TEMPLATEDIR)/pg_geqo.sample
|
||||
|
||||
install-headers: fmgr.h $(SRCDIR)/include/config.h
|
||||
@if [ ! -d $(HEADERDIR) ]; then mkdir $(HEADERDIR); fi
|
||||
@@ -253,6 +254,8 @@
|
||||
$(LIBDIR):
|
||||
mkdir $@
|
||||
$(HEADERDIR):
|
||||
+ mkdir $@
|
||||
+$(TEMPLATEDIR):
|
||||
mkdir $@
|
||||
|
||||
#############################################################################
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.6 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- bin/pg_dump/Makefile.in.orig Sun Jan 17 01:19:05 1999
|
||||
+++ bin/pg_dump/Makefile.in Thu Mar 16 17:49:44 2000
|
||||
@@ -29,7 +29,7 @@
|
||||
all: submake pg_dump
|
||||
|
||||
pg_dump: $(OBJS) $(LIBPQDIR)/libpq.a
|
||||
- $(CC) -o pg_dump -L$(LIBPQDIR) $(OBJS) -lpq $(LDFLAGS)
|
||||
+ $(CC) -o pg_dump $(OBJS) $(LIBPQ) $(LDFLAGS)
|
||||
|
||||
../../utils/strdup.o:
|
||||
$(MAKE) -C ../../utils strdup.o
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.10 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- bin/pg_encoding/Makefile.orig Sat Jun 5 06:27:31 1999
|
||||
+++ bin/pg_encoding/Makefile Thu Mar 16 17:49:44 2000
|
||||
@@ -20,7 +20,7 @@
|
||||
all: pg_encoding
|
||||
|
||||
pg_encoding: $(OBJS) $(LIBPQDIR)/libpq.a
|
||||
- $(CC) -o pg_encoding $(OBJS) -L$(LIBPQDIR) -lpq $(LDFLAGS)
|
||||
+ $(CC) -o pg_encoding $(OBJS) $(LIBPQ) $(LDFLAGS)
|
||||
|
||||
install: pg_encoding
|
||||
$(INSTALL) $(INSTL_EXE_OPTS) pg_encoding$(X) $(BINDIR)/pg_encoding$(X)
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.7 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- bin/pg_id/Makefile.orig Sun Jan 17 01:19:10 1999
|
||||
+++ bin/pg_id/Makefile Thu Mar 16 17:49:44 2000
|
||||
@@ -27,7 +27,7 @@
|
||||
all: pg_id
|
||||
|
||||
pg_id: $(OBJS) $(LIBPQDIR)/libpq.a
|
||||
- $(CC) -o pg_id -L$(LIBPQDIR) $(OBJS) -lpq $(LDFLAGS)
|
||||
+ $(CC) -o pg_id $(OBJS) $(LIBPQ) $(LDFLAGS)
|
||||
|
||||
$(LIBPQDIR)/libpq.a:
|
||||
$(MAKE) -C $(LIBPQDIR) libpq.a
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.5 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- bin/pgtclsh/Makefile.orig Tue Oct 27 16:51:54 1998
|
||||
+++ bin/pgtclsh/Makefile Thu Mar 16 17:49:44 2000
|
||||
@@ -22,15 +22,12 @@
|
||||
include Makefile.tkdefs
|
||||
endif
|
||||
|
||||
-CFLAGS+= $(X_CFLAGS) -I$(SRCDIR)/interfaces/libpgtcl
|
||||
+CFLAGS+= $(X_CFLAGS) -I$(LIBPGTCLDIR)
|
||||
|
||||
ifdef KRBVERS
|
||||
LDFLAGS+= $(KRBLIBS)
|
||||
CFLAGS+= $(KRBFLAGS)
|
||||
endif
|
||||
-
|
||||
-LIBPGTCL= -L$(SRCDIR)/interfaces/libpgtcl -lpgtcl
|
||||
-LIBPQ= -L$(LIBPQDIR) -lpq
|
||||
|
||||
# If we are here then TCL is available
|
||||
PGMS = pgtclsh
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.5 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- bin/psql/Makefile.in.orig Sun Jan 17 01:19:19 1999
|
||||
+++ bin/psql/Makefile.in Thu Mar 16 17:49:44 2000
|
||||
@@ -33,7 +33,7 @@
|
||||
all: submake psql
|
||||
|
||||
psql: $(OBJS) $(LIBPQDIR)/libpq.a
|
||||
- $(CC) -o psql -L$(LIBPQDIR) $(OBJS) -lpq $(LDFLAGS)
|
||||
+ $(CC) -o psql $(OBJS) $(LIBPQ) $(LDFLAGS)
|
||||
|
||||
../../utils/strdup.o:
|
||||
$(MAKE) -C ../../utils strdup.o
|
|
@ -1,41 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.5 2000/03/18 17:43:55 jlam Exp $
|
||||
|
||||
--- bin/psql/psql.c.orig Fri Jun 4 17:21:13 1999
|
||||
+++ bin/psql/psql.c Thu Mar 16 17:49:44 2000
|
||||
@@ -45,28 +45,23 @@
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_LIBREADLINE
|
||||
-#ifdef HAVE_READLINE_H
|
||||
-#include <readline.h>
|
||||
-#define USE_READLINE 1
|
||||
-#if defined(HAVE_HISTORY_H)
|
||||
-#include <history.h>
|
||||
-#define USE_HISTORY 1
|
||||
-#endif
|
||||
-#else
|
||||
#if defined(HAVE_READLINE_READLINE_H)
|
||||
#include <readline/readline.h>
|
||||
#define USE_READLINE 1
|
||||
+#elif defined(HAVE_READLINE_H)
|
||||
+#include <readline.h>
|
||||
+#define USE_READLINE 1
|
||||
+#endif
|
||||
+#endif
|
||||
+#if defined(HAVE_HISTORY)
|
||||
#if defined(HAVE_READLINE_HISTORY_H)
|
||||
#include <readline/history.h>
|
||||
#define USE_HISTORY 1
|
||||
-#endif
|
||||
-#endif
|
||||
-#endif
|
||||
-#if defined(HAVE_HISTORY) && !defined(USE_HISTORY)
|
||||
+#elif defined(HAVE_HISTORY_H)
|
||||
+#include <history.h>
|
||||
#define USE_HISTORY 1
|
||||
#endif
|
||||
#endif
|
||||
-
|
||||
|
||||
#ifdef WIN32
|
||||
#define popen(x,y) _popen(x,y)
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.5 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- configure.in.orig Mon Nov 1 19:24:29 1999
|
||||
+++ configure.in Thu Mar 16 17:49:44 2000
|
||||
@@ -23,11 +23,7 @@
|
||||
bsdi*) os=bsdi need_tas=no ;;
|
||||
freebsd1*|freebsd2*) os=freebsd need_tas=no ;;
|
||||
freebsd*) os=freebsd need_tas=no elf=yes ;;
|
||||
- netbsd*)
|
||||
- os=bsd need_tas=no
|
||||
- case "$host_cpu" in
|
||||
- powerpc) elf=yes ;;
|
||||
- esac ;;
|
||||
+ netbsd*) os=netbsd need_tas=no ;;
|
||||
openbsd*) os=bsd need_tas=no ;;
|
||||
dgux*) os=dgux need_tas=no ;;
|
||||
aix*) os=aix need_tas=no ;;
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.2 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- include/port/bsd.h.orig Tue May 25 12:14:29 1999
|
||||
+++ include/port/bsd.h Thu Mar 16 17:49:44 2000
|
||||
@@ -1,16 +1,16 @@
|
||||
#define USE_POSIX_TIME
|
||||
|
||||
-#if defined(i386)
|
||||
+#if defined(__i386__)
|
||||
#define NEED_I386_TAS_ASM
|
||||
#define HAS_TEST_AND_SET
|
||||
#endif
|
||||
|
||||
-#if defined(sparc)
|
||||
+#if defined(__sparc__)
|
||||
#define NEED_SPARC_TAS_ASM
|
||||
#define HAS_TEST_AND_SET
|
||||
#endif
|
||||
|
||||
-#if defined(vax)
|
||||
+#if defined(__vax__)
|
||||
#define NEED_VAX_TAS_ASM
|
||||
#define HAS_TEST_AND_SET
|
||||
#endif
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-al,v 1.3 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/ecpg/lib/Makefile.in.orig Wed Jun 30 19:57:23 1999
|
||||
+++ interfaces/ecpg/lib/Makefile.in Thu Mar 16 17:49:44 2000
|
||||
@@ -12,12 +12,12 @@
|
||||
|
||||
NAME= ecpg
|
||||
SO_MAJOR_VERSION= 3
|
||||
-SO_MINOR_VERSION= 0.0
|
||||
+SO_MINOR_VERSION= 0
|
||||
|
||||
SRCDIR= @top_srcdir@
|
||||
include $(SRCDIR)/Makefile.global
|
||||
|
||||
-CFLAGS+= -I../include -I$(SRCDIR)/interfaces/libpq
|
||||
+CFLAGS+= -I../include -I$(LIBPQDIR)
|
||||
|
||||
ifdef KRBVERS
|
||||
CFLAGS+= $(KRBFLAGS)
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
OBJS= ecpglib.o typename.o
|
||||
|
||||
-SHLIB_LINK= -L../../libpq -lpq
|
||||
+SHLIB_LINK= $(LIBPQ)
|
||||
|
||||
# Shared library stuff, also default 'all' target
|
||||
include $(SRCDIR)/Makefile.shlib
|
|
@ -1,39 +0,0 @@
|
|||
$NetBSD: patch-am,v 1.4 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/jdbc/Makefile.orig Wed Jun 23 01:56:17 1999
|
||||
+++ interfaces/jdbc/Makefile Thu Mar 16 17:49:44 2000
|
||||
@@ -27,7 +27,7 @@
|
||||
# In 6.5, the all rule builds the makeVersion class which then calls make using
|
||||
# the jdbc1 or jdbc2 rules
|
||||
all: makeVersion.class
|
||||
- make $$($(JAVA) makeVersion)
|
||||
+ $(MAKE) $$($(JAVA) makeVersion)
|
||||
@echo ------------------------------------------------------------
|
||||
@echo The JDBC driver has now been built. To make it available to
|
||||
@echo other applications, copy the postgresql.jar file to a public
|
||||
@@ -45,10 +45,10 @@
|
||||
@echo
|
||||
@echo ------------------------------------------------------------
|
||||
@echo To build the examples, type:
|
||||
- @echo " make examples"
|
||||
+ @echo " $(MAKE) examples"
|
||||
@echo
|
||||
@echo "To build the CORBA example (requires Java2):"
|
||||
- @echo " make corba"
|
||||
+ @echo " $(MAKE) corba"
|
||||
@echo ------------------------------------------------------------
|
||||
@echo
|
||||
|
||||
@@ -121,10 +121,10 @@
|
||||
@echo JDBC 1 specification, and one to the JDBC 2 specification.
|
||||
@echo
|
||||
@echo To build the driver for JDBC 1 (usually for JDK 1.1 thru 1.1.7)
|
||||
- @echo then type: make jdbc1
|
||||
+ @echo then type: $(MAKE) jdbc1
|
||||
@echo
|
||||
@echo To build the driver for JDBC 2 (usually for JDK 1.2 and later)
|
||||
- @echo then type: make jdbc2
|
||||
+ @echo then type: $(MAKE) jdbc2
|
||||
@echo
|
||||
@echo If you still have problems, then please email the interfaces
|
||||
@echo or bugs lists, or better still to me direct (peter@retep.org.uk)
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-an,v 1.2 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/libpgtcl/Makefile.in.orig Wed Jun 30 19:57:24 1999
|
||||
+++ interfaces/libpgtcl/Makefile.in Thu Mar 16 17:49:44 2000
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
OBJS= pgtcl.o pgtclCmds.o pgtclId.o
|
||||
|
||||
-SHLIB_LINK+= -L../libpq -lpq
|
||||
+SHLIB_LINK+= $(LIBPQ)
|
||||
|
||||
# If crypt is a separate library, rather than part of libc, it may need
|
||||
# to be referenced separately to keep (broken) linkers happy. (This is
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ao,v 1.2 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/libpq++/Makefile.in.orig Tue Sep 7 14:11:35 1999
|
||||
+++ interfaces/libpq++/Makefile.in Thu Mar 16 17:49:44 2000
|
||||
@@ -43,9 +43,9 @@
|
||||
OBJS = pgconnection.o pgdatabase.o pgtransdb.o pgcursordb.o pglobject.o
|
||||
|
||||
ifeq ($(PORTNAME), win)
|
||||
-SHLIB_LINK+= --driver-name g++ -L../libpq -lpq
|
||||
+SHLIB_LINK+= --driver-name g++ $(LIBPQ)
|
||||
else
|
||||
-SHLIB_LINK= -L../libpq -lpq
|
||||
+SHLIB_LINK= $(LIBPQ)
|
||||
endif
|
||||
|
||||
# For CC on IRIX, must use CC as linker/archiver of C++ libraries
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ap,v 1.1 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/odbc/GNUmakefile.in.orig Wed Jun 30 19:57:29 1999
|
||||
+++ interfaces/odbc/GNUmakefile.in Thu Mar 16 17:49:44 2000
|
||||
@@ -37,8 +37,6 @@
|
||||
pgtypes.o psqlodbc.o qresult.o results.o socket.o parse.o statement.o \
|
||||
gpps.o tuple.o tuplelist.o dlg_specific.o $(OBJX)
|
||||
|
||||
-SHLIB_LINK= $(LIBS)
|
||||
-
|
||||
# Shared library stuff, also default 'all' target
|
||||
include $(SRCDIR)/Makefile.shlib
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-aq,v 1.1 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/odbc/dlg_specific.h.orig Wed Jan 6 15:44:07 1999
|
||||
+++ interfaces/odbc/dlg_specific.h Thu Mar 16 17:49:45 2000
|
||||
@@ -35,9 +35,9 @@
|
||||
#ifdef ODBCINST
|
||||
#define xstr(s) str(s)
|
||||
#define str(s) #s
|
||||
-#define ODBCINST_INI xstr(ODBCINST) "/odbcinst.ini"
|
||||
+#define ODBCINST_INI xstr(ODBCINST) "/odbc.ini"
|
||||
#else
|
||||
-#define ODBCINST_INI "/etc/odbcinst.ini"
|
||||
+#define ODBCINST_INI "/etc/odbc.ini"
|
||||
#endif
|
||||
#else
|
||||
#define ODBC_INI "ODBC.INI" /* ODBC initialization file */
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-ar,v 1.1 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- interfaces/odbc/psqlodbc.c.orig Mon Dec 28 20:49:57 1998
|
||||
+++ interfaces/odbc/psqlodbc.c Thu Mar 16 17:49:45 2000
|
||||
@@ -33,8 +33,8 @@
|
||||
|
||||
GLOBAL_VALUES globals;
|
||||
|
||||
-BOOL _init(void);
|
||||
-BOOL _fini(void);
|
||||
+static BOOL _init(void);
|
||||
+static BOOL _fini(void);
|
||||
RETCODE SQL_API SQLDummyOrdinal(void);
|
||||
|
||||
#ifdef WIN32
|
||||
@@ -98,7 +98,7 @@
|
||||
#endif
|
||||
|
||||
/* These two functions do shared library initialziation on UNIX, well at least
|
||||
- * on Linux. I don't know about other systems.
|
||||
+ * on Linux and NetBSD. I don't know about other systems.
|
||||
*/
|
||||
BOOL
|
||||
_init(void)
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-as,v 1.1 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- pl/plpgsql/src/Makefile.in.orig Wed Jun 30 19:57:31 1999
|
||||
+++ pl/plpgsql/src/Makefile.in Thu Mar 16 17:49:45 2000
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
OBJS= pl_parse.o pl_handler.o pl_comp.o pl_exec.o pl_funcs.o
|
||||
|
||||
-SHLIB_LINK+= -L$(LIBPQDIR) -lpq
|
||||
+SHLIB_LINK+= $(LIBPQ)
|
||||
|
||||
# If crypt is a separate library, rather than part of libc, it may need
|
||||
# to be referenced separately to keep (broken) linkers happy. (This is
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-at,v 1.1 2000/03/18 17:43:17 jlam Exp $
|
||||
|
||||
--- pl/tcl/Makefile.orig Sun Dec 13 18:46:49 1998
|
||||
+++ pl/tcl/Makefile Thu Mar 16 17:49:45 2000
|
||||
@@ -75,7 +75,7 @@
|
||||
|
||||
CFLAGS+= $(TCL_DEFS)
|
||||
|
||||
-LDADD+= -L$(LIBPQDIR) -lpq
|
||||
+LDADD+= $(LIBPQ)
|
||||
|
||||
#
|
||||
# DLOBJS is the dynamically-loaded object file.
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue