Improve portability by using standard types.

This commit is contained in:
joerg 2010-01-08 17:02:42 +00:00
parent ca0c94c8c6
commit aaa7e62171
2 changed files with 30 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2008/12/26 20:23:45 hasso Exp $
$NetBSD: distinfo,v 1.7 2010/01/08 17:02:42 joerg Exp $
SHA1 (gpart-0.1h.tar.gz) = 23f66162e1d85977ea43bfe6b5e5bff0ad2d566e
RMD160 (gpart-0.1h.tar.gz) = 1cdfb1779801ee8755b05975ced24441a3a2b639
@ -8,3 +8,4 @@ SHA1 (patch-ab) = 43fda85fe6b11c00b256682c7184578a985b9397
SHA1 (patch-ac) = 15a57dd0e9b57c7a64869b43df37a5b2493e77d2
SHA1 (patch-ad) = e53ca24886c072d514802e7dca7a79da2e1916d0
SHA1 (patch-ae) = e9126b145ec8995645d79cd5d569da6e882b3c89
SHA1 (patch-af) = a201375f69b1581259a2bc287d7ce5ab7c7dafe4

View file

@ -0,0 +1,28 @@
$NetBSD: patch-af,v 1.1 2010/01/08 17:02:42 joerg Exp $
--- src/gm_ntfs.h.orig 2010-01-08 16:59:01.000000000 +0000
+++ src/gm_ntfs.h
@@ -29,18 +29,11 @@
/* 'NTFS' in little endian */
#define NTFS_SUPER_MAGIC 0x5346544E
-#if defined(i386) || defined(__i386__) || defined(__alpha__)
-
-/* unsigned integral types */
-#ifndef NTFS_INTEGRAL_TYPES
-#define NTFS_INTEGRAL_TYPES
-typedef unsigned char ntfs_u8;
-typedef unsigned short ntfs_u16;
-typedef unsigned int ntfs_u32;
-typedef s64_t ntfs_u64;
-#endif /* NTFS_INTEGRAL_TYPES */
-#endif /* defined(i386) || defined(__i386__) || defined(__alpha__) */
-
+#include <inttypes.h>
+typedef uint8_t ntfs_u8;
+typedef uint16_t ntfs_u16;
+typedef uint32_t ntfs_u32;
+typedef int64_t ntfs_u64;
/* Macros reading unsigned integers from a byte pointer */
/* these should work for all little endian machines */