Upgrade to tcl version 8.0.5. This seems to be primarily a bug-fix

release.
This commit is contained in:
agc 1999-04-01 13:36:55 +00:00
parent 7ad7d3c271
commit aaac4bc29e
11 changed files with 893 additions and 898 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.29 1999/03/28 21:50:17 hubertf Exp $
# $NetBSD: Makefile,v 1.30 1999/04/01 13:36:55 agc Exp $
# FreeBSD Id: Makefile,v 1.22 1997/12/24 01:21:37 alex Exp
#
@ -13,8 +13,8 @@ MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.PostgreSQL.ORG/
BUILD_DEPENDS+= bison:../../devel/bison
DEPENDS+= tk-8.0p2:../../x11/tk80
DEPENDS+= tcl-8.0p2:../../lang/tcl80
DEPENDS+= tk-8.0.5:../../x11/tk80
DEPENDS+= tcl-8.0.5:../../lang/tcl80
DEPENDS+= addnerd-1.6:../../sysutils/addnerd
# Needs ELF clue, mips has no TAS implementation

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 1999/02/20 22:48:29 hubertf Exp $
# $NetBSD: Makefile,v 1.9 1999/04/01 13:36:56 agc Exp $
#
DISTNAME= xblast-2.6.beta-sound
@ -10,8 +10,8 @@ MASTER_SITES= http://www.ikp.uni-koeln.de/~vogel/archive/
MAINTAINER= root@garbled.net
HOMEPAGE= http://www.ikp.uni-koeln.de/~vogel/xblast/xblast.html
BUILD_DEPENDS+= wish8.0:../../x11/tk80
BUILD_DEPENDS+= tclsh8.0:../../lang/tcl80
DEPENDS+= tcl-8.0.5:../../lang/tcl80
DEPENDS+= tk-8.0.5:../../x11/tk80
USE_IMAKE= yes

View file

@ -1,16 +1,16 @@
# $NetBSD: Makefile,v 1.19 1999/04/01 09:55:42 agc Exp $
# $NetBSD: Makefile,v 1.20 1999/04/01 13:36:56 agc Exp $
# FreeBSD Id: Makefile,v 1.1.1.1 1997/08/20 10:33:35 jkh Exp
#
DISTNAME= tcl8.0p2
PKGNAME= tcl-8.0p2
DISTNAME= tcl8.0.5
PKGNAME= tcl-8.0.5
CATEGORIES= lang
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_0/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.scriptics.com/
WRKSRC= ${WRKDIR}/tcl8.0/unix
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
GNU_CONFIGURE= yes
# Use disable-shared, so that libtool works with the generated Makefile

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.3 1998/08/07 13:24:58 agc Exp $
$NetBSD: md5,v 1.4 1999/04/01 13:36:56 agc Exp $
MD5 (tcl8.0p2.tar.gz) = c1ee11750153717cb8237b830867a0e6
MD5 (tcl8.0.5.tar.gz) = 4247975c801510fb378b76237b2abaaf

View file

@ -1,9 +1,9 @@
$NetBSD: patch-aa,v 1.10 1999/04/01 09:57:07 agc Exp $
$NetBSD: patch-aa,v 1.11 1999/04/01 13:36:56 agc Exp $
Configure this for libtool operation
--- Makefile.in.orig Tue Nov 25 16:31:41 1997
+++ Makefile.in Thu Sep 17 17:24:53 1998
--- Makefile.in.orig Tue Mar 9 06:51:26 1999
+++ Makefile.in Thu Apr 1 12:57:13 1999
@@ -55,7 +55,9 @@
BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
@ -15,7 +15,7 @@ Configure this for libtool operation
# Top-level directory in which to install manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -133,7 +135,7 @@
@@ -146,7 +148,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -24,7 +24,7 @@ Configure this for libtool operation
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -315,9 +317,7 @@
@@ -336,9 +338,7 @@
# The following target is configured by autoconf to generate either
# a shared library or non-shared library for Tcl.
${TCL_LIB_FILE}: ${OBJS}
@ -35,7 +35,7 @@ Configure this for libtool operation
# Make target which outputs the list of the .o contained in the Tcl lib
# usefull to build a single big shared library containing Tcl and other
@@ -330,20 +330,19 @@
@@ -351,20 +351,19 @@
# case
objs: ${OBJS}
@ -63,7 +63,7 @@ Configure this for libtool operation
# Note, in the target below TCL_LIBRARY needs to be set or else
@@ -421,21 +420,20 @@
@@ -444,17 +443,16 @@
fi; \
done;
@echo "Installing $(TCL_LIB_FILE)"
@ -87,12 +87,7 @@ Configure this for libtool operation
do \
if [ ! -d $$i ] ; then \
echo "Making directory $$i"; \
- mkdir $$i; \
+ mkdir -p $$i; \
chmod 755 $$i; \
else true; \
fi; \
@@ -449,8 +447,16 @@
@@ -472,8 +470,16 @@
else true; \
fi; \
done;
@ -111,7 +106,7 @@ Configure this for libtool operation
@for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex $(UNIX_DIR)/tclAppInit.c $(UNIX_DIR)/ldAix; \
do \
echo "Installing $$i"; \
@@ -502,6 +508,13 @@
@@ -525,6 +531,13 @@
chmod 444 $(MANN_INSTALL_DIR)/$$i; \
done;
$(UNIX_DIR)/mkLinks $(MANN_INSTALL_DIR)
@ -125,7 +120,7 @@ Configure this for libtool operation
Makefile: $(UNIX_DIR)/Makefile.in
$(SHELL) config.status
@@ -555,239 +568,239 @@
@@ -578,245 +591,245 @@
# Object files used on all Unix systems:
panic.o: $(GENERIC_DIR)/panic.c
@ -328,6 +323,10 @@ Configure this for libtool operation
- $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclProc.c
+ ${LIBTOOL} --mode=compile $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclProc.c
tclResolve.o: $(GENERIC_DIR)/tclResolve.c
- $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclResolve.c
+ ${LIBTOOL} --mode=compile $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclResolve.c
tclStringObj.o: $(GENERIC_DIR)/tclStringObj.c
- $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclStringObj.c
+ ${LIBTOOL} --mode=compile $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclStringObj.c
@ -348,6 +347,10 @@ Configure this for libtool operation
- $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclTestObj.c
+ ${LIBTOOL} --mode=compile $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclTestObj.c
tclTestProcBodyObj.o: $(GENERIC_DIR)/tclTestProcBodyObj.c
- $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclTestProcBodyObj.c
+ ${LIBTOOL} --mode=compile $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclTestProcBodyObj.c
tclTimer.o: $(GENERIC_DIR)/tclTimer.c
- $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclTimer.c
+ ${LIBTOOL} --mode=compile $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tclTimer.c

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.6 1999/04/01 09:59:04 agc Exp $
$NetBSD: patch-ab,v 1.7 1999/04/01 13:36:56 agc Exp $
Use -fPIC on NetBSD
On Solaris, fix up the tcl library name, so it's the same as NetBSD
@ -6,12 +6,11 @@ for pkgsrc internal use (PLIST entries)
On Solaris, do not use dots in version names for the library (same
reason as previous)
Use -fPIC on Solaris too, otherwise we overflow a 2048 entry table.
Set LDFLAGS to the correct value
Set TCL_SHARED_BUILD to 1.
--- configure.orig Tue Nov 25 16:31:42 1997
+++ configure Thu Sep 17 11:36:29 1998
@@ -3781,7 +3781,7 @@
--- configure.orig Tue Mar 9 06:51:26 1999
+++ configure Thu Apr 1 14:12:15 1999
@@ -4096,7 +4096,7 @@
if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
echo "$ac_t""yes" 1>&6
@ -20,7 +19,7 @@ Set TCL_SHARED_BUILD to 1.
SHLIB_LD="ld -Bshareable -x"
SHLIB_LD_LIBS=""
SHLIB_SUFFIX=".so"
@@ -3909,7 +3909,7 @@
@@ -4224,7 +4224,7 @@
TCL_LIB_VERSIONS_OK=nodots
;;
SunOS-5*)
@ -29,31 +28,22 @@ Set TCL_SHARED_BUILD to 1.
SHLIB_LD="/usr/ccs/bin/ld -G -z text"
# Note: need the LIBS below, otherwise Tk won't find Tcl's
@@ -3921,6 +3921,9 @@
@@ -4236,6 +4236,9 @@
DL_LIBS="-ldl"
LD_FLAGS=""
LD_SEARCH_FLAGS='-R ${LIB_RUNTIME_DIR}'
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ TCL_UNSHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.a'
+ TCL_SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.so.1.0'
+ TCL_UNSHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.a'
+ TCL_LIB_VERSIONS_OK=nodots
;;
ULTRIX-4.*)
SHLIB_CFLAGS="-G 0"
@@ -4345,6 +4348,8 @@
MAKE_LIB="ar cr ${TCL_LIB_FILE} \${OBJS}"
@@ -4679,6 +4682,8 @@
eval "TCL_LIB_FILE=libtcl${TCL_UNSHARED_LIB_SUFFIX}"
MAKE_LIB="ar cr \${TCL_LIB_FILE} \${OBJS}"
fi
+TCL_SHARED_BUILD=1
+
+TCL_SHARED_BUILD=1
# Note: in the following variable, it's important to use the absolute
# path name of the Tcl directory rather than "..": this is because
# AIX remembers this path and will attempt to use it at run-time to look
@@ -4518,7 +4523,7 @@
s%@BUILD_DLTEST@%$BUILD_DLTEST%g
s%@DL_LIBS@%$DL_LIBS%g
s%@DL_OBJS@%$DL_OBJS%g
-s%@LD_FLAGS@%$LD_FLAGS%g
+s%@LD_FLAGS@%$LDFLAGS%g
s%@MAKE_LIB@%$MAKE_LIB%g
s%@MATH_LIBS@%$MATH_LIBS%g
s%@SHLIB_CFLAGS@%$SHLIB_CFLAGS%g

File diff suppressed because it is too large Load diff

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.14 1998/11/19 15:40:46 agc Exp $
# $NetBSD: Makefile,v 1.15 1999/04/01 13:36:56 agc Exp $
# FreeBSD Id: Makefile,v 1.25 1998/02/15 05:36:54 peter Exp
#
@ -26,8 +26,8 @@ PATCH_DIST_ARGS= -d ${WRKSRC}/lib --forward --quiet -E ${PATCH_DIST_STRIP}
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.beedub.com/exmh/
DEPENDS+= tcl-8.0p2:../../lang/tcl80
DEPENDS+= tk-8.0p2:../../x11/tk80
DEPENDS+= tcl-8.0.5:../../lang/tcl80
DEPENDS+= tk-8.0.5:../../x11/tk80
DEPENDS+= nmh-0.27:../../mail/nmh
DEPENDS+= mm-2.7:../../mail/metamail

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 1999/01/30 23:18:52 agc Exp $
# $NetBSD: Makefile,v 1.3 1999/04/01 13:36:56 agc Exp $
# FreeBSD Id: Makefile,v 1.3 1998/09/25 10:07:44 asami Exp
#
@ -10,8 +10,8 @@ MASTER_SITES= http://www-cad.eecs.berkeley.edu/HomePages/aml/abacus/ \
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www-cad.eecs.berkeley.edu/HomePages/aml/abacus/abacus.html
DEPENDS+= tcl-8.0p2:../../lang/tcl80
DEPENDS+= tk-8.0p2:../../x11/tk80
DEPENDS+= tcl-8.0.5:../../lang/tcl80
DEPENDS+= tk-8.0.5:../../x11/tk80
USE_GMAKE= yes
USE_X11BASE= yes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 1998/12/18 00:42:40 tsarna Exp $
# $NetBSD: Makefile,v 1.9 1999/04/01 13:36:57 agc Exp $
#
DISTNAME= pyth151
@ -11,14 +11,14 @@ MAINTAINER= dolecek@ics.muni.cz
HOMEPAGE= http://www.python.org/topics/tkinter/
DEPENDS+= python-1.5.1:../../lang/python
DEPENDS+= tk-8.0p2:../../x11/tk80
DEPENDS+= tcl-8.0p2:../../lang/tcl80
DEPENDS+= tk-8.0.5:../../x11/tk80
DEPENDS+= tcl-8.0.5:../../lang/tcl80
DIST_SUBDIR= python
WRKSRC= ${WRKDIR}/Python-1.5.1/Modules
ALL_TARGET= default
EXTRACT_AFTER_ARGS= Python-1.5.1/Modules/_tkinter.c \
EXTRACT_ELEMENTS= Python-1.5.1/Modules/_tkinter.c \
Python-1.5.1/Modules/tkappinit.c
PYTHON_CONFIGDIR= ${LOCALBASE}/lib/python1.5/config/

View file

@ -1,18 +1,18 @@
# $NetBSD: Makefile,v 1.24 1999/04/01 10:20:07 agc Exp $
# $NetBSD: Makefile,v 1.25 1999/04/01 13:36:57 agc Exp $
# FreeBSD Id: Makefile,v 1.4 1997/10/01 09:20:31 tg Exp
#
DISTNAME= tk8.0p2
PKGNAME= tk-8.0p2
DISTNAME= tk8.0.5
PKGNAME= tk-8.0.5
CATEGORIES= x11
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_0/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.scriptics.com/
DEPENDS+= tcl-8.0p2:../../lang/tcl80
DEPENDS+= tcl-8.0.5:../../lang/tcl80
WRKSRC= ${WRKDIR}/tk8.0/unix
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
GNU_CONFIGURE= yes
USE_X11= yes