Update to 20081106:
since 20071211: - fix a wrong encoded umlaut and enhance the check for that in the Makefile - words added and shifted around - additionaly put the dictionary under GPLv3 - allow Ispell F prefix flag to be combined with suffixes - eliminate absolutely useless G flag (prefix ge) - deactivate K suffix flag: unused - eliminate H suffix flag: was almost unused - remove Q and q redundancy: every Q flagged word needs a q now, too - fix build issue with de_CH hunspell dictionary (a missing ß/ss conversion) - better empty-line fault tolerance of dictionaries - revise the aspell Makefile target using the myspell format now for aspell - simplify W flag - use sha256 checksums and prevent checksumming temporary files since 20070829: - words added and shifted around - Hunspell affix fix
This commit is contained in:
parent
f7248bc503
commit
aad455f557
4 changed files with 74 additions and 35 deletions
|
@ -1,32 +1,38 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/09/11 18:37:27 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2008/11/11 14:17:34 wiz Exp $
|
||||
#
|
||||
|
||||
VERSION= 20070829
|
||||
# bogus by purpose
|
||||
DISTNAME= hunspell-de-${VERSION}
|
||||
DISTNAME= igerman98-20081106
|
||||
PKGNAME= ${DISTNAME:S/igerman98/hunspell-de/}
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.j3e.de/hunspell/
|
||||
DISTFILES= de_AT-${VERSION}.zip de_CH-${VERSION}.zip de_DE-${VERSION}.zip
|
||||
EXTRACT_SUFX= .zip
|
||||
MASTER_SITES= http://www.j3e.de/ispell/igerman98/dict/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.j3e.de/ispell/igerman98/
|
||||
COMMENT= German dictionaries for hunspell
|
||||
|
||||
DIST_SUBDIR= hunspell-dictionaries
|
||||
# don't want -L
|
||||
EXTRACT_OPTS_ZIP= -aqo
|
||||
BUILD_DEPENDS+= ispell-base>=3.1.20nb1:../../textproc/ispell-base
|
||||
DEPENDS+= hunspell>=1.1.5:../../textproc/hunspell
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
INSTALLATION_DIRS= share/hunspell share/doc/hunspell-de
|
||||
BUILD_TARGET= hunspell-all
|
||||
USE_TOOLS+= gmake perl sed
|
||||
REPLACE_PERL= bin/clear_affix.pl bin/dic2iso.pl bin/grepl bin/lcfirst.pl \
|
||||
bin/sq.pl bin/uniqflag.pl bin/unsq.pl bin/extractlines.pl \
|
||||
bin/hunspell-optimize-roothelper.pl bin/myspellfixprefix.pl
|
||||
|
||||
do-build:
|
||||
SUBST_CLASSES+= sed
|
||||
SUBST_FILES.sed= bin/clear_affix bin/dic2iso bin/iso2dic bin/iso2tex \
|
||||
bin/tex2iso bin/conv_dict_de_CH
|
||||
SUBST_SED.sed= -e "s,/bin/sed,${SED},"
|
||||
SUBST_STAGE.sed= pre-build
|
||||
SUBST_MESSAGE.sed= Fixing path to sed.
|
||||
|
||||
INSTALLATION_DIRS= share/hunspell
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/de* ${PREFIX}/share/hunspell
|
||||
${INSTALL_DATA} ${WRKSRC}/[CR]* ${PREFIX}/share/doc/hunspell-de
|
||||
${INSTALL_DATA} ${WRKSRC}/dict* ${PREFIX}/share/doc/hunspell-de
|
||||
${INSTALL_DATA} ${WRKSRC}/hunspell/de*aff ${PREFIX}/share/hunspell
|
||||
${INSTALL_DATA} ${WRKSRC}/hunspell/de*dic ${PREFIX}/share/hunspell
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,16 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/09/11 18:37:27 wiz Exp $
|
||||
share/doc/hunspell-de/COPYING
|
||||
share/doc/hunspell-de/COPYING_OASIS
|
||||
share/doc/hunspell-de/Copyright
|
||||
share/doc/hunspell-de/dictionary.lst.example
|
||||
share/doc/hunspell-de/README_de_AT.txt
|
||||
share/doc/hunspell-de/README_de_CH.txt
|
||||
share/doc/hunspell-de/README_de_DE.txt
|
||||
@comment $NetBSD: PLIST,v 1.2 2008/11/11 14:17:34 wiz Exp $
|
||||
share/hunspell/de_AT.aff
|
||||
share/hunspell/de_AT.dic
|
||||
share/hunspell/de_AT_small.aff
|
||||
share/hunspell/de_AT_small.dic
|
||||
share/hunspell/de_CH.aff
|
||||
share/hunspell/de_CH.dic
|
||||
share/hunspell/de_CH_small.aff
|
||||
share/hunspell/de_CH_small.dic
|
||||
share/hunspell/de_DE.aff
|
||||
share/hunspell/de_DE.dic
|
||||
share/hunspell/de_DE_small.aff
|
||||
share/hunspell/de_DE_small.dic
|
||||
@unexec ${RMDIR} %D/share/hunspell 2>/dev/null || ${TRUE}
|
||||
@dirrm share/doc/hunspell-de
|
||||
|
|
|
@ -1,11 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/09/11 18:37:27 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2008/11/11 14:17:34 wiz Exp $
|
||||
|
||||
SHA1 (hunspell-dictionaries/de_AT-20070829.zip) = 1753360c700e65ddbd90b2bd5e6804de4ad1fbd5
|
||||
RMD160 (hunspell-dictionaries/de_AT-20070829.zip) = 1820bc3c80dac52f1ced315e1e8dd8487f22eec7
|
||||
Size (hunspell-dictionaries/de_AT-20070829.zip) = 299833 bytes
|
||||
SHA1 (hunspell-dictionaries/de_CH-20070829.zip) = 79a0575e8e1dcb4226c6609cb74bd3c48c073c68
|
||||
RMD160 (hunspell-dictionaries/de_CH-20070829.zip) = c91f2a9c4dc0c1b3498cbbdc48ce7aaf5595a68a
|
||||
Size (hunspell-dictionaries/de_CH-20070829.zip) = 305794 bytes
|
||||
SHA1 (hunspell-dictionaries/de_DE-20070829.zip) = e81be462afae2a43bb7ff04b3b0b86370027e3d9
|
||||
RMD160 (hunspell-dictionaries/de_DE-20070829.zip) = a8e0557b1c487687238f0cd87545f7e8443968f5
|
||||
Size (hunspell-dictionaries/de_DE-20070829.zip) = 298720 bytes
|
||||
SHA1 (igerman98-20081106.tar.bz2) = 8416e1f07bd53be48bce677622ff14f823001b74
|
||||
RMD160 (igerman98-20081106.tar.bz2) = c6f1ea67302892078b717b4edd03fa74f85d37a0
|
||||
Size (igerman98-20081106.tar.bz2) = 470769 bytes
|
||||
SHA1 (patch-aa) = Size (igerman98-20081106.tar.bz2) = 470769 bytes
|
||||
|
|
40
textproc/hunspell-de/patches/patch-aa
Normal file
40
textproc/hunspell-de/patches/patch-aa
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-aa,v 1.1 2008/11/11 14:17:34 wiz Exp $
|
||||
|
||||
--- Makefile.orig 2008-11-06 20:04:26.000000000 +0100
|
||||
+++ Makefile
|
||||
@@ -192,7 +192,7 @@ myspell/$(1).dic: $$(WORDS_$(1)) $$(WORD
|
||||
cat $$(WORDS_$(1)) $$(WORDS_de_all) dicts/abkuerzpunkt.txt \
|
||||
| (test -e ./bin/conv_dict_$(1) && ./bin/conv_dict_$(1) || cat) \
|
||||
| ./bin/myspell-generic-process.sh > $$@.tmp
|
||||
- wc -l < $$@.tmp > $$@
|
||||
+ wc -l < $$@.tmp | sed "s/^ *//" > $$@
|
||||
cat myspell/de_all.dic.header | $(SED) "s/AFF_VERSION_REPLACE/$(VERSION_STRING)/;s/LANG_REPLACE/$(1)/" >> $$@
|
||||
./bin/dic2iso < $$@.tmp >> $$@
|
||||
$(RM_OR_NOT) $$@.tmp
|
||||
@@ -297,7 +297,7 @@ hunspell/$(1)_small.dic: $$(HUNSPELL_DIC
|
||||
| (test -e ./bin/conv_dict_$(1) && ./bin/conv_dict_$(1) || cat) \
|
||||
| ./bin/hunspell-generic-process.sh \
|
||||
> $$@.tmp
|
||||
- wc -l < $$@.tmp > $$@
|
||||
+ wc -l < $$@.tmp | sed "s/^ *//" > $$@
|
||||
cat myspell/de_all.dic.header | \
|
||||
$(SED) "s/AFF_VERSION_REPLACE/$(VERSION_STRING)/;s/LANG_REPLACE/$(1)/;s/Myspell/Hunspell/" >> $$@
|
||||
./bin/dic2iso < $$@.tmp >> $$@
|
||||
@@ -314,7 +314,7 @@ hunspell/$(1).dic: $$(HUNSPELL_DICTS_ALL
|
||||
| ./bin/hunspell-generic-process.sh \
|
||||
| ./bin/hunspell-optimize-roothelper.pl \
|
||||
> $$@.tmp
|
||||
- wc -l < $$@.tmp > $$@
|
||||
+ wc -l < $$@.tmp | sed "s/^ *//" > $$@
|
||||
cat myspell/de_all.dic.header | $(SED) "s/AFF_VERSION_REPLACE/$$(VERSION_STRING)/;s/LANG_REPLACE/$(1)/;s/Myspell/Hunspell/" >> $$@
|
||||
./bin/dic2iso < $$@.tmp >> $$@
|
||||
$(RM_OR_NOT) $$@.tmp
|
||||
@@ -365,7 +365,7 @@ huntest: hunspell/hunspell-test.txt
|
||||
# so this is the lesser evil. No perfect solution found so far...
|
||||
cat hunspell/hunspell-test.txt |$(HUNSPELL) -L -d hunspell/de_DE > $@.tmp 2>&1
|
||||
@if `grep -q "^0 " $@.tmp`;then echo "Huntest NICHT bestanden:"; cat $@.tmp; exit 1;fi
|
||||
- @if ! test "`wc -l < $@.tmp`" = "`tail -n 1 $@.tmp | cut -f1 -d:`";then echo "Huntest NICHT bestanden (Zu viele als korrekt erkannte Wörter):"; cat $@.tmp; exit 1;fi
|
||||
+ @if ! test "`wc -l < $@.tmp | sed 's/^ *//'`" = "`tail -n 1 $@.tmp | cut -f1 -d:`";then echo "Huntest NICHT bestanden (Zu viele als korrekt erkannte Wörter):"; cat $@.tmp; exit 1;fi
|
||||
|
||||
|
||||
###
|
Loading…
Reference in a new issue