Remove rumba -- replace by sharity-light package.

This commit is contained in:
wiz 2001-03-09 16:10:55 +00:00
parent 9ec4779822
commit aae7d07f00
12 changed files with 0 additions and 415 deletions

View file

@ -1,34 +0,0 @@
# $NetBSD: Makefile,v 1.11 2001/02/25 04:18:08 hubertf Exp $
# $FreeBSD Id: Makefile,v 1.2 1997/07/21 19:28:46 max Exp
#
DISTNAME= rumba.0.6.s
PKGNAME= rumba-0.6
CATEGORIES= net
MASTER_SITES= ftp://hal.kph.tuwien.ac.at/pub/NeXT/tools/rumba/ \
ftp://next-ftp.peak.org/pub/next/apps/utils/networks/
EXTRACT_SUFX= .gnutar.gz
MAINTAINER= tron@netbsd.org
COMMENT= Userland smbfs --- SMB to NFS protocol converter
MAKE_ENV= PWD=${WRKSRC}
.include "../../mk/bsd.prefs.mk"
post-extract:
@${MKDIR} ${WRKDIR}/unrumba
@${LN} -s ${FILESDIR}/unrumba.c ${WRKDIR}/unrumba
@${LN} -s ${FILESDIR}/Makefile.unrumba ${WRKDIR}/unrumba/Makefile
post-build:
cd ${WRKDIR}/unrumba && ${MAKE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rumba ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKDIR}/unrumba/unrumba ${PREFIX}/sbin
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/rumba
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rumba/README
${INSTALL_MAN} ${WRKSRC}/smbmount.8 ${PREFIX}/man/man8/rumba.8
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +0,0 @@
#
# $NetBSD: Makefile.unrumba,v 1.2 1998/08/07 11:10:52 agc Exp $
#
PROG=unrumba
NOMAN=sorry
.include <bsd.prog.mk>

View file

@ -1,3 +0,0 @@
$NetBSD: md5,v 1.3 1998/08/07 13:25:11 agc Exp $
MD5 (rumba.0.6.s.gnutar.gz) = 743ed7d48161ce962f353389447b55a5

View file

@ -1,7 +0,0 @@
$NetBSD: patch-sum,v 1.4 2000/12/28 01:35:42 wiz Exp $
MD5 (patch-aa) = 7a2b34a86d60e407460741debe33ee20
MD5 (patch-ab) = d9e8bbf3fc231b36ce6c2bf63c86e0ad
MD5 (patch-ac) = bea96514b66561818e9973aff7111161
MD5 (patch-ad) = 23ec229a10d236ee4de41e717c8e2f9e
MD5 (patch-ae) = e59497a657c886d4cdeeee54936dc3b3

View file

@ -1,74 +0,0 @@
/* $NetBSD: unrumba.c,v 1.3 1998/08/07 11:10:52 agc Exp $ */
#include <sys/param.h>
#include <sys/mount.h>
#include <err.h>
#include <sysexits.h>
#include <unistd.h>
#include <stdlib.h>
#include <signal.h>
static void usage(void);
int
main(int argc, char** argv)
{
struct statfs* mntbuf;
int mntcount, i;
int aflag=0;
int ch;
while ( (ch = getopt(argc, argv, "a")) != -1) {
switch (ch) {
case 'a':
aflag=1;
break;
case '?':
default:
usage();
}
}
argc -= optind;
argv += optind;
if (aflag && argc != 0)
usage();
if (!aflag && argc == 0)
usage();
for (; argc>0 || aflag; aflag?(void)(aflag=0):(void)(argc--, argv++)) {
char abspath[MAXPATHLEN];
pid_t pid=0;
if (argc > 0) {
if (realpath(argv[0], abspath) == 0) {
warn(abspath);
continue;
}
}
mntcount=getmntinfo(&mntbuf, MNT_NOWAIT);
if (mntcount < 0)
err(EX_OSERR, "getmntinfo");
for (i=0; i<mntcount; i++) {
char* s;
int error;
if (argc > 0 && strcmp(abspath, mntbuf[i].f_mntonname) != 0) continue;
if (strcmp(mntbuf[i].f_fstypename,MOUNT_NFS) !=0 ) continue;
if (strncmp(mntbuf[i].f_mntfromname, "rumba-", 6) != 0) continue;
pid=strtoul(mntbuf[i].f_mntfromname+6, &s, 10);
if (*s) continue;
error = unmount (mntbuf[i].f_mntonname, 0);
if (error == 0) {
kill (pid, SIGHUP);
} else {
warn(mntbuf[i].f_mntonname);
}
}
if (argc > 0 && !pid)
warnx("%s: not currently mounted", abspath);
}
}
void
usage(void)
{
errx(EX_USAGE, "Usage: unrumba [-a] [node]");
}

View file

@ -1,55 +0,0 @@
$NetBSD: patch-aa,v 1.5 2000/12/28 01:35:42 wiz Exp $
--- Makefile.orig Mon Mar 23 00:09:38 1998
+++ Makefile
@@ -13,12 +13,12 @@
##############################################################################
# For NEXTSTEP/OPENSTEP:
-CFLAGS = -Wall -O2 -traditional-cpp -g
-INCLUDES = $(MYINCL) $(INCL)
+#CFLAGS = -Wall -O2 -traditional-cpp -g
+#INCLUDES = $(MYINCL) $(INCL)
# put your architecture here:
-ARCH = -arch i386
-THE_CC = cc
-RPC_WARNFLAGS = -Wno-unused -Wno-switch -Wno-uninitialized
+#ARCH = -arch i386
+#THE_CC = cc
+#RPC_WARNFLAGS = -Wno-unused -Wno-switch -Wno-uninitialized
# For Linux:
#CFLAGS = -Wall -O2 -g
@@ -32,10 +32,10 @@
#RPC_WARNFLAGS = -Wno-unused -Wno-switch -Wno-uninitialized
# For NetBsd
-#CFLAGS = -Wall -O2 -DNETBSD
-#INCLUDES = $(MYINCL) $(INCL)
-#THE_CC = cc
-#RPC_WARNFLAGS = -Wno-unused -Wno-switch -Wno-uninitialized
+CFLAGS = -Wall -O2 -DNETBSD
+INCLUDES = $(MYINCL) $(INCL)
+THE_CC = cc
+RPC_WARNFLAGS = -Wno-unused -Wno-switch -Wno-uninitialized
# For HP-UX:
# this "CFLAGS" line is for HP's cc, obviously. For gcc try "-Wall -O2"
@@ -67,7 +67,7 @@
OFILES = proc.o sock.o rumba.o psinode.o kernel.o smb_abstraction.o fo_nfs.o
.c.o:
- $(CC) $(CFLAGS) $(ARCH) -c -o $*.o $<
+ $(CC) $(CFLAGS) -c -o $*.o $<
all: $(NAME)
@@ -75,7 +75,7 @@
(cd nfs; $(MAKE) "CFLAGS=$(CFLAGS)" "CC=$(THE_CC)" "ARCH=$(ARCH)" "RPC_WARNFLAGS=$(RPC_WARNFLAGS)")
$(NAME): $(OFILES) nfs_dir
- $(CC) $(ARCH) -o $(NAME) $(OFILES) nfs/nfs.o $(LIBS)
+ $(CC) -o $(NAME) $(OFILES) nfs/nfs.o $(LIBS)
clean:
rm -f $(OFILES)

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.4 1998/08/07 11:10:53 agc Exp $
--- nfs/syscalls.c.orig Mon Mar 23 00:00:17 1998
+++ nfs/syscalls.c Wed May 6 18:39:39 1998
@@ -17,6 +17,9 @@
#endif
#include <netdb.h>
#include <arpa/inet.h>
+#ifndef NFSMNT_SOFT
+#include <nfs/nfsmount.h>
+#endif
#include "my_defines.h"
/* --------------------------- general constants --------------------------- */

View file

@ -1,160 +0,0 @@
$NetBSD: patch-ac,v 1.3 1998/08/25 15:52:02 tv Exp $
--- smbmount.8.orig Tue Aug 25 11:32:47 1998
+++ smbmount.8 Tue Aug 25 11:37:08 1998
@@ -1,8 +1,8 @@
-.TH SMBMOUNT 8 11/23/1996 smbmount smbmount
+.TH RUMBA 8 11/23/1996 rumba rumba
.SH NAME
-smbmount \- mount program for smbfs
+rumba \- mount a SMB filesystem through NFS protocol
.SH SYNOPSIS
-.B smbmount
+.B rumba
.B servicename mount-point
[
.B -h
@@ -54,8 +54,8 @@
.SH DESCRIPTION
This program is an interface to the SMB filesystem.
-.B smbfs
-is a filesystem which understands the SMB protocol. This is the
+.B rumba
+is a filesystem emulator which understands the SMB protocol. This is the
protocol Windows for Workgroups, Windows NT or Lan Manager use to talk
to each other. It was inspired by
.B samba,
@@ -94,10 +94,10 @@
get rid of difficulties with the shell using \\ as an escape
character.
-To make smbmount compatible with the automounter, only one leading '/'
+To make rumba compatible with the automounter, only one leading '/'
is required, although any number of '/'s is accepted.
-Currently smbmount uses gethostbyname() to find the IP number of the
+Currently rumba uses gethostbyname() to find the IP number of the
desired host. It is thus not really compatible with Lan Manager
conventions, where the netbios name of the server is not necessarily
the same as the hostname. In environments which enforce a netbios name
@@ -115,11 +115,11 @@
as in the normal mount command.
If the real uid of the caller is not root,
-.B smbmount
+.B rumba
checks whether the user is allowed to mount a filesystem on the
-mount-point. So it should be safe to make smbmount setuid root. In the
+mount-point. So it should be safe to make rumba setuid root. In the
filesystem, the real uid of the caller is stored, so that
-.B smbumount
+.B unrumba
can check whether the caller is allowed to unmount the filesystem.
.RE
@@ -153,8 +153,8 @@
.B -n
nor
.B -P
-are given, smbmount prompts for a password. This makes it difficult to
-use in scripts such as /etc/rc. But that's not smbmount's fault, but a
+are given, rumba prompts for a password. This makes it difficult to
+use in scripts such as /etc/rc. But that's not rumba's fault, but a
general problem with the Lan Manager security model. If anybody has a
satisfying solution to this problem, please tell me.
.RE
@@ -168,7 +168,7 @@
This option should only be used if the server refuses your login
attempt without telling him about his netbios name.
-This option does not alter the way smbmount finds the server's IP
+This option does not alter the way rumba finds the server's IP
address. It always uses gethostbyname().
The default value for this option is the server name given in the
@@ -224,7 +224,7 @@
.B -u
and
.B -g
-you can tell smbmount which id's it should assign to the files in the
+you can tell rumba which id's it should assign to the files in the
mounted direcory.
The defaults for these values are the current uid and gid.
@@ -241,7 +241,7 @@
.B -g,
these options are also used to bridge differences in concepts between
Lan Manager and unix. Lan Manager does not know anything about file
-permissions. So smbmount has to be told which permissions it should
+permissions. So rumba has to be told which permissions it should
assign to the mounted files and direcories. The values have to be
given as octal numbers. The default values are taken from the current
umask, where the file mode is the current umask, and the dir mode adds
@@ -256,7 +256,7 @@
.B -p
.I port
.RS 3
-The port is the TCP port smbmount tries to connect on the server. The
+The port is the TCP port rumba tries to connect on the server. The
default for this value is 139, as specified in RFC 1001/1002 (NetBIOS
over TCP/IP). Normally it should not be altered, as all commercial
servers offer their services on this port.
@@ -270,7 +270,7 @@
.RS 3
With
.B -m
-you can tell smbmount that it should offer some special maximum packet
+you can tell rumba that it should offer some special maximum packet
size that it can transfer in one SMB packet. Normally this option
should not be used.
.RE
@@ -290,12 +290,8 @@
being used, so you need to supply a valid name that would be known to
the server.
-Starting with smbfs-0.8 it is possible that your smbmount program is
-newer than the kernel you are currently using. You can fix this by
-recompiling smbmount with the correct kernel sources installed.
-
.SH NOTES
-.B smbfs
+.B rumba
supports long file names where the server supports the LANMAN2
protocol.
@@ -310,12 +306,12 @@
.SH DIAGNOSTICS
-Most diagnostics issued by smbfs are logged by syslogd. Normally
+Most diagnostics issued by rumba are logged by syslogd. Normally
nothing is printed, only error situations are logged there.
-If you have problems with smbfs, a good diagnostic tool is the program
+If you have problems with rumba, a good diagnostic tool is the program
smbclient from the samba package. If your problem does not occur with
-smbclient, then it's definitely a problem with smbfs. If smbclient
+smbclient, then it's definitely a problem with rumba. If smbclient
also shows the problem, it can print lots of debugging information to
help you to find the problem.
@@ -323,17 +319,11 @@
make does not find the Makefile in a smb-mounted direcory. Why??? If
you type make -f Makefile, everything works fine.
-There might be lots of race conditions in the kernel code. Anybody
-more experienced in kernel hacking might take a look at it and tell me
-about problems. I will do my best. For example I do not know which
-routines smbfs calls in the kernel might call schedule(). Can kmalloc
-call the scheduler? Does kfree?
-
You might see the use of gethostbyname() to find the server in a way
not conforming to Lan Manager as a bug.
.SH SEE ALSO
-.B syslogd(8), smbumount(8)
+.B syslogd(8)
.SH CREDITS
The original smbfs kernel code was a mixture of user-level smbfs and

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ad,v 1.3 2000/08/25 21:00:14 tron Exp $
--- proc.c.orig Wed Dec 31 00:28:48 1997
+++ proc.c Wed May 17 12:51:36 2000
@@ -878,12 +878,13 @@
char *p;
char *buf = server->packet;
int result;
+ const word o_attr = aSYSTEM | aHIDDEN;
smb_lock_server(server);
retry:
p = smb_setup_header(server, SMBunlink, 1, 2 + len);
- WSET(buf, smb_vwv0, 0);
+ WSET(buf, smb_vwv0, o_attr);
smb_encode_ascii(p, path, len);
if ((result = smb_request_ok(server, SMBunlink, 0, 0)) < 0) {

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ae,v 1.3 2000/12/28 01:35:43 wiz Exp $
--- nfs/Makefile.orig Wed Dec 31 01:29:08 1997
+++ nfs/Makefile
@@ -16,13 +16,13 @@
all: nfs.o
-COMPILE = $(CC) $(ARCH) -c $(INCLUDES) $(CFLAGS)
+COMPILE = $(CC) -c $(INCLUDES) $(CFLAGS)
.c.o:
$(COMPILE) $<
nfs.o: $(OFILES)
- $(LD) $(ARCH) -r -o $@ $(OFILES)
+ $(LD) -r -o $@ $(OFILES)
# the purpose of the sed "s/char data/long long data/" hack is to ensure
# proper alignment. [Marc Boucher <marc@CAM.ORG>]

View file

@ -1,16 +0,0 @@
It is part of author's Announcment:
This is the first public release of rumba. If you want a short
description of what rumba can do for you: you can mount volumes exported
by Windows or related operating systems on your Unix machine. For a more
detailed description I will quote from the README file:
What does rumba do?
===================
If you know smbfs for Linux: rumba is roughly the same. It is derived
from smbfs, but runs as a user level program, not in the kernel. If you
know samba: rumba is roughly the opposite: a client for the Lanmanager
protocol. If you know neither of these: rumba lets you mount drives
exported by Windows (f.Workgroups/95/NT), Lan Manager, OS/2 etc. on
Unix machines.

View file

@ -1,6 +0,0 @@
@comment $NetBSD: PLIST,v 1.4 1999/05/17 22:29:39 tron Exp $
sbin/rumba
sbin/unrumba
man/man8/rumba.8
share/doc/rumba/README
@dirrm share/doc/rumba