py-celery: updated to 5.3.6

5.3.6

This release is focused mainly to fix AWS SQS new feature comatibility issue and old regressions.
The code changes are mostly fix for regressions. More details can be found below.

What's Changed

- Increased docker-build CI job timeout from 30m -> 60m
- Incredibly minor spelling fix.
- Fix non-zero exit code when receiving remote shutdown
- Update task.py get_custom_headers missing 'compression' key
- Update kombu>=5.3.4 to fix SQS request compatibility with boto JSON serializer
- test requirements version update
- Update elasticsearch version
- Propagates more ImportErrors during autodiscovery


5.3.5

What's Changed

- Update test.txt versions
- fix os.getcwd() FileNotFoundError
- Fix typo in CONTRIBUTING.rst
- typo(doc): configuration.rst
- assert before raise
- Update GHA checkout version
- Fixed replaced_task_nesting
- Fix code indentation for route_task() example
- support redis 5.x
- Fix typos in test_canvas.py
- Marked flaky tests
- Fix typos in calling.rst
- Added support for replaced_task_nesting in chains
- Fix typos in canvas.rst
- Patch Version Release Checklist
- Added Python 3.11 support to Dockerfile
- Dependabot (Celery)
- Bump actions/checkout from 3 to 4
- Update ETA example to include timezone
- Replaces datetime.fromisoformat with the more lenient dateutil parser
- Fixed indentation in Dockerfile for Python 3.11
- Fix git bug in Dockerfile
- Tox lint upgrade from Python 3.9 to Python 3.11
- Document gevent concurrency
- Update test.txt
- Celery Docker Upgrades
- pyupgrade upgrade v3.11.0 -> v3.13.0
- Update msgpack.txt
- Update auth.txt
- Update msgpack.txt to fix build issues
- Basic ElasticSearch / ElasticClient 8.x Support
- Fix eager tasks does not populate name field
- Fix typo in celery.app.control
- Update solar.txt ephem
- Update test.txt pytest-timeout
- Correct some mypy errors
- Update elasticsearch.txt
- Update test.txt deps
- Update test.txt
- Improved the "Next steps" documentation.
- Disabled couchbase tests due to broken package breaking main
- Update elasticsearch deps
- Update cryptography==41.0.5
- Update pytest==7.4.3
- test initial support of python 3.12.x
- updated new versions to fix CI
- Update zstd.txt
- Fixed CI Support with Python 3.12
- updated CI, docs and classifier for next release
- updated dockerfile to add python 3.12
- lint,mypy,docker-unit-tests -> Python 3.12
- Correct type of `request` in `task_revoked` documentation
- update docs docker image
- Fixed RecursionError caused by giving `config_from_object` nested mod…
- Fix: serialization error when gossip working
* [documentation] broker_connection_max_retries of 0 does not mean "retry forever"
- added 2  debian package for better stability in Docker
This commit is contained in:
adam 2024-02-09 06:06:40 +00:00
parent da2450d324
commit aaf4aefc6a
4 changed files with 29 additions and 50 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.24 2022/07/11 08:50:27 adam Exp $
# $NetBSD: Makefile,v 1.25 2024/02/09 06:06:40 adam Exp $
DISTNAME= celery-5.2.7
DISTNAME= celery-5.3.6
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=c/celery/}
@ -10,22 +10,24 @@ HOMEPAGE= https://docs.celeryproject.org/
COMMENT= Asynchronous task/job queue based on distributed message passing
LICENSE= modified-bsd
DEPENDS+= ${PYPKGPREFIX}-billiard>=3.6.4.0:../../parallel/py-billiard
DEPENDS+= ${PYPKGPREFIX}-click>=8.0.3:../../devel/py-click
DEPENDS+= ${PYPKGPREFIX}-click-didyoumean>=0.0.3:../../devel/py-click-didyoumean
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-billiard>=4.2.0:../../parallel/py-billiard
DEPENDS+= ${PYPKGPREFIX}-click>=8.1.2:../../devel/py-click
DEPENDS+= ${PYPKGPREFIX}-click-didyoumean>=0.3.0:../../devel/py-click-didyoumean
DEPENDS+= ${PYPKGPREFIX}-click-plugins>=1.1.1:../../devel/py-click-plugins
DEPENDS+= ${PYPKGPREFIX}-click-repl>=0.2.0:../../devel/py-click-repl
DEPENDS+= ${PYPKGPREFIX}-kombu>=5.2.3:../../net/py-kombu
DEPENDS+= ${PYPKGPREFIX}-pytz>=2021.3:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-vine>=5.0.0:../../devel/py-vine
TEST_DEPENDS+= ${PYPKGPREFIX}-boto3>=1.9.178:../../net/py-boto3
TEST_DEPENDS+= ${PYPKGPREFIX}-moto>=2.2.6:../../net/py-moto
TEST_DEPENDS+= ${PYPKGPREFIX}-msgpack-[0-9]*:../../devel/py-msgpack
#TEST_DEPENDS+= ${PYPKGPREFIX}-pre-commit-[0-9]*:../../wip/py-pre-commit
TEST_DEPENDS+= ${PYPKGPREFIX}-test>=6.2:../../devel/py-test
DEPENDS+= ${PYPKGPREFIX}-dateutil>=2.8.2:../../time/py-dateutil
DEPENDS+= ${PYPKGPREFIX}-kombu>=5.3.4:../../net/py-kombu
DEPENDS+= ${PYPKGPREFIX}-tzdata>=2022.7:../../time/py-tzdata
DEPENDS+= ${PYPKGPREFIX}-vine>=5.1.0:../../devel/py-vine
TEST_DEPENDS+= ${PYPKGPREFIX}-boto3>=1.26.143:../../net/py-boto3
TEST_DEPENDS+= ${PYPKGPREFIX}-moto>=4.1.11:../../net/py-moto
TEST_DEPENDS+= ${PYPKGPREFIX}-test-celery-[0-9]*:../../devel/py-test-celery
TEST_DEPENDS+= ${PYPKGPREFIX}-test-subtests-[0-9]*:../../devel/py-test-subtests
TEST_DEPENDS+= ${PYPKGPREFIX}-test-timeout-[0-9]*:../../devel/py-test-timeout
#TEST_DEPENDS+= ${PYPKGPREFIX}-test-click-[0-9]*:../../
#TEST_DEPENDS+= ${PYPKGPREFIX}-test-order-[0-9]*:../../
TEST_DEPENDS+= ${PYPKGPREFIX}-test-subtests>=0.11.0:../../devel/py-test-subtests
TEST_DEPENDS+= ${PYPKGPREFIX}-test-timeout>=2.2.0:../../devel/py-test-timeout
# unlisted but needed
TEST_DEPENDS+= ${PYPKGPREFIX}-dns-[0-9]*:../../net/py-dns
TEST_DEPENDS+= ${PYPKGPREFIX}-mongo-[0-9]*:../../databases/py-mongo
@ -34,14 +36,9 @@ USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
USE_PKG_RESOURCES= yes
post-install:
cd ${DESTDIR}${PREFIX}/bin && \
${MV} celery celery-${PYVERSSUFFIX} || ${TRUE}
# test status as of 5.2.3 with py-pre-commit
# 1 failed, 2444 passed, 49 skipped, 3 xfailed, 30 warnings
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,12 +1,11 @@
@comment $NetBSD: PLIST,v 1.7 2021/05/07 18:02:57 adam Exp $
@comment $NetBSD: PLIST,v 1.8 2024/02/09 06:06:40 adam Exp $
bin/celery-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/entry_points.txt
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/celery/__init__.py
${PYSITELIB}/celery/__init__.pyc
${PYSITELIB}/celery/__init__.pyo

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.17 2022/07/11 08:50:27 adam Exp $
$NetBSD: distinfo,v 1.18 2024/02/09 06:06:40 adam Exp $
BLAKE2s (celery-5.2.7.tar.gz) = ccb3c16c97dc91373eaf1e32620d333f49ef0bd086e4fde5d6fbe25879987102
SHA512 (celery-5.2.7.tar.gz) = 68e3bb082f97ebe20391293cc8fa96c41c8f5ac5e8c24b2b7bd66eb104ec459bdfa49741e47486676e5daa88d7a71e3eb0d9432851aeafc74b0d4352e567e853
Size (celery-5.2.7.tar.gz) = 1474243 bytes
SHA1 (patch-requirements_test.txt) = 7ef7e9a6a72fc19b547d073f9d9bf327959412a7
BLAKE2s (celery-5.3.6.tar.gz) = 363d46cd79f90b3c3b2fb92f1475c9a967bfd91686d6d56a06529dbb599d963f
SHA512 (celery-5.3.6.tar.gz) = 169fa01c72f4d4932a255f4e7a547d1cc24f6899540414950c37e487163127bd3681b9ad741e9b1375c8a0b2b566b7467448e4523c77b34d29b3873007fb6885
Size (celery-5.3.6.tar.gz) = 1544498 bytes

View File

@ -1,16 +0,0 @@
$NetBSD: patch-requirements_test.txt,v 1.4 2022/02/15 16:24:57 wiz Exp $
Relax restrictions.
--- requirements/test.txt.orig 2021-11-21 13:37:38.000000000 +0000
+++ requirements/test.txt
@@ -1,7 +1,7 @@
-pytest~=6.2
+pytest
pytest-celery
pytest-subtests
-pytest-timeout~=1.4.2
+pytest-timeout
boto3>=1.9.178
moto>=2.2.6
pre-commit