First pass at a new festival package, based on later sources, which will

compile with gcc3. Committed now for others to improve.
This commit is contained in:
agc 2004-12-21 18:12:25 +00:00
parent e78827ec5c
commit ab0546a588
18 changed files with 77 additions and 406 deletions

View file

@ -1,25 +1,21 @@
# $NetBSD: Makefile,v 1.34 2004/08/18 21:44:08 minskim Exp $
# $NetBSD: Makefile,v 1.35 2004/12/21 18:12:25 agc Exp $
DISTNAME= festival-1.4.1
PKGREVISION= 1
DISTNAME= festival-1.95-beta
PKGNAME= festival-1.95beta
CATEGORIES= audio
MASTER_SITES= ftp://ftp.cstr.ed.ac.uk/pub/festival/1.4.1/ \
http://www.speech.cs.cmu.edu/festival/cstr/festival/1.4.1/ \
MASTER_SITES= http://www.cstr.ed.ac.uk/download/festival/1.95/ \
http://festvox.org/packed/festival/1.95/ \
ftp://cslu.cse.ogi.edu/pub/tts/
DISTFILES= ${DISTNAME}.tar.gz \
speech_tools-1.2.1.tar.gz \
OGIresLPC-2.0.9.tar.gz \
OGIfestpatch-1.4.1.2.tar.gz
# note that OGIfestpatch above file must be extracted last. it is, however
# this behavior not defined in pkgsrc at the time of writing
speech_tools-1.2.95-beta.tar.gz
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.cstr.ed.ac.uk/projects/festival/
COMMENT= Festival is an advanced multi-lingual speech synthesis system
COMMENT= Advanced multi-lingual speech synthesis system
WRKSRC= ${WRKDIR}
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
USE_GNU_TOOLS+= make
USE_X11= yes
SPEECHTOOLS= ${WRKSRC}/speech_tools
@ -27,6 +23,9 @@ FESTIVAL= ${WRKSRC}/festival
FHOME= ${PREFIX}/share/festival
CONFIG_GUESS_OVERRIDE= ${SPEECHTOOLS}/config.guess ${FESTIVAL}/config.guess
CONFIG_SUB_OVERRIDE= ${SPEECHTOOLS}/config.sub ${FESTIVAL}/config.sub
.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Msunpro)
@ -37,7 +36,7 @@ PKG_COMPILER!= case "${CC_VERSION}" in \
gcc-2.7.*) ${ECHO} gcc27;; \
gcc-2.8.*) ${ECHO} gcc28;; \
gcc-2.95.*) ${ECHO} gcc295;; \
gcc-3.3.*) ${ECHO} gcc295;; \
gcc-3.3.*) ${ECHO} gcc32;; \
egcs*) ${ECHO} egcs;; \
*) ${ECHO} ;; \
esac
@ -67,15 +66,15 @@ MAKE_ENV+= PKG_EST_HOME="${SPEECHTOOLS}" \
CC="${CC}" \
CXX="${CXX}"
pre-patch:
@ ${CP} ${SPEECHTOOLS}/config/config-dist ${SPEECHTOOLS}/config/config && \
${CHMOD} u+w ${SPEECHTOOLS}/config/config
@ ${CP} ${FESTIVAL}/config/config-dist ${FESTIVAL}/config/config && \
${CHMOD} u+w ${FESTIVAL}/config/config
post-patch:
@ ${CP} ${FILESDIR}/top-Makefile ${WRKSRC}/Makefile
@ ${CP} ${FILESDIR}/NetBSD.mak ${SPEECHTOOLS}/config/systems/NetBSD.mak
@${CP} ${FILESDIR}/top-Makefile ${WRKSRC}/Makefile
@${CP} ${FILESDIR}/ix86_NetBSD.mak ${SPEECHTOOLS}/config/systems/
@${CP} ${FILESDIR}/ix86_NetBSD2.0.mak ${SPEECHTOOLS}/config/systems/
@${CP} ${FILESDIR}/ix86_NetBSD.mak ${FESTIVAL}/config/systems/
@${CP} ${FILESDIR}/ix86_NetBSD2.0.mak ${FESTIVAL}/config/systems/
do-configure:
cd ${SPEECHTOOLS} && ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
do-install:
${INSTALL_DATA_DIR} ${FHOME}
@ -83,7 +82,7 @@ do-install:
${FIND} ${FESTIVAL}/lib -type d -print | ${XARGS} ${CHMOD} 755
cd ${FESTIVAL} && ${PAX} -rw lib examples ${FHOME}
${RM} -f ${FHOME}/lib/etc/NetBSD/audsp
${INSTALL_PROGRAM} ${FESTIVAL}/lib/etc/NetBSD/audsp ${PREFIX}/libexec
${INSTALL_PROGRAM} ${FESTIVAL}/lib/etc/ix86_NetBSD/audsp ${PREFIX}/libexec
${INSTALL_PROGRAM} ${FESTIVAL}/src/main/festival ${PREFIX}/libexec/festival.naked
${INSTALL_PROGRAM} ${FESTIVAL}/src/main/festival_client ${PREFIX}/libexec/festival_client.naked
for n in festival.sh festival_client.sh sitevars.scm; \

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2002/12/10 05:21:51 gson Exp $
@comment $NetBSD: PLIST,v 1.4 2004/12/21 18:12:25 agc Exp $
bin/festival
bin/festival_client
libexec/audsp
@ -6,126 +6,23 @@ libexec/festival.naked
libexec/festival_client.naked
man/man1/festival.1
man/man1/festival_client.1
share/festival/examples/Makefile
share/festival/examples/Makefile.orig
share/festival/examples/addr-mode.scm
share/festival/examples/benchmark
share/festival/examples/benchmark.orig
share/festival/examples/benchmark.text
share/festival/examples/dumpfeats
share/festival/examples/dumpfeats.sh
share/festival/examples/durmeanstd
share/festival/examples/durmeanstd.sh
share/festival/examples/ex1.email
share/festival/examples/ex1.ogi
share/festival/examples/example.sable
share/festival/examples/example.th
share/festival/examples/example2.sable
share/festival/examples/festival_client.c
share/festival/examples/festival_client.h
share/festival/examples/festival_client.pl
share/festival/examples/intro.text
share/festival/examples/latest
share/festival/examples/latest.sh
share/festival/examples/make_utts
share/festival/examples/make_utts.sh
share/festival/examples/powmeanstd
share/festival/examples/saytime
share/festival/examples/saytime.sh
share/festival/examples/scfg_parse_text
share/festival/examples/scfg_parse_text.sh
share/festival/examples/speech_pm_1.0.tar
share/festival/examples/spintro.text
share/festival/examples/text2pos
share/festival/examples/text2pos.sh
share/festival/examples/text2wave
share/festival/examples/text2wave.sh
share/festival/examples/th-mode.scm
share/festival/examples/tobi.stml
share/festival/examples/toksearch.scm
share/festival/examples/webdemo.scm
share/festival/lib/Makefile
share/festival/lib/Sable.v0_2.dtd
share/festival/lib/VCLocalRules
share/festival/lib/cart_aux.scm
share/festival/lib/cslush.scm
share/festival/lib/cstr.scm
share/festival/lib/darpa_phones.scm
share/festival/lib/display.scm
share/festival/lib/duration.scm
share/festival/lib/email-mode.scm
share/festival/lib/engmorph.scm
share/festival/lib/engmorphsyn.scm
share/festival/lib/etc/Makefile
share/festival/lib/etc/NetBSD/.made
share/festival/lib/etc/email_filter
share/festival/lib/f2bdurtreeZ.scm
share/festival/lib/f2bf0lr.scm
share/festival/lib/festdoc.scm
share/festival/lib/festival.el
share/festival/lib/festival.scm
share/festival/lib/festtest.scm
share/festival/lib/etc/ix86_${OPSYS}/.made
share/festival/lib/etc/ix86_${OPSYS}/audsp
share/festival/lib/fringe.scm
share/festival/lib/gswdurtreeZ.scm
share/festival/lib/holmes_phones.scm
share/festival/lib/init.scm
share/festival/lib/intonation.scm
share/festival/lib/java.scm
share/festival/lib/klatt_durs.scm
share/festival/lib/languages.scm
share/festival/lib/lexicons.scm
share/festival/lib/lts.scm
share/festival/lib/lts_build.scm
share/festival/lib/mbrola.scm
share/festival/lib/mettree.scm
share/festival/lib/module_description.scm
share/festival/lib/mrpa_allophones.scm
share/festival/lib/mrpa_durs.scm
share/festival/lib/mrpa_phones.scm
share/festival/lib/ogi_effect.scm
share/festival/lib/ogi_enhance.scm
share/festival/lib/ogi_gswdurtreeZ_wb.scm
share/festival/lib/ogi_hack.scm
share/festival/lib/ogi_kddurtreeZ_wb.scm
share/festival/lib/ogi_klatt_durs_wb.scm
share/festival/lib/ogi_languages.scm
share/festival/lib/ogi_lexicons.scm
share/festival/lib/ogi_lts_worldbet.scm
share/festival/lib/ogi_phrase.scm
share/festival/lib/ogi_postlex.scm
share/festival/lib/ogi_synthesis.scm
share/festival/lib/ogi_token.scm
share/festival/lib/ogi_unitsel.scm
share/festival/lib/ogi_wordsynth.scm
share/festival/lib/ogi_worldbet_phones.scm
share/festival/lib/ogimarkup-mode.scm
share/festival/lib/pauses.scm
share/festival/lib/phoneset.scm
share/festival/lib/phrase.scm
share/festival/lib/pos.scm
share/festival/lib/postlex.scm
share/festival/lib/radio_phones.scm
share/festival/lib/sable-latin.ent
share/festival/lib/sable-mode.scm
share/festival/lib/scfg.scm
share/festival/lib/scfg_wsj_wp20.gram
share/festival/lib/sec.B.hept.ngrambin
share/festival/lib/sec.ts20.quad.ngrambin
share/festival/lib/siod.scm
share/festival/lib/sitevars.scm
share/festival/lib/soleml-mode.scm
share/festival/lib/speech.properties
share/festival/lib/synthesis.scm
share/festival/lib/tilt.scm
share/festival/lib/tobi.scm
share/festival/lib/tobi_rules.scm
share/festival/lib/token.scm
share/festival/lib/tokenpos.scm
share/festival/lib/tts.scm
share/festival/lib/voices.scm
share/festival/lib/web.scm
@unexec ${RM} -r %D/share/festival/lib/voices
@unexec ${RM} -r %D/share/festival/lib/dicts
@dirrm share/festival/lib/etc/NetBSD
@dirrm share/festival/lib/etc/ix86_${OPSYS}
@dirrm share/festival/lib/etc
@dirrm share/festival/lib
@dirrm share/festival/examples

View file

@ -1,24 +1,6 @@
$NetBSD: distinfo,v 1.8 2004/10/15 16:50:17 kristerw Exp $
$NetBSD: distinfo,v 1.9 2004/12/21 18:12:25 agc Exp $
SHA1 (festival-1.4.1.tar.gz) = d3be7d58b986c37c39444a2dcc044cdc3ee1e774
Size (festival-1.4.1.tar.gz) = 543335 bytes
SHA1 (speech_tools-1.2.1.tar.gz) = 6facbaeaacb5022a20e59d669eaaeee8d9899e42
Size (speech_tools-1.2.1.tar.gz) = 1206616 bytes
SHA1 (OGIresLPC-2.0.9.tar.gz) = e54b7d3f7ed1696a6eeca0fe1695a099d2ed3712
Size (OGIresLPC-2.0.9.tar.gz) = 140306 bytes
SHA1 (OGIfestpatch-1.4.1.2.tar.gz) = 12b1b0198facf10fc781ac5d0a1521d45da30c9d
Size (OGIfestpatch-1.4.1.2.tar.gz) = 32904 bytes
SHA1 (patch-aa) = be60f30a65bd7d7d49a438c274a8c1b1f0fb64fc
SHA1 (patch-ab) = 5d49c932446fb625c9e6bd114af67c9d959bb2ba
SHA1 (patch-ac) = 64597fabe79d93f402bcf5bf100ac2e9d0613e0c
SHA1 (patch-ad) = 42d20ef5aca5752093224e50c177e55465a1155f
SHA1 (patch-ae) = d045128bacdedf05cd18b0dd750ea6a6a34a0ce4
SHA1 (patch-af) = 3bcd5f48bcc6f2ecc68e179d8a0c70cdd6cfa5fd
SHA1 (patch-ag) = 17f19d5b738f44f98bb2572f0a8231429adb6065
SHA1 (patch-ah) = 4bda46a40668209140e937206f6e6ae76e5a740f
SHA1 (patch-ai) = 690a0649e8231296dae291b7210b6e7c84bae961
SHA1 (patch-aj) = a50a9e762096faf7dc1272325a925e54d2c882a0
SHA1 (patch-ak) = 705016ef010989c1b9ffe2d23b78ee9615a4c6f7
SHA1 (patch-al) = d8a22c5f509a6d75aa3295037654b594e8db4a4a
SHA1 (patch-am) = cd6e07df1729fecca5cd9869229701b63ba71d14
SHA1 (patch-an) = bdd701017c72db315de8fcfb4ac6ce3bf97d4d47
SHA1 (festival-1.95-beta.tar.gz) = 7bbf841b07a09cfe1ab17db23c2ebc12ea3d854b
Size (festival-1.95-beta.tar.gz) = 707573 bytes
SHA1 (speech_tools-1.2.95-beta.tar.gz) = 5f0533a1b06c56f06e382d752b920ee62a5e8312
Size (speech_tools-1.2.95-beta.tar.gz) = 1281274 bytes

View file

@ -0,0 +1,29 @@
###########################################################################
## ##
## Author: Alistair Crooks (agc@netbsd.org) ##
## Date: Wed Oct 27 2004 ##
## -------------------------------------------------------------------- ##
## Settings for NetBSD. ##
## ##
###########################################################################
include $(EST)/config/systems/default.mak
## the native audio module for this type of system
NATIVE_AUDIO_MODULE = NETBSD
## echo -n doesn't work (well only sometimes ?)
ECHO_N = /usr/bin/printf "%s"
NAWK=awk
# GCC_MAKE_SHARED_LIB = ld -Bshareable -x -o XXX
DEFAULT_JAVA_HOME=${PREFIX}/java
JAVA=$(JAVA_HOME)/bin/java
JAVAC=$(JAVA_HOME)/bin/javac
JAVAH=$(JAVA_HOME)/bin/javah -jni
JAR=$(JAVA_HOME)/bin/jar cf0v

View file

@ -0,0 +1,17 @@
###########################################################################
## ##
## Author: Alistair Crooks (agc@netbsd.org) ##
## -------------------------------------------------------------------- ##
## Settings for NetBSD 2.0 ##
## ##
###########################################################################
# ELF
include $(EST)/config/systems/ix86_NetBSD.mak
JAVA_SYSTEM_INCLUDES = -I$(JAVA_HOME)/include
GCC=gcc32

View file

@ -1,20 +0,0 @@
$NetBSD: patch-aa,v 1.2 1999/10/11 14:13:49 proff Exp $
--- festival/config/config Mon Oct 11 07:48:44 1999
+++ festival/config/config Mon Oct 11 05:48:33 1999
@@ -20,7 +20,7 @@
## You may need to set this explicitly if automounter or NFS
## side effects cause problems
-FESTIVAL_HOME := $(shell (cd $(TOP); pwd))
+FESTIVAL_HOME := $(PKG_FESTIVAL_HOME)
###########################################################################
## Feature selection.
@@ -70,3 +70,6 @@
## in config/configs/default.mak.
+ALSO_INCLUDE += OGIcommon
+ALSO_INCLUDE += OGIdbase
+ALSO_INCLUDE += OGIresLPC

View file

@ -1,25 +0,0 @@
$NetBSD: patch-ab,v 1.2 1999/10/11 14:13:49 proff Exp $
--- festival/doc/Makefile Thu Jun 17 20:29:54 1999
+++ festival/doc/Makefile Mon Oct 11 06:06:35 1999
@@ -44,7 +44,7 @@
EXAMPLE_TO_DOCUMENT=
-FESTIVAL=$(TOP)/bin/festival --libdir $(TOP)/lib
+FESTIVAL=$(TOP)/src/main/festival --libdir $(TOP)/lib
# Include some of EST documentation.
DOCXX_EXTRA_FILES =
@@ -72,9 +72,9 @@
%.1 : %.head %.options %.tail
cat $^ >$@
%.options : $(TOP)/src/main/%
- $(TOP)/bin/$* -man_options >$@
+ $(FESTIVAL)$* -man_options >$@
%.options : $(TOP)/src/main/%.exe
- $(TOP)/bin/$* -man_options >$@
+ $(FESTIVAL)$* -man_options >$@
festival.info: festival.texi festfunc.texi festvars.texi festfeat.texi
@ if [ ! -d info ] ; \

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ac,v 1.2 1999/10/11 14:13:49 proff Exp $
--- festival/examples/benchmark Thu Feb 27 00:47:45 1997
+++ festival/examples/benchmark Mon Oct 11 05:41:14 1999
@@ -1,6 +1,6 @@
#!/bin/sh
-default_libdir="/projects/festival/lib"
+default_libdir="$FESTIVAL_HOME/lib"
while true
do
@@ -15,9 +15,9 @@
esac
done
-text=${1-"$HOME/projects/festival/examples/benchmark.text"}
+text=${1-"$FESTIVAL_HOME/examples/benchmark.text"}
-for i in . src/main ../src/main $HOME/projects/festival/src/main /cstr/bin
+for i in . src/main ../src/main $FESTIVAL_HOME/src/main
do
if [ -n "$festival" ]
then

View file

@ -1,54 +0,0 @@
$NetBSD: patch-ad,v 1.3 2001/07/18 15:19:36 wiz Exp $
--- speech_tools/config/config.orig Tue Jul 17 16:03:21 2001
+++ speech_tools/config/config
@@ -15,7 +15,7 @@
## You may need to set this explicitly if automounter or NFS
## side effects cause problems
-EST_HOME := $(shell (cd $(EST); pwd))
+EST_HOME := $(PKG_EST_HOME)
###########################################################################
## System type.
@@ -28,15 +28,19 @@
##
## Examples: sparc_SunOS5 intel_Linux2.0
-SYSTEM_TYPE=$(MACHINETYPE)_$(OSTYPE)$(OSREV)
+#SYSTEM_TYPE=$(MACHINETYPE)_$(OSTYPE)$(OSREV)
+# unforunately the above does not fit in well with NetBSD's multiple
+# architectures and frequent changes of revision level (for people running
+# NetBSD-current)
+SYSTEM_TYPE=NetBSD
###########################################################################
## Compiler.
## The definitions are in compilers/$(COMPILER).mak
## Examples: gcc suncc egcs gcc28
-COMPILER=gcc
-
+#COMPILER=gcc
+COMPILER=$(PKG_COMPILER)
###########################################################################
## Java system to use if you include the Java interface.
## Examples jdk
@@ -77,13 +81,15 @@
## specify a program to play files in a desired format.
## NCD's network audio system, This is recommended.
-# INCLUDE_MODULES += NAS_AUDIO
+INCLUDE_MODULES += NAS_AUDIO
## Elightenment Sound Demon, for KDE etc.
# INCLUDE_MODULES += ESD_AUDIO
## Native audio for your platform (sun, linux, freebsd, irix, windows)
-INCLUDE_MODULES += NATIVE_AUDIO
+# INCLUDE_MODULES += NATIVE_AUDIO
+# The NetBSD pkg doesn't support native audio at this time. NAS is
+# superior for most applications.
## Special code to run Windows MPLAYER
# INCLUDE_MODULES += MPLAYER_AUDIO

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ae,v 1.2 1999/10/11 14:13:49 proff Exp $
--- speech_tools/include/EST_unix.h Sun May 30 20:53:04 1999
+++ speech_tools/include/EST_unix.h Mon Oct 11 05:40:15 1999
@@ -53,6 +53,7 @@
# include <sys/wait.h>
# include <sys/resource.h>
# include <dirent.h>
+# define unix 1
#elif defined(SYSTEM_IS_WIN32)
# include <io.h>
# include "win32/EST_unix_win32.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-af,v 1.1 1999/10/11 14:13:49 proff Exp $
--- festival/config/project.mak-dist Mon Oct 11 21:41:08 1999
+++ festival/config/project.mak Mon Oct 11 22:27:37 1999
@@ -70,8 +70,8 @@
# Place where programs are compiled
-PROJECT_MAIN_DIR=$(FESTIVAL_HOME)/src/main
-PROJECT_SCRIPTS_DIR=$(FESTIVAL_HOME)/src/scripts
+PROJECT_MAIN_DIR=$(PKG_FESTIVAL_BUILD_HOME)/src/main
+PROJECT_SCRIPTS_DIR=$(PKG_FESTIVAL_BUILD_HOME)/src/scripts
# Where the main RCS tree is, probably only used within CSTR

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ag,v 1.2 2000/09/18 04:55:47 fredb Exp $
--- speech_tools/config/modules/nas_audio.mak.orig Fri May 5 20:55:15 2000
+++ speech_tools/config/modules/nas_audio.mak Fri May 5 20:58:07 2000
@@ -45,6 +45,6 @@
AUDIO_DEFINES += -DSUPPORT_NAS
AUDIO_INCLUDES += -I$(NAS_INCLUDE)
MODULE_LIBS += -L$(NAS_LIB) -laudio
-MODULE_EXTRA_LIBS += -L$(X11_LIB) -lX11 -lXt
+MODULE_EXTRA_LIBS += -L$(X11_LIB) -Wl,-R $(X11_LIB) -lX11 -lXt -lSM -lICE

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ah,v 1.2 2000/09/18 04:55:47 fredb Exp $
--- festival/config/modules/nas_audio.mak.orig Fri May 5 21:07:15 2000
+++ festival/config/modules/nas_audio.mak Fri May 5 21:07:29 2000
@@ -44,6 +44,6 @@
AUDIO_DEFINES += -DSUPPORT_NAS
AUDIO_INCLUDES += -I$(NAS_INCLUDE)
-MODULE_LIBS += -L$(NAS_LIB) -laudio -L$(X11_LIB) -lX11 -lXt
+MODULE_LIBS += -L$(NAS_LIB) -Wl,-R$(NAS_LIB) -laudio -L$(X11_LIB) -Wl,-R$(X11_LIB) -lX11 -lXt -lSM -lICE

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ai,v 1.2 2000/05/31 14:51:16 dmcmahill Exp $
work around pmax compiler bug
--- speech_tools/grammar/ngram/Makefile.orig Sun May 30 06:59:41 1999
+++ speech_tools/grammar/ngram/Makefile Tue May 30 12:41:32 2000
@@ -49,3 +49,10 @@
include $(TOP)/config/common_make_rules
+ifeq ($(MACHINETYPE),pmax)
+
+ngrammar_io.o: ngrammar_io.cc
+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../../include ${OS_INCLUDES} ngrammar_io.cc
+
+endif
+

View file

@ -1,16 +0,0 @@
$NetBSD: patch-aj,v 1.1 2000/05/31 14:51:16 dmcmahill Exp $
work around pmax compiler bug
--- festival/src/modules/OGIcommon/Makefile.orig Thu Aug 26 11:56:36 1999
+++ festival/src/modules/OGIcommon/Makefile Tue May 30 21:08:30 2000
@@ -54,2 +54,9 @@
include $(TOP)/config/common_make_rules
+ifeq ($(MACHINETYPE),pmax)
+
+OGI_Track.o: OGI_Track.cc
+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../../../src/include -I../../../../speech_tools/include ${OS_INCLUDES} OGI_Track.cc
+
+endif
+

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ak,v 1.1 2000/05/31 14:51:17 dmcmahill Exp $
work around pmax compiler bug
--- festival/src/modules/OGIresLPC/Makefile.orig Thu Aug 5 13:01:02 1999
+++ festival/src/modules/OGIresLPC/Makefile Wed May 31 01:20:01 2000
@@ -53,2 +53,10 @@
include $(TOP)/config/common_make_rules
+ifeq ($(MACHINETYPE),pmax)
+
+resLPC_mod.o: resLPC_mod.cc
+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../../../src/include -I../OGIdbase -I ../OGIcommon -I../../../../speech_tools/include ${OS_INCLUDES} resLPC_mod.cc
+
+endif
+
+

View file

@ -1,16 +0,0 @@
$NetBSD: patch-al,v 1.1 2000/05/31 14:51:17 dmcmahill Exp $
work around pmax compiler bug
--- festival/src/modules/Duration/Makefile.orig Sun May 30 08:07:31 1999
+++ festival/src/modules/Duration/Makefile Wed May 31 09:22:01 2000
@@ -51,3 +51,9 @@
include $(TOP)/config/common_make_rules
+ifeq ($(MACHINETYPE),pmax)
+
+duration.o:duration.cc
+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../include -I../../../src/include -I../../../../speech_tools/include ${OS_INCLUDES} duration.cc
+
+endif

View file

@ -1,13 +0,0 @@
$NetBSD: patch-am,v 1.1 2001/11/17 16:29:08 martin Exp $
--- speech_tools/include/unix/EST_socket_unix.h.orig Sat Nov 17 16:55:44 2001
+++ speech_tools/include/unix/EST_socket_unix.h Sat Nov 17 16:56:18 2001
@@ -49,7 +49,7 @@
typedef int ssize_t;
#endif
-#if defined(__linux__)
+#if defined(__linux__) || defined(__NetBSD__)
/* gcc-2.95.1 is fussy and requies certain arguments to follow their type */
/* Linux wants socklen_t params but other (even if they have this defined */
/* want int or maybe unsigned int (pretty random actually) */