Fix build problem with GCC 3.3.1.

This commit is contained in:
tron 2003-09-24 13:52:31 +00:00
parent 40a0f8ca48
commit ab994a9714
2 changed files with 25 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.6 2003/01/07 06:19:06 rh Exp $
$NetBSD: distinfo,v 1.7 2003/09/24 13:52:31 tron Exp $
SHA1 (transfig.3.2.4.tar.gz) = edfec1865dbfe9e7a06ae8be016f1a489b3d307d
Size (transfig.3.2.4.tar.gz) = 326284 bytes
SHA1 (patch-aa) = efc4eb298f4c5871432569c041226127ee0527c1
SHA1 (patch-ab) = f1193557969ca7f6cc9d507710348d38dbfb7bf6
SHA1 (patch-ac) = ac0823470d4de6df7bd5e3ff0f87decf8b4c44b8
SHA1 (patch-ad) = b3a0d55eca4defbec4276f9aa4ce8f1352c3f1fb

View file

@ -0,0 +1,23 @@
--- fig2dev/dev/gensvg.c.orig 2002-12-18 23:38:18.000000000 +0100
+++ fig2dev/dev/gensvg.c 2003-09-24 15:50:52.000000000 +0200
@@ -692,16 +692,16 @@
if (t->angle != 0) {
fprintf (tfp, "<g transform=\"translate(%d,%d) rotate(%d)\" >\n",
(int) (t->base_x * mag), (int) (t->base_y * mag), degrees (t->angle));
- fprintf (tfp, "<text x=\"0\" y=\"0\" fill=\"#%6.6x\" font-family=\"%s\"
- font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
+ fprintf (tfp, "<text x=\"0\" y=\"0\" fill=\"#%6.6x\" font-family=\"%s\" "
+ "font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
rgbColorVal (t->color), family[(int) ceil ((t->font + 1) / 4)],
(t->font % 2 == 0 ? "normal" : "italic"),
(t->font % 4 < 2 ? "normal" : "bold"), (int) (ceil (t->size * 12 * mag)),
anchor[t->type]);
}
else
- fprintf (tfp, "<text x=\"%d\" y=\"%d\" fill=\"#%6.6x\" font-family=\"%s\"
- font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
+ fprintf (tfp, "<text x=\"%d\" y=\"%d\" fill=\"#%6.6x\" font-family=\"%s\" "
+ "font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
(int) (t->base_x * mag), (int) (t->base_y * mag), rgbColorVal (t->color),
family[(int) ceil ((t->font + 1) / 4)],
(t->font % 2 == 0 ? "normal" : "italic"),