This is a fork of UAE, the Ubiquitous Amiga Emulator, with an emulation core

based on WinUAE. It attempts to bring many of the great features of WinUAE
to non-Windows platforms. This version now finally has a name, E-UAE, since
that's what everybody was calling it anyway. The 'E' can stand for anything
you fancy. Experimental, extreme, exciting, egalitarian, eggplant...
This commit is contained in:
adam 2006-01-24 20:21:46 +00:00
parent ec6e11887d
commit ab9bd1255f
6 changed files with 108 additions and 0 deletions

22
emulators/e-uae/DESCR Normal file
View file

@ -0,0 +1,22 @@
This is a fork of UAE, the Ubiquitous Amiga Emulator, with an emulation core
based on WinUAE. It attempts to bring many of the great features of WinUAE
to non-Windows platforms. This version now finally has a name, E-UAE, since
that's what everybody was calling it anyway. The 'E' can stand for anything
you fancy. Experimental, extreme, exciting, egalitarian, eggplant...
E-UAE is open-source software and is made available under the terms of the
GPL. See the COPYING file included with the E-UAE archive for details.
E-UAE is based on the work of dozens of contributors including Bernd Schmidt
(the original author and maintainer of UAE), Bernie Meyer (the author of the
x86 JIT compiler), Toni Wilen (the current maintainer of WinUAE), and many
more.
To make full use of E-UAE you will need access to an image of some version
of the Amiga Kickstart ROM (although UAE does include a ROM emulation which
may work with some old games). The Amiga Kickstart ROMs are copyrighted
material and may not be freely distributed (so don't ask me for a copy). If
you don't have an Amiga from which you can legally make a ROM image, a
selection of ROM images are available for purchase online from Cloanto
(publishers of the Amiga Forever distribution). See
http://www.amigaforever.com/

26
emulators/e-uae/Makefile Normal file
View file

@ -0,0 +1,26 @@
# $NetBSD: Makefile,v 1.1.1.1 2006/01/24 20:21:46 adam Exp $
DISTNAME= e-uae-0.8.28
CATEGORIES= emulators
MASTER_SITES= http://www.rcdrummond.net/uae/e-uae-0.8.28/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= adam@NetBSD.org
HOMEPAGE= http://www.rcdrummond.net/uae/
COMMENT= Enhanced Ubiquitous Amiga Emulator
CONFLICTS+= uae-*
USE_LIBTOOL= yes
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
.include "options.mk"
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/uae
cd ${WRKSRC}/docs && ${INSTALL_DATA} *.txt ${PREFIX}/share/doc/uae
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/ossaudio.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

12
emulators/e-uae/PLIST Normal file
View file

@ -0,0 +1,12 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/01/24 20:21:46 adam Exp $
bin/readdisk
bin/uae
share/doc/uae/bsdsocket.txt
share/doc/uae/cmd-line.txt
share/doc/uae/compiling.txt
share/doc/uae/configuration.txt
share/doc/uae/floppies.txt
share/doc/uae/joystick.txt
share/doc/uae/keyboard.txt
share/doc/uae/scsi.txt
@dirrm share/doc/uae

6
emulators/e-uae/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2006/01/24 20:21:46 adam Exp $
SHA1 (e-uae-0.8.28.tar.bz2) = 11e647ed64420f85893ac77c072e268b650ae183
RMD160 (e-uae-0.8.28.tar.bz2) = 7e9fa21fa14b0ca3a32a28ccb236b9d7628a7f69
Size (e-uae-0.8.28.tar.bz2) = 1148790 bytes
SHA1 (patch-ab) = dfce48dafb163b91c7252da14088e67b3e13bb6c

View file

@ -0,0 +1,21 @@
# $NetBSD: options.mk,v 1.1.1.1 2006/01/24 20:21:46 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.e-uae
PKG_SUPPORTED_OPTIONS= gtk sdl x11
PKG_SUGGESTED_OPTIONS= gtk sdl
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mgtk)
.include "../../x11/gtk2/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Msdl)
CONFIGURE_ARGS+= --with-sdl --with-sdl-gfx
.include "../../devel/SDL/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mx11)
CONFIGURE_ARGS+= --enable-dga --enable-vidmode
.include "../../mk/x11.buildlink3.mk"
.endif

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ab,v 1.1.1.1 2006/01/24 20:21:46 adam Exp $
--- src/disk.c.orig 2005-07-08 07:44:16.000000000 +0200
+++ src/disk.c
@@ -2569,6 +2569,8 @@ void DSKLEN (uae_u16 v, unsigned int hpo
for (dr = 0; dr < MAX_FLOPPY_DRIVES; dr++)
update_drive_gui (dr);
+ /* The following fails with some versions of Kickstart. Disable it. */
+#if 0
/* Try to make floppy access from Kickstart faster. */
if (dskdmaen != 2 && dskdmaen != 3)
return;
@@ -2639,6 +2641,7 @@ void DSKLEN (uae_u16 v, unsigned int hpo
return;
}
}
+#endif
}
void DSKSYNC (unsigned int hpos, uae_u16 v)