Honor PKGINFODIR and list info files directly in the PLIST. Also set

sysconfdir to the example directory in INSTALL_MAKE_FLAGS instead of
patching out installation to $(sysconfdir) in various Makefiles.

Bump the PKGREVISION.
This commit is contained in:
jlam 2006-04-05 22:54:59 +00:00
parent 8151e56f81
commit ab9e528a14
5 changed files with 10 additions and 54 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.28 2006/02/05 23:10:13 joerg Exp $
# $NetBSD: Makefile,v 1.29 2006/04/05 22:54:59 jlam Exp $
#
DISTNAME= pinfo-0.6.1
PKGREVISION= 4
PKGREVISION= 5
CATEGORIES= misc
MASTER_SITES= http://zeus.polsl.gliwice.pl/~pborys/stable-version/
@ -14,18 +14,14 @@ BUILD_USES_MSGFMT= yes
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
INFO_FILES= pinfo.info
CPPFLAGS+= -DDFLT_INFOPATH="\"/usr/share/info:${X11BASE}/info:${LOCALBASE}/info:/usr/local/info\""
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
CONF_FILES= ${PREFIX}/share/examples/pinfo/pinforc ${PKG_SYSCONFDIR}/pinforc
CPPFLAGS+= -DDFLT_INFOPATH="\"/usr/share/info:${PREFIX}/${PKGINFODIR}:${X11BASE}/${PKGINFODIR}:${LOCALBASE}/${PKGINFODIR}:/usr/local/info\""
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/pinfo
${INSTALL_DATA} ${WRKSRC}/src/pinforc ${PREFIX}/share/examples/pinfo
EGDIR= ${PREFIX}/share/examples/pinfo
CONF_FILES= ${EGDIR}/pinforc ${PKG_SYSCONFDIR}/pinforc
INFO_FILES= # PLIST
INSTALL_MAKE_FLAGS= ${MAKE_FLAGS} sysconfdir=${EGDIR:Q}
PKG_OPTIONS_VAR= PKG_OPTIONS.pinfo
PKG_SUPPORTED_OPTIONS= pinfo-native-curses

View file

@ -1,5 +1,6 @@
@comment $NetBSD: PLIST,v 1.6 2004/03/08 22:22:31 seb Exp $
@comment $NetBSD: PLIST,v 1.7 2006/04/05 22:54:59 jlam Exp $
bin/pinfo
info/pinfo.info
man/man1/pinfo.1
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/pinfo.mo
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/pinfo.mo

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2005/02/24 11:02:57 agc Exp $
$NetBSD: distinfo,v 1.6 2006/04/05 22:54:59 jlam Exp $
SHA1 (pinfo-0.6.1.tar.gz) = f0444f4eb3bad4f10ad96c971d7bcd553b567ef4
RMD160 (pinfo-0.6.1.tar.gz) = 85313caf3323f00720bd319dffd2593025745779
@ -6,5 +6,3 @@ Size (pinfo-0.6.1.tar.gz) = 271015 bytes
SHA1 (patch-aa) = e2d7d0e8ccbe5db276fb736d22682bb8f719eb98
SHA1 (patch-ab) = f089af56a969af630e2cb886aa8fb40be055eca7
SHA1 (patch-ac) = 7dbddcf81e9ad6ff00dadd8a93cf2c160992ce75
SHA1 (patch-ad) = fe53fc7178c9376c6858d6d1531585f03bd98ddf
SHA1 (patch-ae) = 2186095dee7aafeca9b1933cc657fa07b775fb1e

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ad,v 1.1 2003/08/03 01:01:33 seb Exp $
--- src/Makefile.am.orig 2000-07-06 10:00:19.000000000 +0000
+++ src/Makefile.am
@@ -88,15 +88,5 @@ else
sigblock.o: $(pinfo_SIGBLOCK)
endif
-install-data-local:
- if [ ! -f $(DESTDIR)$(sysconfdir)/pinforc ] ; then \
- if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
- $(INSTALL) -d $(DESTDIR)$(sysconfdir); \
- fi; \
- $(INSTALL) -m 644 $(srcdir)/pinforc $(DESTDIR)$(sysconfdir) ; \
- else \
- echo "WARNING! Old pinforc detected. I'm not installing the new file"; \
- fi
-
EXTRA_DIST = $(pinfo_READLINE) $(pinfo_SNPRINTF) $(pinfo_SIGBLOCK)

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ae,v 1.1 2003/08/03 01:01:33 seb Exp $
--- src/Makefile.in.orig 2000-10-05 22:42:37.000000000 +0000
+++ src/Makefile.in
@@ -334,14 +334,6 @@ maintainer-clean-generic clean mostlycle
@HAVE_SIGBLOCK_FALSE@sigblock.o: $(pinfo_SIGBLOCK)
install-data-local:
- if [ ! -f $(DESTDIR)$(sysconfdir)/pinforc ] ; then \
- if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
- $(INSTALL) -d $(DESTDIR)$(sysconfdir); \
- fi; \
- $(INSTALL) -m 644 $(srcdir)/pinforc $(DESTDIR)$(sysconfdir) ; \
- else \
- echo "WARNING! Old pinforc detected. I'm not installing the new file"; \
- fi
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.