* Work around the compilation problem on XFree86 4.2. Suggested by Marc

Espie <espie@nerim.net> in tech-pkg@netbsd.org.
* Honor USE_IMAKE.
* Prepend DESTDIR to /var/dict. (No meaning for now?)

Bump PKGREVISION.
This commit is contained in:
uebayasi 2002-04-02 16:29:22 +00:00
parent 05e2a2302f
commit aba743c9f9
3 changed files with 42 additions and 22 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.7 2001/02/16 15:25:11 wiz Exp $
# $NetBSD: Makefile,v 1.8 2002/04/02 16:29:22 uebayasi Exp $
#
DISTNAME= Canna35b2
PKGNAME= Canna-lib-3.5b2
PKGREVISION= 1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.nec.co.jp/pub/Canna/Canna35/
@ -17,6 +18,7 @@ COMMENT= Kana-Kanji conversion system (library)
INSTALL_TARGET= install install.man
USE_IMAKE= # defined
BUILD_DEFS+= USE_INET6
.include "../../mk/bsd.prefs.mk"
@ -27,7 +29,7 @@ INET6= # empty
.endif
CANNAOWNER?= daemon
CANNAGROUP?= daemon
DICT_DIR?= /var/dict
DICT_DIR?= ${DISTDIR}/var/dict
MAKE_ENV+= CANNAOWNER=${CANNAOWNER} CANNAGROUP=${CANNAGROUP} \
DICT_DIR=${DICT_DIR} INET6=${INET6}
PLIST_SUBST= CANNAOWNER=${CANNAOWNER} \
@ -46,9 +48,6 @@ post-patch:
> ${WRKSRC}/cmd/${f}/Imakefile
.endfor
do-configure:
@(cd ${WRKSRC}; ${XMKMF})
post-configure:
@${LN} -s ${WRKSRC}/server/*.h ${WRKSRC}/include

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2001/04/21 10:13:31 wiz Exp $
$NetBSD: distinfo,v 1.3 2002/04/02 16:29:23 uebayasi Exp $
SHA1 (Canna35b2.tar.gz) = 66742205272cbc6bd91f272596381f761feac0a2
Size (Canna35b2.tar.gz) = 1333329 bytes
@ -9,7 +9,7 @@ Size (Canna35b2-unoff2.patch.gz) = 11375 bytes
SHA1 (Canna35b2-hack1.patch.gz) = 24ab2baf104ef9748f92bd5315d4100a7ee961ab
Size (Canna35b2-hack1.patch.gz) = 8384 bytes
SHA1 (patch-aa) = d74119cb2c37a3db1c5d5417c1e35362b1eac655
SHA1 (patch-ab) = 38f3ad4e022299a4dfd8d9391b1742b0d0f02a71
SHA1 (patch-ab) = b224a611de298a1c029350e1f734571f7bf657d1
SHA1 (patch-ac) = 8f910e59d71ef09434a40abde698d730ed7fc1c5
SHA1 (patch-ad) = dd2eb94e75dc4789e298aa1601280d32fbe5ec96
SHA1 (patch-ae) = e44c60ddf1e042ab5df1457b6723071c38baae02

View file

@ -1,18 +1,39 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/08/02 04:37:09 sakamoto Exp $
$NetBSD: patch-ab,v 1.2 2002/04/02 16:29:23 uebayasi Exp $
--- ./Imakefile.orig Wed Nov 27 16:01:34 1996
+++ ./Imakefile Fri Jul 30 19:17:44 1999
@@ -61,5 +61,5 @@
do \
(cd $$i ; echo "installing" "in $(CURRENT_DIR)/$$i..."; \
- $(MAKE) $(MFLAGS) DESTDIR='$(DESTDIR)' install); \
+ $(MAKE) $(MFLAGS) DESTDIR='$(DESTDIR)' install install.man); \
done
--- Imakefile.orig Wed Apr 3 01:19:05 2002
+++ Imakefile
@@ -4,7 +4,7 @@
#define IHaveSubdirs
#define PassCDebugFlags
WORLDOPTS = -k
- SUBDIRS = lib canna server cmd dic misc doc
+ SUBDIRS = lib canna cmd/forcpp cmd/kpdic dic/phono misc doc
INCLUDE = ./include/canna
AllTarget(cannaconf.h)
MakeSubdirs($(SUBDIRS))
@@ -22,7 +22,7 @@
CANNAROOT = .
SERVERDIR = server dic/phono dic/ideo
CLIENTDIR = cmd dic/phono misc
-SGSDIR = canna lib
+SGSDIR = lib canna dic/phono misc doc
@@ -69,5 +69,5 @@
do \
(cd $$i ; echo "installing" "in $(CURRENT_DIR)/$$i..."; \
- $(MAKE) $(MFLAGS) DESTDIR='$(DESTDIR)' install); \
+ $(MAKE) $(MFLAGS) DESTDIR='$(DESTDIR)' install install.man); \
done
install:: mkbindir mklibdir mkdicdir mkerrdir
instserver:: mkdicdir mkerrdir
@@ -39,7 +39,15 @@
MakeDirectoriesLong(mkerrdir, $(ErrDir), $(cannaOwner), $(cannaGroup))
#endif
-LinkFileList(includes,cannaconf.h,$(CANNAROOT)/include,..)
+/* XXX The definition of LinkFileList macro changes in XFree86 4.2.0,
+ which leads a ciritical compilation error. So we expand the macro
+ with the prior definition. */
+/* LinkFileList(includes,cannaconf.h,$(CANNAROOT)/include,..) */
+includes:: cannaconf.h
+ @for flag in ${MAKEFLAGS} ''; do \
+ case "$$flag" in *=*) ;; *[i]*) set +e;; esac; done; \
+ echo " cd" $(CANNAROOT)/include; cd $(CANNAROOT)/include && \
+ for i in cannaconf.h; do (set -x; $(RM) $$i; $(LN) ../$$i .); done
canna::
@echo ""