qiv: Update to 2.3.2
2.3.2 ======== 31.10.2017 [tw] fix: window sometimes recentered, when moved around with mouse 19.10.2017 [as] fix Makefile for cross-compiling: Make pkg-config substitutable (Debian Bug#879108) 10.10.2017 [tw] add specfile to build rpm for CentOS 07.10.2017 [tw] add option --trashbin to use trash bin instead of .qiv-trash when deleting images 06.10.2017 [as] add ability (and options) to display JPEG comments 06.10.2017 [as] more sophisticated exiftool call in qiv-command example 04.10.2017 [tw] fix inconsistent fixed-zoom behaviour 10.08.2017 [tw] Don't try to rotate if file is not an image 06.06.2017 [tw] get rid of some more XID collisions 30.05.2016 [tw] Fix occasionally erratic behaviour of qiv statusbar [tw] Fix xpm autodetection with libmagic 26.05.2016 [tw] Fix small artefacts in pictures which might happen when running remote over slow link (patch by Derek Schrock) 20.05.2016 [tw] update image after it is exposed in window mode 12.05.2016 [js/tw] fix broken "-no-filter" option libmagic filter now works on symlinks 07.11.2015 [tw] fix linking order in "make debug", did not work in some newer gcc versions 18.06.2015 [as] turn on EXIF autorotation by default 13.09.2014 [tw] Add option to sort files by modification time. (patch by Stefan Rüger) 23.04.2014 [tw] In case of "watch" option, check image only every 1/10 sec, instead of every 200us. This was way too short for devices like RasPi etc. (Hamish) [tw] Leave jumping mode on invalid input and process input key as if it was entered in non jumping mode (Sergey Pinaev)
This commit is contained in:
parent
03f5f0c38b
commit
abc52bcca6
3 changed files with 19 additions and 93 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.63 2020/03/10 22:10:13 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.64 2020/05/16 17:58:28 nia Exp $
|
||||
|
||||
DISTNAME= qiv-2.3.1
|
||||
PKGREVISION= 11
|
||||
DISTNAME= qiv-2.3.2
|
||||
CATEGORIES= graphics x11
|
||||
MASTER_SITES= http://spiegl.de/qiv/download/
|
||||
MASTER_SITES= https://spiegl.de/qiv/download/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= snj@NetBSD.org
|
||||
|
@ -13,9 +12,20 @@ LICENSE= gnu-gpl-v2
|
|||
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
MAKE_FLAGS+= PREFIX=${PREFIX}
|
||||
MAKE_FLAGS+= CFLAGS=${CFLAGS:Q}
|
||||
|
||||
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 share/examples/qiv share/pixmaps
|
||||
INSTALLATION_DIRS+= share/applications
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/qiv ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/qiv.1 ${DESTDIR}${PREFIX}/man/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/qiv.png ${DESTDIR}${PREFIX}/share/pixmaps
|
||||
${INSTALL_DATA} ${WRKSRC}/qiv.desktop ${DESTDIR}${PREFIX}/share/applications
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/contrib/qiv-command.example \
|
||||
${DESTDIR}${PREFIX}/share/examples/qiv
|
||||
|
||||
.include "../../devel/libgetopt/buildlink3.mk"
|
||||
.include "../../graphics/imlib2/buildlink3.mk"
|
||||
.include "../../graphics/lcms2/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.12 2015/11/03 21:34:18 agc Exp $
|
||||
$NetBSD: distinfo,v 1.13 2020/05/16 17:58:28 nia Exp $
|
||||
|
||||
SHA1 (qiv-2.3.1.tgz) = 8f8455951047ed41c773b9214375d02f7acaf814
|
||||
RMD160 (qiv-2.3.1.tgz) = 04a128a3eb96f68c2465e457ab661e0d2d1be8c0
|
||||
SHA512 (qiv-2.3.1.tgz) = 5a9b8ac082c78071c903e2f10a98effc412c0b6b940437b6592077978de03b5c7b6192e4d696f0389c12e99e0d3b5ca40c3be54ca2dfa5439121af2415f32812
|
||||
Size (qiv-2.3.1.tgz) = 130621 bytes
|
||||
SHA1 (patch-aa) = e48c7997153dfc41e7b63f738d65762635f42ba6
|
||||
SHA1 (qiv-2.3.2.tgz) = 3fe6a696f97466834705bfe9091ecc5a4c1e338c
|
||||
RMD160 (qiv-2.3.2.tgz) = 0ebbe5b6dfa64f363595c3f6da6071134fc5a8d3
|
||||
SHA512 (qiv-2.3.2.tgz) = c4636591f79e8e4c13807433a4101a461e614439e497a5637b958bd9d0937b04515854483d4060d9b1004d6c6060b437d634fdbe491eb0747a660ba65240472d
|
||||
Size (qiv-2.3.2.tgz) = 133614 bytes
|
||||
|
|
|
@ -1,83 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.9 2014/10/10 20:57:32 snj Exp $
|
||||
|
||||
Override hardcoded paths/flags.
|
||||
|
||||
--- Makefile.orig 2013-12-19 16:50:37.000000000 -0800
|
||||
+++ Makefile 2014-10-10 12:42:15.000000000 -0700
|
||||
@@ -4,7 +4,7 @@
|
||||
#######################################################################
|
||||
|
||||
# Directory where qiv will be installed under.
|
||||
-PREFIX = /usr/local
|
||||
+#PREFIX = /usr/local
|
||||
|
||||
# Font to use for statusbar in fullscreen mode
|
||||
STATUSBAR_FONT = "Monospace 9"
|
||||
@@ -49,15 +49,6 @@ EXIF = -DHAVE_EXIF
|
||||
# Do not edit below here!
|
||||
######################################################################
|
||||
|
||||
-CC = gcc
|
||||
-#CFLAGS = -O0 -g -Wall
|
||||
-CFLAGS = -O2 -Wall \
|
||||
- -fcaller-saves -ffast-math -fno-strength-reduce \
|
||||
- -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
|
||||
-#CFLAGS = -O2 -Wall -fomit-frame-pointer -finline-functions \
|
||||
-# -fcaller-saves -ffast-math -fno-strength-reduce \
|
||||
-# -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
|
||||
-
|
||||
INCLUDES := $(shell pkg-config --cflags gdk-2.0 imlib2)
|
||||
LIBS := $(shell pkg-config --libs gdk-2.0 imlib2) -lX11 -lXext
|
||||
|
||||
@@ -110,10 +101,10 @@ DEFINES_G = $(DEFINES) -DDEBUG
|
||||
all: $(PROGRAM)
|
||||
|
||||
$(PROGRAM): $(OBJS)
|
||||
- $(CC) $(CFLAGS) $(DEFINES) $(OBJS) $(LIBS) -o $(PROGRAM)
|
||||
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(DEFINES) $(LDFLAGS) $(OBJS) $(LIBS) -o $(PROGRAM)
|
||||
|
||||
$(OBJS): %.o: %.c $(HEADERS)
|
||||
- $(CC) -c $(CFLAGS) $(DEFINES) $(INCLUDES) $< -o $@
|
||||
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFINES) $(INCLUDES) $< -o $@
|
||||
|
||||
main.o: main.h
|
||||
|
||||
@@ -137,32 +128,11 @@ distclean : clean
|
||||
rm -f $(PROGRAM) $(PROGRAM_G)
|
||||
|
||||
install: $(PROGRAM)
|
||||
- @echo "Installing QIV..."
|
||||
- @if [ ! -e $(PREFIX)/bin ]; then \
|
||||
- install -d -m 0755 $(PREFIX)/bin; \
|
||||
- echo install -d -m 0755 $(PREFIX)/bin; \
|
||||
- fi
|
||||
- install -s -m 0755 $(PROGRAM) $(PREFIX)/bin
|
||||
- @if [ ! -e $(PREFIX)/man/man1 ]; then \
|
||||
- echo install -d -m 0755 $(PREFIX)/man/man1; \
|
||||
- install -d -m 0755 $(PREFIX)/man/man1; \
|
||||
- fi
|
||||
- install -m 0644 $(PROGRAM).1 $(PREFIX)/man/man1
|
||||
- $(COMPRESS_PROG) $(PREFIX)/man/man1/$(PROGRAM).1
|
||||
- @if [ ! -e $(PREFIX)/share/pixmaps ]; then \
|
||||
- echo install -d -m 0755 $(PREFIX)/share/pixmaps; \
|
||||
- install -d -m 0755 $(PREFIX)/share/pixmaps; \
|
||||
- fi
|
||||
- install -m 0644 qiv.png $(PREFIX)/share/pixmaps/qiv.png
|
||||
- @if [ ! -e $(PREFIX)/share/applications ]; then \
|
||||
- echo install -d -m 0755 $(PREFIX)/share/applications; \
|
||||
- install -d -m 0755 $(PREFIX)/share/applications; \
|
||||
- fi
|
||||
- install -m 0644 qiv.desktop $(PREFIX)/share/applications/qiv.desktop
|
||||
- @if ./qiv -f ./intro.jpg ; \
|
||||
- then echo "-- Test Passed --" ; \
|
||||
- else echo "-- Test Failed --" ; \
|
||||
- fi
|
||||
- @echo "\nDont forget to look into the \"qiv-command\" file and install it!\n-> cp qiv-command.example $(PREFIX)/bin/qiv-command\n\n"
|
||||
+ $(BSD_INSTALL_PROGRAM) $(PROGRAM) $(DESTDIR)$(PREFIX)/bin
|
||||
+ $(BSD_INSTALL_DATA) $(PROGRAM).1 $(DESTDIR)$(PREFIX)/man/man1
|
||||
+ $(BSD_INSTALL_DATA) qiv.png $(DESTDIR)$(PREFIX)/share/pixmaps
|
||||
+ $(BSD_INSTALL_DATA) qiv.desktop $(DESTDIR)$(PREFIX)/share/applications
|
||||
+ $(BSD_INSTALL_SCRIPT) contrib/qiv-command.example \
|
||||
+ $(DESTDIR)$(PREFIX)/share/examples/qiv
|
||||
|
||||
# the end... ;-)
|
Loading…
Reference in a new issue