use portable openssh 2.9p1.
Important Changes: ================== WARNING: SSH protocol v2 is now the default protocol version use the 'Protocol' option from ssh(1) and sshd(8) if you want to change this. SSH protocol v2 implementation adds support for: HostbasedAuthentication, similar to RhostsRSA in SSH protocol v1 Rekeying (negotiate new encryption keys for the current SSH session, try ~R in interactive SSH sessions) updated DH group exchange: draft-ietf-secsh-dh-group-exchange-01.txt client option HostKeyAlgorithms server options ClientAliveInterval and ClientAliveCountMax tty mode passing general: gid swapping in sshd (fixes access to /home/group/user based directory structures) Dan Kaminsky <dankamin@cisco.com> contributed an experimental SOCKS4 proxy to the ssh client (yes, client not the server). Use 'ssh -D 1080 server' if you want to try this out. server option PrintLastLog improvements for scp > 2GB improved ListenAddress option. You can now use ListenAddress host:port improved interoperability (bug detection for older implementations) improved documentation
This commit is contained in:
parent
d0e04410c0
commit
abe4852687
3 changed files with 41 additions and 17 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.48 2001/04/30 04:16:11 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.49 2001/05/14 16:32:32 itojun Exp $
|
||||
|
||||
DISTNAME= openssh-2.5.2p2
|
||||
DISTNAME= openssh-2.9p1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://gd.tuwien.ac.at/OpenBSD/OpenSSH/portable/ \
|
||||
ftp://ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/ \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/19 15:40:35 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/05/14 16:32:33 itojun Exp $
|
||||
|
||||
SHA1 (openssh-2.5.2p2.tar.gz) = 64f1e350b435217aa55d0e97b4c7460145fd7090
|
||||
Size (openssh-2.5.2p2.tar.gz) = 610450 bytes
|
||||
SHA1 (patch-ah) = 7b84bce66a52ae46d63cdcd915eb8397916f1ecc
|
||||
SHA1 (openssh-2.9p1.tar.gz) = 445c6272b3b9f42fdec037da962d65091b3b2ddb
|
||||
Size (openssh-2.9p1.tar.gz) = 658444 bytes
|
||||
SHA1 (patch-ah) = e0d6462760888270849a18834f03a0adf6b1bccb
|
||||
|
|
|
@ -1,26 +1,44 @@
|
|||
$NetBSD: patch-ah,v 1.10 2001/02/20 16:33:14 itojun Exp $
|
||||
$NetBSD: patch-ah,v 1.11 2001/05/14 16:32:33 itojun Exp $
|
||||
|
||||
--- Makefile.in.orig Mon Feb 19 04:13:33 2001
|
||||
+++ Makefile.in Wed Feb 21 01:28:06 2001
|
||||
@@ -10,2 +10,3 @@
|
||||
--- Makefile.in.orig Fri Apr 27 09:31:08 2001
|
||||
+++ Makefile.in Tue May 15 01:25:53 2001
|
||||
@@ -8,6 +8,7 @@
|
||||
mandir=@mandir@
|
||||
mansubdir=@mansubdir@
|
||||
sysconfdir=@sysconfdir@
|
||||
+examplesdir=@prefix@/share/examples/openssh
|
||||
piddir=@piddir@
|
||||
@@ -17,3 +18,3 @@
|
||||
srcdir=@srcdir@
|
||||
top_srcdir=@top_srcdir@
|
||||
@@ -15,7 +16,7 @@
|
||||
DESTDIR=
|
||||
VPATH=@srcdir@
|
||||
SSH_PROGRAM=@bindir@/ssh
|
||||
-ASKPASS_PROGRAM=$(libexecdir)/ssh-askpass
|
||||
+ASKPASS_PROGRAM=/usr/X11R6/bin/ssh-askpass
|
||||
SFTP_SERVER=$(libexecdir)/sftp-server
|
||||
@@ -152,3 +153,3 @@
|
||||
|
||||
-install: manpages $(TARGETS) install-files host-key
|
||||
+install: manpages $(TARGETS) install-files
|
||||
PATHS= -DETCDIR=\"$(sysconfdir)\" \
|
||||
@@ -164,7 +165,7 @@
|
||||
distprep: catman-do
|
||||
autoreconf
|
||||
|
||||
@@ -161,2 +162,3 @@
|
||||
-install: $(TARGETS) install-files host-key
|
||||
+install: $(TARGETS) install-files
|
||||
|
||||
install-files:
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(bindir)
|
||||
@@ -173,6 +174,7 @@
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/$(mansubdir)1
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/$(mansubdir)8
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(libexecdir)
|
||||
+ $(srcdir)/mkinstalldirs $(DESTDIR)$(examplesdir)
|
||||
$(INSTALL) -m $(SSH_MODE) -s ssh $(DESTDIR)$(bindir)/ssh
|
||||
@@ -187,19 +189,7 @@
|
||||
$(INSTALL) -m 0755 -s scp $(DESTDIR)$(bindir)/scp
|
||||
$(INSTALL) -m 0755 -s ssh-add $(DESTDIR)$(bindir)/ssh-add
|
||||
@@ -199,23 +201,11 @@
|
||||
if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir); \
|
||||
fi
|
||||
- if [ ! -f $(DESTDIR)$(sysconfdir)/ssh_config ]; then \
|
||||
- $(INSTALL) -m 644 ssh_config.out $(DESTDIR)$(sysconfdir)/ssh_config; \
|
||||
|
@ -43,7 +61,11 @@ $NetBSD: patch-ah,v 1.10 2001/02/20 16:33:14 itojun Exp $
|
|||
- fi ; \
|
||||
+ $(INSTALL) -m 644 ssh_prng_cmds.out $(DESTDIR)$(examplesdir)/ssh_prng_cmds; \
|
||||
fi
|
||||
@@ -236,6 +226,6 @@
|
||||
if [ ! -f $(DESTDIR)$(sysconfdir)/primes ]; then \
|
||||
$(INSTALL) -m 644 primes.out $(DESTDIR)$(sysconfdir)/primes; \
|
||||
@@ -248,10 +238,10 @@
|
||||
./ssh-keygen -t rsa -f $(DESTDIR)$(sysconfdir)/ssh_host_rsa_key -N ""
|
||||
|
||||
uninstallall: uninstall
|
||||
- -rm -f $(DESTDIR)$(sysconfdir)/ssh_config
|
||||
- -rm -f $(DESTDIR)$(sysconfdir)/sshd_config
|
||||
|
@ -54,3 +76,5 @@ $NetBSD: patch-ah,v 1.10 2001/02/20 16:33:14 itojun Exp $
|
|||
+ -rm -f $(DESTDIR)$(examplesdir)/ssh_prng_cmds
|
||||
+ -rmdir $(DESTDIR)$(examplesdir)
|
||||
-rmdir $(DESTDIR)$(bindir)
|
||||
-rmdir $(DESTDIR)$(sbindir)
|
||||
-rmdir $(DESTDIR)$(mandir)/$(mansubdir)1
|
||||
|
|
Loading…
Reference in a new issue