Update lablgtk to 1.2.6:

* fixed a problem of SpinButton.get_value_as_int for the case of
    the value is minus' src/gtkEdit.ml (Jun Furuse)
  * ocamllex is abstracted by CAMLLEX in Makefiles (Jun Furuse)
  * more parametrizations in config.make.nt (Jun)
  * added the selection method to clist. (Jun)
  * Glib.Io.add_watch returns event source, so that we can remove it later (J)
  * added Glib.Io.read (J)
  * added a new module Gdk.Input (J)
  * various improvements to GtkText (Antoine Mine)
  * fix Glib.IO (Henri Dubois-Ferriere)
  * fixes in ml_gdk.c: win32 and ClientData
  * GtkThread.main switches GtkMain.Main.main to call GtkThread.thread_main
  * added GList.clist#get_row_state and GWindow.file_selection#file_list
    (by Francois Pessaux)
  * added META (by Stefano Zacchiroli)
  * fixed applications/camlirc (Tim Freeman)
  * add gdk_property_*
  * fix GdkPixbuf.create_pixmap
  * add GdkEventClient (requested by Didier le Botlan)
  * add Gdk.Window.get_pointer_location (Tim Freeman)
This commit is contained in:
wiz 2004-03-04 16:13:35 +00:00
parent ee9e3c8abf
commit ac10c147b4
5 changed files with 41 additions and 14 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES,v 1.5087 2004/03/04 15:57:16 minskim Exp $
$NetBSD: CHANGES,v 1.5088 2004/03/04 16:13:35 wiz Exp $
Changes to the packages collection and infrastructure in 2004:
@ -1152,3 +1152,4 @@ Changes to the packages collection and infrastructure in 2004:
Added milter-greylist-0.9.tgz [manu 2004-03-04]
Added torrentutils-0.3.0 [wiz 2004-03-04]
Updated py-bsddb3 to 4.2.4 [minskim 2004-03-04]
Updated lablgtk to 1.2.6 [wiz 2004-03-04]

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.9 2004/01/24 15:30:33 grant Exp $
# $NetBSD: Makefile,v 1.10 2004/03/04 16:13:35 wiz Exp $
DISTNAME= lablgtk-1.2.5
PKGREVISION= 3
DISTNAME= lablgtk-1.2.6
CATEGORIES= x11
MASTER_SITES= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/
@ -9,7 +8,7 @@ MAINTAINER= dillo@NetBSD.org
HOMEPAGE= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html
COMMENT= GTK+ bindings for ocaml
USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
USE_GNU_TOOLS+= make
.include "../../mk/bsd.prefs.mk"
@ -39,6 +38,6 @@ post-build:
opt
.endif
.include "../../x11/gtk/buildlink2.mk"
.include "../../lang/ocaml/buildlink2.mk"
.include "../../x11/gtk/buildlink3.mk"
.include "../../lang/ocaml/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

25
x11/lablgtk/buildlink3.mk Normal file
View file

@ -0,0 +1,25 @@
# $NetBSD: buildlink3.mk,v 1.1 2004/03/04 16:13:35 wiz Exp $
#
# This Makefile fragment is included by packages that use lablgtk.
#
# This file was created automatically using createbuildlink-3.1.
#
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
LABLGTK_BUILDLINK3_MK:= ${LABLGTK_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= lablgtk
.endif
.if !empty(LABLGTK_BUILDLINK3_MK:M+)
BUILDLINK_PACKAGES+= lablgtk
BUILDLINK_DEPENDS.lablgtk+= lablgtk>=1.2.5nb3
BUILDLINK_PKGSRCDIR.lablgtk?= ../../x11/lablgtk
.include "../../x11/gtk/buildlink3.mk"
.include "../../lang/ocaml/buildlink3.mk"
.endif # LABLGTK_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2003/01/19 10:59:01 salo Exp $
$NetBSD: distinfo,v 1.3 2004/03/04 16:13:35 wiz Exp $
SHA1 (lablgtk-1.2.5.tar.gz) = 3ae950864d2772c60cc1d4962e52cb22c2abac97
Size (lablgtk-1.2.5.tar.gz) = 463565 bytes
SHA1 (patch-aa) = 50a1780cd9f40ff552715c13e49a876d1adb4b5f
SHA1 (lablgtk-1.2.6.tar.gz) = a70bffb0756fcbf464f0cb5e9eb87a8f9580f43f
Size (lablgtk-1.2.6.tar.gz) = 480949 bytes
SHA1 (patch-aa) = 0fcec0178fdb2bbfbe7b69f892823da820b2833f

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.2 2003/01/19 10:59:02 salo Exp $
$NetBSD: patch-aa,v 1.3 2004/03/04 16:13:36 wiz Exp $
--- src/Makefile.orig Fri Aug 9 02:27:19 2002
--- src/Makefile.orig Thu May 15 16:17:53 2003
+++ src/Makefile
@@ -136,31 +136,38 @@ testcc: lablgladecc lablgtktop
@@ -137,32 +137,39 @@ testcc: lablgladecc lablgtktop
rm -f testcc.ml
install:
@ -27,7 +27,9 @@ $NetBSD: patch-aa,v 1.2 2003/01/19 10:59:02 salo Exp $
+ ${BSD_INSTALL_SCRIPT} varcc $(INSTALLDIR)
+ if test -f lablgtktop_t; then ${BSD_INSTALL_PROGRAM} lablgtktop_t $(INSTALLDIR); fi
if test -f lablgtk.cmxa; then $(MAKE) installopt; fi
+ ${BSD_INSTALL_DATA_DIR} $(DLLDIR)
if test -f dlllablgtk.so; then \
- if test -d $(DLLDIR); then : ; else mkdir -p $(DLLDIR); fi; \
- cp $(CLIBS:lib%.a=dll%.so) $(DLLDIR) || \
- echo "Couldn't install dlls in default location"; \
+ for F in $(CLIBS:lib%.a=dll%.so); \