Fix a build problem with the new toolchain, where you would get:

mysqld.cc:2268: implicit declaration of function `int select(...)'
Patch from Christoph Badura.
This commit is contained in:
veego 2001-10-08 17:28:12 +00:00
parent 3523c99beb
commit ac26155df6
2 changed files with 19 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.7 2001/10/08 17:24:15 veego Exp $
$NetBSD: distinfo,v 1.8 2001/10/08 17:28:12 veego Exp $
SHA1 (mysql-3.23.43.tar.gz) = ebae00aeac2b301ebaf9a919c070a0005d4b1ac3
Size (mysql-3.23.43.tar.gz) = 11777006 bytes
SHA1 (patch-aa) = 05c56d81e17893dd267fcd5f68d8c378f024a06f
SHA1 (patch-ae) = 3df96ba682364349ae1d955328da76cc59810b1b
SHA1 (patch-af) = 5492aad46ff87863856ae459f8237f2bf8722ce4
SHA1 (patch-ah) = 7cd4278c9bdc5220de04f7e6b62bb8d11c892ffb

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ah,v 1.7 2001/10/08 17:28:13 veego Exp $
--- mit-pthreads/include/unistd.h-orig Wed Oct 3 18:08:36 2001
+++ mit-pthreads/include/unistd.h Mon Oct 8 08:15:37 2001
@@ -177,6 +177,12 @@
void usleep __P_((unsigned));
int vfork __P_((void));
+/* FIXME: this should go to <sys/time.h>! */
+#if __STDC__
+struct timeval; /* select(2) XXX */
+#endif
+int select __P((int, fd_set *, fd_set *, fd_set *, struct timeval *));
+
#endif /* !_POSIX_SOURCE */
__END_DECLS