Add missing tools 'msgmerge xgettext' and missing dependencies 'gmp mpfr'.
Resolve build warning in getopt.c for SunOS and make sure all the tests pass with a fix to 'readdir' test invocation.
This commit is contained in:
parent
324338f59f
commit
ac555c26d7
4 changed files with 42 additions and 3 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.57 2013/10/19 19:47:39 bsiegert Exp $
|
||||
# $NetBSD: Makefile,v 1.58 2013/12/15 09:42:14 richard Exp $
|
||||
|
||||
DISTNAME= gawk-4.1.0
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gawk/}
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
@ -16,7 +17,7 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= msgfmt
|
||||
USE_TOOLS+= msgfmt msgmerge xgettext
|
||||
GNU_CONFIGURE= yes
|
||||
TEST_TARGET= check
|
||||
INFO_FILES= yes
|
||||
|
@ -48,4 +49,6 @@ post-install:
|
|||
BUILDLINK_API_DEPENDS.gettext+= gettext-lib>=0.10.36
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/gmp/buildlink3.mk"
|
||||
.include "../../math/mpfr/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.25 2013/10/19 19:47:39 bsiegert Exp $
|
||||
$NetBSD: distinfo,v 1.26 2013/12/15 09:42:14 richard Exp $
|
||||
|
||||
SHA1 (gawk-4.1.0.tar.xz) = caabca3c1a59d05807c826c45a4639b82cad612a
|
||||
RMD160 (gawk-4.1.0.tar.xz) = 71267e56aabed02ecc77f26661171a7b626dc71d
|
||||
Size (gawk-4.1.0.tar.xz) = 2049080 bytes
|
||||
SHA1 (patch-Makefile.in) = 12eb8f205fa224634b9f5122cfca55803382516f
|
||||
SHA1 (patch-extension_configure) = f53c897d1931a139a0bdaad69234a7530db6c838
|
||||
SHA1 (patch-getopt.c) = ec519d4276fab67b350cb934b2a9959e1dbf8a2f
|
||||
SHA1 (patch-test_Makefile.in) = 19ce59a4e72fde4901c83af9b9472b9260fda228
|
||||
|
|
15
lang/gawk/patches/patch-getopt.c
Normal file
15
lang/gawk/patches/patch-getopt.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-getopt.c,v 1.1 2013/12/15 09:42:14 richard Exp $
|
||||
|
||||
SunOS needs stdlib.h for malloc/free used in p_getopt_internal_r
|
||||
|
||||
--- getopt.c.orig 2013-05-02 19:51:30.000000000 +0000
|
||||
+++ getopt.c
|
||||
@@ -57,7 +57,7 @@
|
||||
|
||||
/* This needs to come after some library #include
|
||||
to get __GNU_LIBRARY__ defined. */
|
||||
-#if defined (__GNU_LIBRARY__) || defined (__CYGWIN__) || defined(__DJGPP__)
|
||||
+#if defined (__GNU_LIBRARY__) || defined (__CYGWIN__) || defined(__DJGPP__) || defined(__sun)
|
||||
/* Don't include stdlib.h for
|
||||
* non-GNU C libraries
|
||||
* non-Cygwin
|
19
lang/gawk/patches/patch-test_Makefile.in
Normal file
19
lang/gawk/patches/patch-test_Makefile.in
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-test_Makefile.in,v 1.1 2013/12/15 09:42:14 richard Exp $
|
||||
|
||||
Non portable '-f' flag for ls should be -U for unsorted
|
||||
pkgsrc replacement links mean -L should be used too.
|
||||
|
||||
NB on SunOS, locale/en should be installed in order to have
|
||||
all tests successfully execute (namely mbfw1 and mbprintf1)
|
||||
|
||||
--- test/Makefile.in.orig 2013-12-15 08:43:50.258867212 +0000
|
||||
+++ test/Makefile.in
|
||||
@@ -2156,7 +2156,7 @@ readdir:
|
||||
fi
|
||||
@echo $@
|
||||
@$(AWK) -f $(srcdir)/readdir.awk $(top_srcdir) > _$@
|
||||
- @ls -afli $(top_srcdir) | sed 1d | $(AWK) -f $(srcdir)/readdir0.awk -v extout=_$@ > $@.ok
|
||||
+ @ls -aliUL $(top_srcdir) | sed 1d | $(AWK) -f $(srcdir)/readdir0.awk -v extout=_$@ > $@.ok
|
||||
@-$(CMP) $@.ok _$@ && rm -f $@.ok _$@
|
||||
|
||||
fts:
|
Loading…
Reference in a new issue