Trivial fix for GCC3.

This commit is contained in:
mycroft 2003-09-30 09:36:27 +00:00
parent b67552af4c
commit ac5f504f17
2 changed files with 15 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.8 2003/05/09 15:21:29 drochner Exp $
$NetBSD: distinfo,v 1.9 2003/09/30 09:36:27 mycroft Exp $
SHA1 (dia-0.91.tar.gz) = 4514af1f5685e45480761c6f42e5ecdc2492cd2c
Size (dia-0.91.tar.gz) = 3409320 bytes
SHA1 (patch-bc) = 0b868e0b6c1d156eebfffce4c35a003db8e40613
SHA1 (patch-bd) = c79dffdce3e7b65c1d10e11480f81b76f56a8066

View file

@ -0,0 +1,13 @@
$NetBSD: patch-bd,v 1.1 2003/09/30 09:36:27 mycroft Exp $
--- plug-ins/python/pydia-geometry.c.orig 2003-01-19 16:38:22.000000000 +0000
+++ plug-ins/python/pydia-geometry.c 2003-09-30 09:30:54.000000000 +0000
@@ -211,7 +211,7 @@
{
#define I_OR_F(v) \
(self->is_int ? \
- PyInt_FromLong(self->r.ri.##v) : PyFloat_FromDouble(self->r.rf.##v))
+ PyInt_FromLong(self->r.ri.v) : PyFloat_FromDouble(self->r.rf.v))
if (!strcmp(attr, "__members__"))
return Py_BuildValue("[ssss]", "top", "left", "right", "bottom" );